You are not logged in.

#1 2010-02-13 15:24:16

eldarion
Member
From: Santarém - Portugal
Registered: 2006-08-01
Posts: 71

[SOLVED] Slow "magic lamp" and "minimize" animations on KDE 4.4

So after updating to KDE 4.4 i noticed that the "magic lamp" and "minimize" animations were slower on my machine (with Nvidia GeForce 7900, proprietary module).

After searching what was going out, i found out the reason: the "fade in/fade out" title animation of the new oxygen kwin style. I searched for a way to turn it off on the configuration dialog without success.

So, what i did was to edit ~/.kde4/share/config/oxygenrc and add the line:

AnimationsDuration=0

inside the

[Windeco]

section. Now the fade effect is immediate and so it will not interfere with the "magic lamp" and "minimize" animations. Please note that it's recommended that you change the kwin style before making the changes inside oxygenrc. Then change your windeco to "oxygen" again.

I hope this will be helpful to someone.

Last edited by eldarion (2010-02-13 15:32:00)

Offline

#2 2010-02-14 14:59:56

ls6678
Member
Registered: 2009-02-17
Posts: 34

Re: [SOLVED] Slow "magic lamp" and "minimize" animations on KDE 4.4

Awesome, worked like a charm. big_smile

Offline

#3 2010-02-14 16:22:56

hash
Member
From: Poland
Registered: 2008-07-31
Posts: 109

Re: [SOLVED] Slow "magic lamp" and "minimize" animations on KDE 4.4

Thanks a lot, that did the trick!

Offline

#4 2010-02-14 20:26:13

Zerg2000
Member
From: Poland
Registered: 2008-03-30
Posts: 10

Re: [SOLVED] Slow "magic lamp" and "minimize" animations on KDE 4.4

Thank You! Did You report it to KDE team?


E-mail: zerg2000 (a) astral org pl
Jabber: zerg2000@jabber.astral.org.pl

Offline

#5 2010-02-14 21:41:23

eldarion
Member
From: Santarém - Portugal
Registered: 2006-08-01
Posts: 71

Re: [SOLVED] Slow "magic lamp" and "minimize" animations on KDE 4.4

I'm glad i was helpful.

Zerg2000 wrote:

Thank You! Did You report it to KDE team?

No i didn't. I'm not sure if this is a bug. Anyway, they should at least add an option to turn this thing off.

Offline

#6 2010-02-21 13:52:48

kokoko3k
Member
Registered: 2008-11-14
Posts: 1,631

Re: [SOLVED] Slow "magic lamp" and "minimize" animations on KDE 4.4

I agree, nitrogen style does.

Offline

Board footer

Powered by FluxBB