You are not logged in.

#1 2010-02-24 17:43:16

From: Poland
Registered: 2009-06-22
Posts: 166

Wierd file associations in Firefox

Hi. I had lots of problems before with regular firefox, so I decided I'd give 'firefox-kde-opensuse' from AUR a shot. And while it's definitely better in terms of KDE intergaton, there still persists a rather funny bug.

The problem is that with some files (not every one of them seems to suffer from this, mind you) when I click the link and select "Open With:" there is already an appropriate program chosen, like Wine for .exe files. But when I click OK and the file finishes its download,  I get a prompt from KMozillaHelper asking which program to use. I tried writing wine, selecting "Bind this program to this filetype" etc. and still the same window appears every time I try to open .exe file. It happens quite often, actually, not only with .exe files. So, for example, I can try to open RTF file and it says "Open with: OpenOffice Writer", I click OK, and then KMozillaHelper asks me what program should be used to open this RTF file. What's funny, is that when I click the radio button to "Save" and then double-click the file in the Downloads window, it opens with the associated program with ease.

But, for example, I tried googling "offer filetype:rtf" and when I click a link in Google (seems to work that way with every rtf document I found), it immediately starts to download and opens in OpenOffice. But when someone sends me .rtf as an email attachment, for example, this "Open With:" problem starts to appear once again.

Please, can you help me? ;( I also had the same problem with regular Firefox, I have no idea what's going on.

Last edited by warnec (2010-02-24 21:29:15)


Board footer

Powered by FluxBB