You are not logged in.

#1 2010-03-01 10:03:18

el_cammello
Member
From: Italy
Registered: 2009-03-20
Posts: 70
Website

nvidia libglx.so Segmentation fault

After pacman -Syu,

X.Org X Server 1.7.5
Release Date: 2010-02-16
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.32-ARCH x86_64 
Current Operating System: Linux stazione2 2.6.32-ARCH #1 SMP PREEMPT Tue Feb 23 19:43:46 CET 2010 x86_64
Kernel command line: root=/dev/sda5 ro checkdisk quiet vga=795
Build Date: 17 February 2010  07:57:38PM
 
Current version of pixman: 0.16.6
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Mar  1 10:54:51 2010
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "X.org Configured"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "Monitor0"
(**) |   |-->Device "Card0"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(==) Automatically adding devices
(==) Automatically enabling devices
(**) FontPath set to:
    /usr/share/fonts/misc,
    /usr/share/fonts/100dpi:unscaled,
    /usr/share/fonts/75dpi:unscaled,
    /usr/share/fonts/TTF,
    /usr/share/fonts/Type1,
    /usr/share/fonts/misc,
    /usr/share/fonts/100dpi:unscaled,
    /usr/share/fonts/75dpi:unscaled,
    /usr/share/fonts/TTF,
    /usr/share/fonts/Type1
(**) ModulePath set to "/usr/lib/xorg/modules"
(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
(WW) Disabling Mouse0
(WW) Disabling Keyboard0
(II) Loader magic: 0x7c0fa0
(II) Module ABI versions:
    X.Org ANSI C Emulation: 0.4
    X.Org Video Driver: 6.0
    X.Org XInput driver : 7.0
    X.Org Server Extension : 2.0
(--) using VT number 7

(--) PCI:*(0:0:5:0) 10de:0240:1043:81cd nVidia Corporation C51PV [GeForce 6150] rev 162, Mem @ 0xfc000000/16777216, 0xd0000000/268435456, 0xfb000000/16777216, BIOS @ 0x????????/131072
(II) Open ACPI successful (/var/run/acpid.socket)
(II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
(II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
(II) "glx" will be loaded by default.
(II) "dri" will be loaded. This was enabled by default and also specified in the config file.
(II) "dri2" will be loaded. This was enabled by default and also specified in the config file.
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
    compiled for 1.7.5, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
    compiled for 1.7.5, module version = 1.1.0
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions/libdri.so
(II) Module dri: vendor="X.Org Foundation"
    compiled for 1.7.5, module version = 1.0.0
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
    compiled for 1.7.5, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
    compiled for 4.0.2, module version = 1.0.0
    Module class: X.Org Server Extension
(II) NVIDIA GLX Module  195.36.08  Thu Feb 25 04:50:39 PST 2010
(II) Loading extension GLX
(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
    compiled for 4.0.2, module version = 1.0.0
    Module class: X.Org Video Driver
(II) NVIDIA dlloader X Driver  195.36.08  Thu Feb 25 04:18:36 PST 2010
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 00@00:05:0
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules/libfb.so
(II) Module fb: vendor="X.Org Foundation"
    compiled for 1.7.5, module version = 1.0.0
    ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "wfb"
(II) LoadModule: "wfb"
(II) Loading /usr/lib/xorg/modules/libwfb.so
(II) Module wfb: vendor="X.Org Foundation"
    compiled for 1.7.5, module version = 1.0.0
    ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Module "ramdac" already built-in
(==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) Mar 01 10:54:51 NVIDIA(0): Enabling RENDER acceleration
(II) Mar 01 10:54:51 NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) Mar 01 10:54:51 NVIDIA(0):     enabled.
(II) Mar 01 10:54:52 NVIDIA(0): NVIDIA GPU GeForce 6150 (C51) at PCI:0:5:0 (GPU-0)
(--) Mar 01 10:54:52 NVIDIA(0): Memory: 524288 kBytes
(--) Mar 01 10:54:52 NVIDIA(0): VideoBIOS: 05.51.22.33.07
(--) Mar 01 10:54:52 NVIDIA(0): Interlaced video modes are supported on this GPU
(--) Mar 01 10:54:52 NVIDIA(0): Connected display device(s) on GeForce 6150 at PCI:0:5:0:
(--) Mar 01 10:54:52 NVIDIA(0):     ACI ASUS VK193 (CRT-0)
(--) Mar 01 10:54:52 NVIDIA(0): ACI ASUS VK193 (CRT-0): 350.0 MHz maximum pixel clock
(II) Mar 01 10:54:52 NVIDIA(0): Assigned Display Device: CRT-0
(==) Mar 01 10:54:52 NVIDIA(0): 
(==) Mar 01 10:54:52 NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
(==) Mar 01 10:54:52 NVIDIA(0):     will be used as the requested mode.
(==) Mar 01 10:54:52 NVIDIA(0): 
(II) Mar 01 10:54:52 NVIDIA(0): Validated modes:
(II) Mar 01 10:54:52 NVIDIA(0):     "nvidia-auto-select"
(II) Mar 01 10:54:52 NVIDIA(0): Virtual screen size determined to be 1440 x 900
(--) Mar 01 10:54:52 NVIDIA(0): DPI set to (89, 87); computed from "UseEdidDpi" X config
(--) Mar 01 10:54:52 NVIDIA(0):     option
(==) Mar 01 10:54:52 NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp
(II) Mar 01 10:54:52 NVIDIA(0): Initialized GPU GART.
(II) Mar 01 10:54:52 NVIDIA(0): Setting mode "nvidia-auto-select"
(II) Loading extension NV-GLX
(II) Mar 01 10:54:52 NVIDIA(0): Initialized OpenGL Acceleration
(==) NVIDIA(0): Disabling shared memory pixmaps
(II) Mar 01 10:54:52 NVIDIA(0): Initialized X Rendering Acceleration
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(==) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(II) Loading extension XINERAMA
(==) RandR enabled
(II) Initializing built-in extension Generic Event Extension
(II) Initializing built-in extension SHAPE
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension BIG-REQUESTS
(II) Initializing built-in extension SYNC
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-MISC
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing extension GLX

Backtrace:
0: /usr/bin/X (xorg_backtrace+0x28) [0x45a8d8]
1: /usr/bin/X (0x400000+0x61a19) [0x461a19]
2: /lib/libpthread.so.0 (0x7fb3ef762000+0xee80) [0x7fb3ef770e80]
3: /lib/libc.so.6 (_IO_vfprintf+0x409e) [0x7fb3eea34cae]
4: /lib/libc.so.6 (vsnprintf+0xa2) [0x7fb3eea5a572]
5: /usr/bin/X (LogVWrite+0x7f) [0x456b8f]
6: /usr/bin/X (LogVMessageVerb+0x64) [0x4571e4]
7: /usr/bin/X (xf86Msg+0x97) [0x4f3107]
8: /usr/lib/xorg/modules/extensions/libglx.so (0x7fb3ed1fd000+0x288b6f) [0x7fb3ed485b6f]
Segmentation fault at address 0x1

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting


Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

sad


Sorry for my bad english :-)

Offline

#2 2010-03-01 14:04:01

Kaemon
Member
Registered: 2010-03-01
Posts: 2

Re: nvidia libglx.so Segmentation fault

Same here

X.Org X Server 1.7.5
Release Date: 2010-02-16
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.32-ARCH x86_64 
Current Operating System: Linux solsys 2.6.32-ARCH #1 SMP PREEMPT Tue Feb 23 19:43:46 CET 2010 x86_64
Kernel command line: root=/dev/sda6
Build Date: 17 February 2010  07:57:38PM
 
Current version of pixman: 0.16.6
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Mar  1 14:57:52 2010
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "X.org Configured"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "Monitor0"
(**) |   |-->Device "Card0"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(**) Option "DontZap" "true"
(**) Option "AllowEmptyInput" "false"
(**) Option "AutoAddDevices" "true"
(**) Automatically adding devices
(==) Automatically enabling devices
(**) FontPath set to:
    /usr/share/fonts/misc,
    /usr/share/fonts/100dpi:unscaled,
    /usr/share/fonts/75dpi:unscaled,
    /usr/share/fonts/TTF,
    /usr/share/fonts/Type1,
    /usr/share/fonts/misc,
    /usr/share/fonts/100dpi:unscaled,
    /usr/share/fonts/75dpi:unscaled,
    /usr/share/fonts/TTF,
    /usr/share/fonts/Type1
(**) ModulePath set to "/usr/lib/xorg/modules"
(II) Loader magic: 0x7c0fa0
(II) Module ABI versions:
    X.Org ANSI C Emulation: 0.4
    X.Org Video Driver: 6.0
    X.Org XInput driver : 7.0
    X.Org Server Extension : 2.0
(++) using VT number 7

(--) PCI:*(0:1:0:0) 10de:0611:1043:8267 nVidia Corporation G92 [GeForce 8800 GT] rev 162, Mem @ 0xfd000000/16777216, 0xd0000000/268435456, 0xfa000000/33554432, I/O @ 0x0000cc00/128, BIOS @ 0x????????/131072
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
(II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
(II) "glx" will be loaded by default.
(II) "dri" will be loaded by default.
(II) "dri2" will be loaded by default.
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
    compiled for 1.7.5, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
    compiled for 1.7.5, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
    compiled for 4.0.2, module version = 1.0.0
    Module class: X.Org Server Extension
(II) NVIDIA GLX Module  195.36.08  Thu Feb 25 04:50:39 PST 2010
(II) Loading extension GLX
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions/libdri.so
(II) Module dri: vendor="X.Org Foundation"
    compiled for 1.7.5, module version = 1.0.0
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
    compiled for 1.7.5, module version = 1.1.0
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
    compiled for 4.0.2, module version = 1.0.0
    Module class: X.Org Video Driver
(II) LoadModule: "mouse"
(WW) Warning, couldn't open module mouse
(II) UnloadModule: "mouse"
(EE) Failed to load module "mouse" (module does not exist, 0)
(II) LoadModule: "kbd"
(WW) Warning, couldn't open module kbd
(II) UnloadModule: "kbd"
(EE) Failed to load module "kbd" (module does not exist, 0)
(II) NVIDIA dlloader X Driver  195.36.08  Thu Feb 25 04:18:36 PST 2010
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 01@00:00:0
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules/libfb.so
(II) Module fb: vendor="X.Org Foundation"
    compiled for 1.7.5, module version = 1.0.0
    ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "wfb"
(II) LoadModule: "wfb"
(II) Loading /usr/lib/xorg/modules/libwfb.so
(II) Module wfb: vendor="X.Org Foundation"
    compiled for 1.7.5, module version = 1.0.0
    ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Module "ramdac" already built-in
(==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "AddARGBGLXVisuals" "True"
(**) Mar 01 14:57:52 NVIDIA(0): Enabling RENDER acceleration
(II) Mar 01 14:57:52 NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) Mar 01 14:57:52 NVIDIA(0):     enabled.
(II) Mar 01 14:57:53 NVIDIA(0): NVIDIA GPU GeForce 8800 GT (G92) at PCI:1:0:0 (GPU-0)
(--) Mar 01 14:57:53 NVIDIA(0): Memory: 524288 kBytes
(--) Mar 01 14:57:53 NVIDIA(0): VideoBIOS: 62.92.1a.00.00
(II) Mar 01 14:57:53 NVIDIA(0): Detected PCI Express Link width: 16X
(--) Mar 01 14:57:53 NVIDIA(0): Interlaced video modes are supported on this GPU
(--) Mar 01 14:57:53 NVIDIA(0): Connected display device(s) on GeForce 8800 GT at PCI:1:0:0:
(--) Mar 01 14:57:53 NVIDIA(0):     Acer AL1916 (CRT-0)
(--) Mar 01 14:57:53 NVIDIA(0):     NVIDIA TV Encoder (TV-0)
(--) Mar 01 14:57:53 NVIDIA(0): Acer AL1916 (CRT-0): 400.0 MHz maximum pixel clock
(--) Mar 01 14:57:53 NVIDIA(0): NVIDIA TV Encoder (TV-0): 400.0 MHz maximum pixel clock
(--) Mar 01 14:57:53 NVIDIA(0): TV encoder: NVIDIA
(II) Mar 01 14:57:53 NVIDIA(0): Assigned Display Device: CRT-0
(==) Mar 01 14:57:53 NVIDIA(0): 
(==) Mar 01 14:57:53 NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
(==) Mar 01 14:57:53 NVIDIA(0):     will be used as the requested mode.
(==) Mar 01 14:57:53 NVIDIA(0): 
(II) Mar 01 14:57:53 NVIDIA(0): Validated modes:
(II) Mar 01 14:57:53 NVIDIA(0):     "nvidia-auto-select"
(II) Mar 01 14:57:53 NVIDIA(0): Virtual screen size determined to be 1280 x 1024
(--) Mar 01 14:57:53 NVIDIA(0): DPI set to (85, 86); computed from "UseEdidDpi" X config
(--) Mar 01 14:57:53 NVIDIA(0):     option
(**) Mar 01 14:57:53 NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp
(II) Mar 01 14:57:53 NVIDIA: Using 768.00 MB of virtual memory for indirect framebuffer
(II) Mar 01 14:57:53 NVIDIA:     access.
(II) Mar 01 14:57:53 NVIDIA(0): Initialized GPU GART.
(II) Mar 01 14:57:53 NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
(II) Mar 01 14:57:53 NVIDIA(0):     may not be running or the "AcpidSocketPath" X
(II) Mar 01 14:57:53 NVIDIA(0):     configuration option may not be set correctly.  When the
(II) Mar 01 14:57:53 NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
(II) Mar 01 14:57:53 NVIDIA(0):     try to use it to receive ACPI event notifications.  For
(II) Mar 01 14:57:53 NVIDIA(0):     details, please see the "ConnectToAcpid" and
(II) Mar 01 14:57:53 NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
(II) Mar 01 14:57:53 NVIDIA(0):     Config Options in the README.
(II) Mar 01 14:57:53 NVIDIA(0): Setting mode "nvidia-auto-select"
(II) Loading extension NV-GLX
(II) Mar 01 14:57:53 NVIDIA(0): Initialized OpenGL Acceleration
(==) NVIDIA(0): Disabling shared memory pixmaps
(II) Mar 01 14:57:53 NVIDIA(0): Initialized X Rendering Acceleration
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(==) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(II) Loading extension XINERAMA
(==) RandR enabled
(II) Initializing built-in extension Generic Event Extension
(II) Initializing built-in extension SHAPE
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension BIG-REQUESTS
(II) Initializing built-in extension SYNC
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-MISC
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing extension GLX

Backtrace:
0: /usr/bin/X (xorg_backtrace+0x28) [0x45a8d8]
1: /usr/bin/X (0x400000+0x61a19) [0x461a19]
2: /lib/libpthread.so.0 (0x7f46600c8000+0xee80) [0x7f46600d6e80]
3: /lib/libc.so.6 (_IO_vfprintf+0x409e) [0x7f465f39acae]
4: /lib/libc.so.6 (vsnprintf+0xa2) [0x7f465f3c0572]
5: /usr/bin/X (LogVWrite+0x7f) [0x456b8f]
6: /usr/bin/X (LogVMessageVerb+0x64) [0x4571e4]
7: /usr/bin/X (xf86Msg+0x97) [0x4f3107]
8: /usr/lib/xorg/modules/extensions/libglx.so (0x7f465e17a000+0x288b6f) [0x7f465e402b6f]
Segmentation fault at address 0x1

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting


Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

edit: Caused by nvidia drivers 195. downgrade to 190 "solve" this problem.

Last edited by Kaemon (2010-03-01 14:18:56)

Offline

#3 2010-03-01 14:19:35

el_cammello
Member
From: Italy
Registered: 2009-03-20
Posts: 70
Website

Re: nvidia libglx.so Segmentation fault

I've open the bug report: http://bugs.archlinux.org/task/18512


Sorry for my bad english :-)

Offline

#4 2010-03-01 19:27:43

trapanator
Member
From: Italy
Registered: 2009-08-10
Posts: 137

Re: nvidia libglx.so Segmentation fault

same here.

Offline

#5 2010-03-01 21:04:14

no-daemon
Member
Registered: 2010-02-13
Posts: 15

Re: nvidia libglx.so Segmentation fault

This bug sounds weird;
I'm running (195.36.08) installed from upstream, on Arch-x86_64 with no (.. read no new..) issues, with a 8500 GT card.
Should be related to KDE 4.4. Check other packages that have been updated when you first saw the bug, try starting another DE.


less is a lot more!

Offline

#6 2010-03-02 03:25:42

cleanrock
Member
Registered: 2008-11-17
Posts: 108

Re: nvidia libglx.so Segmentation fault

You could try to use a default xorg.conf:
# cd /etc/X11
# mv xorg.conf xorg.conf_OLD
# nvidia-xconfig

Offline

#7 2010-03-02 18:12:07

Kaemon
Member
Registered: 2010-03-01
Posts: 2

Re: nvidia libglx.so Segmentation fault

Installing older nvidia and nvidia-utils solve this
tried more DE/WM - dont help (xfce, openbox, KDE)
new xorg.conf - dont help

My card is 8800GT

Offline

#8 2010-03-02 19:54:55

no-daemon
Member
Registered: 2010-02-13
Posts: 15

Re: nvidia libglx.so Segmentation fault

Kaemon wrote:

Installing older nvidia and nvidia-utils solve this
tried more DE/WM - dont help (xfce, openbox, KDE)
new xorg.conf - dont help

My card is 8800GT

Sorry to hear that, I saw this reported also in another distro (http://forum.mandriva.com/viewtopic.php?t=125478) and I'd hate to see this happening to me too.
Tested with the Arch package, same,  there is a conflict with both libgl or with nvidia-utils.
Funny thing, both (libgl 7.7-1 (and 7.7-2 from /testing) and nvidia-utils 195.36.08-1) work well here with the upstream driver.
Reverting to the previous driver, or installing it directly from upstream would the best things to do for the moment.

Last edited by no-daemon (2010-03-02 19:55:22)


less is a lot more!

Offline

#9 2010-03-03 17:13:57

Revelation60
Member
From: The Netherlands
Registered: 2009-03-19
Posts: 149
Website

Re: nvidia libglx.so Segmentation fault

I have the same bug. sad Reverting worked, but that of couse, does not fix the bug.

Offline

#10 2010-04-12 08:39:03

trapanator
Member
From: Italy
Registered: 2009-08-10
Posts: 137

Re: nvidia libglx.so Segmentation fault

Up this thread...

the issue is still present afther Kernel 2.6.33 upgrade.

Offline

#11 2010-04-14 01:45:53

ilkyest
Member
From: Brazil
Registered: 2010-02-13
Posts: 267

Re: nvidia libglx.so Segmentation fault

trapanator wrote:

Up this thread...

the issue is still present afther Kernel 2.6.33 upgrade.

I don't know guys if I would help in something, but, I'm having theese issues when I do things like root user with su.

I'm a overclocker, and uses it at this time, when I'm looking at a segmentation fault. But, if I do the same comand, but with kdesu <and the command> I don't take more problems like this.

It sounds so strange, but..... it's true

Offline

#12 2010-04-15 12:09:45

ihad
Member
Registered: 2010-04-15
Posts: 6

Re: nvidia libglx.so Segmentation fault

I encountered the same problem yesterday and actually solved it smile

Some time ago I manually installed the nvidia drivers from the installer provided by nvidia.com. Later I decided to go back to the arch packages. Fortunately, or rather unfortunately, both the installer and the package had the same version at that time (190.something), and everything worked fine.

After installing the 195.x.x package xorg went bust with a segmentation fault. This happened because I had 2 different versions of libnvida-tls.so, the first and correct one in /usr/lib and some cruft from the manual install in /usr/lib64. AFAICT /usr/lib64 shouldn't even be there, because no library in that directory was owned by any package.

So, check if you have nvidia-libraries in /usr/lib64. If yes, check if they belong to any package, and if not, remove then (or remove /usr/lib64 altogether). Also check for libvdpau version conflicts to make e.g. mplayer happy.

After removing all the cruft I was able to start X again.

HTH

Offline

#13 2010-04-16 03:19:22

improvviso
Member
Registered: 2010-04-16
Posts: 1

Re: nvidia libglx.so Segmentation fault

ihad, Thank You for your solution.

Removing the conflicting libnvidia files in /usr/lib64 solved the problem for me. After checking ownership of all the files in /usr/lib64, I did end up deleting the directory and have had no trouble.

Offline

#14 2010-04-16 08:38:37

ihad
Member
Registered: 2010-04-15
Posts: 6

Re: nvidia libglx.so Segmentation fault

improvviso, I'm glad I could help.

Offline

#15 2010-04-16 12:29:59

trapanator
Member
From: Italy
Registered: 2009-08-10
Posts: 137

Re: nvidia libglx.so Segmentation fault

great! Now it worked!

Offline

Board footer

Powered by FluxBB