You are not logged in.

#1 2010-03-02 05:25:05

jarryson
Member
Registered: 2007-02-18
Posts: 298

X become very unstable when enable KMS with kernel2.6.33

my card is X700 mobility (RV420 5653) CPU is AMD turion mt34 and notebook is Uniwill p50ca

i have no problem using KMS and 3D acceleration with 2.6.31.

these days i update my kernel to 2.6.33, and no matter i use mesa, ati-dri, libgl, xf86-video-ati from official or compiled by my self, i can't get my X work properly.

X server and the whole system become very unstable. many application can break the system. even xfce terminal. when i open it, the computer will reboot immediately. and other program such as opera, openoffice can cause the same problem. but seems mplayer works fine.

and if i disable KMS, the X is fine then.

any ideas?

Offline

#2 2010-03-02 06:16:24

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: X become very unstable when enable KMS with kernel2.6.33

Do you have an xorg.conf or not ? If you do, try to delete it.

Offline

#3 2010-03-02 20:34:57

belerofontr
Member
Registered: 2008-11-25
Posts: 3

Re: X become very unstable when enable KMS with kernel2.6.33

I have an R300 chip and the Xserver doesn't even start. After the last kernel message it comes a black screen, and I can't do anything but press poweroff button of my laptop. I don't have an xorg.conf.

I will have to disable KMS sad

Offline

#4 2010-03-03 02:31:58

abraxas88
Member
From: Cosenza, Italy
Registered: 2009-12-12
Posts: 87

Re: X become very unstable when enable KMS with kernel2.6.33

belerofontr wrote:

I have an R300 chip and the Xserver doesn't even start. After the last kernel message it comes a black screen, and I can't do anything but press poweroff button of my laptop. I don't have an xorg.conf.

I will have to disable KMS sad

Same here, with Ati Xpress 200M (ven 5A62)


Asus G53Jw-IX160V Intel Core i7 740M 1.73 GHz, 8 GB RAM DDR3 1333 MHz, nVidia GTX 460M 1.5 GB GDDR5. Arch Linux 64 bit, of course. wink

Offline

#5 2010-03-03 07:07:55

jarryson
Member
Registered: 2007-02-18
Posts: 298

Re: X become very unstable when enable KMS with kernel2.6.33

now i back to kernel 2.6.31 and using drivers in the official repo and everything is fine.

@flamelab, i have tried that, but not working, either

Offline

#6 2010-03-03 10:00:44

Lothium
Member
Registered: 2009-10-10
Posts: 192

Re: X become very unstable when enable KMS with kernel2.6.33

I also have an X700 Mobility and no kernel works for me with kms. Sometimes my system doesn't start and with other kernels I only see the mouse cursor and the shadows of the windows. I have no idea whats the problem, but it exists since 6 months I think.

Offline

#7 2010-03-03 12:13:17

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,837

Re: X become very unstable when enable KMS with kernel2.6.33

R300 here (Xpress 200M) working fine with 2.6.33 and KMS enabled. Make sure your system is completely up-to-date - the libdrm and xf86-video-ati packages in testing are required.

Offline

#8 2010-03-03 12:38:17

abraxas88
Member
From: Cosenza, Italy
Registered: 2009-12-12
Posts: 87

Re: X become very unstable when enable KMS with kernel2.6.33

tomk wrote:

R300 here (Xpress 200M) working fine with 2.6.33 and KMS enabled. Make sure your system is completely up-to-date - the libdrm and xf86-video-ati packages in testing are required.

My system is up-to-date indeed! Should I put radeon into modules array in mkinitcpio.conf? What about xorg.conf? Should I delete it?

Last edited by abraxas88 (2010-03-03 12:40:48)


Asus G53Jw-IX160V Intel Core i7 740M 1.73 GHz, 8 GB RAM DDR3 1333 MHz, nVidia GTX 460M 1.5 GB GDDR5. Arch Linux 64 bit, of course. wink

Offline

#9 2010-03-03 13:06:44

belerofontr
Member
Registered: 2008-11-25
Posts: 3

Re: X become very unstable when enable KMS with kernel2.6.33

My system is also up-to-date. My card is also an Ati Xpress 200M

Offline

#10 2010-03-03 14:34:30

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 3,117

Re: X become very unstable when enable KMS with kernel2.6.33

Working fine here with an R300 (X600XT) and a RV610 (Mobility(??) HD2400).


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#11 2010-03-03 14:38:12

Lothium
Member
Registered: 2009-10-10
Posts: 192

Re: X become very unstable when enable KMS with kernel2.6.33

Ok, forget what I said before... I updated my whole system to testing and erased the xorg.conf and restarted. KMS works great. No problems. But the desktop-performance is not very good. Before I had 2300 fps in glxgears (I know glxgears is not a benchmark) and now I have only around 1000 fps and the animations in KDE are a bit choppy and laggy. Hope they fix this, then I am happy with KMS and use it the whole time. Now I changed back to UMS.

Best regards!

Offline

#12 2010-03-03 15:14:57

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,837

Re: X become very unstable when enable KMS with kernel2.6.33

abraxas88 - KMS config details are covered on the ATI wiki page, and the xorg page will help you decide about your xorg.conf.

Offline

#13 2010-03-03 15:42:13

jarryson
Member
Registered: 2007-02-18
Posts: 298

Re: X become very unstable when enable KMS with kernel2.6.33

i am now using kernel 2.6.31.12 (compiled by myself) with drivers from official repo, and everything is fine.

but if i change my kernel to 2.6.33, KMS seems fine, but the desktop nearly not working. seems there is a new version of ati ddx driver just relased, hope that works.

PS: my system is up to date of course. i am using early start method to start KMS. and not every time the system can successfully load radeon module, if not ,the mathine will reboot immediately, if yes, the X wont work fine, either.

but 2.6.31 with KMS enable is very fine.

Offline

#14 2010-03-03 19:54:47

abraxas88
Member
From: Cosenza, Italy
Registered: 2009-12-12
Posts: 87

Re: X become very unstable when enable KMS with kernel2.6.33

Nothing, guys smile I've tried both early and late start, but as I log in KDE, the screen becomes black and the machine freezes.


Asus G53Jw-IX160V Intel Core i7 740M 1.73 GHz, 8 GB RAM DDR3 1333 MHz, nVidia GTX 460M 1.5 GB GDDR5. Arch Linux 64 bit, of course. wink

Offline

#15 2010-03-03 20:24:09

Lothium
Member
Registered: 2009-10-10
Posts: 192

Re: X become very unstable when enable KMS with kernel2.6.33

Ok, I use nothing from the wiki. I don't make any entries in any files. I just installed all from testing and deleted the xorg.conf- No parameter in the grub line or something. Then it uses KMS in early mode. As I said before, performance is not so good, but it works for me this way. Hope this will help anyone.

Offline

#16 2010-03-03 21:21:57

abraxas88
Member
From: Cosenza, Italy
Registered: 2009-12-12
Posts: 87

Re: X become very unstable when enable KMS with kernel2.6.33

It seems that a new ati driver has been released... let's hope it'll work now.


Asus G53Jw-IX160V Intel Core i7 740M 1.73 GHz, 8 GB RAM DDR3 1333 MHz, nVidia GTX 460M 1.5 GB GDDR5. Arch Linux 64 bit, of course. wink

Offline

#17 2010-03-04 12:31:20

abraxas88
Member
From: Cosenza, Italy
Registered: 2009-12-12
Posts: 87

Re: X become very unstable when enable KMS with kernel2.6.33

Nothing to do...


Asus G53Jw-IX160V Intel Core i7 740M 1.73 GHz, 8 GB RAM DDR3 1333 MHz, nVidia GTX 460M 1.5 GB GDDR5. Arch Linux 64 bit, of course. wink

Offline

#18 2010-03-23 16:34:21

jarryson
Member
Registered: 2007-02-18
Posts: 298

Re: X become very unstable when enable KMS with kernel2.6.33

i found a solution, it works very well:
https://bugzilla.kernel.org/show_bug.cgi?id=15287

i don't know when it could merge to main kernel tree.

Offline

#19 2010-03-24 13:20:36

abraxas88
Member
From: Cosenza, Italy
Registered: 2009-12-12
Posts: 87

Re: X become very unstable when enable KMS with kernel2.6.33

Do you mean the last patch? How do I add it to the kernel? Sorry for the question, I've never did that before.


Asus G53Jw-IX160V Intel Core i7 740M 1.73 GHz, 8 GB RAM DDR3 1333 MHz, nVidia GTX 460M 1.5 GB GDDR5. Arch Linux 64 bit, of course. wink

Offline

Board footer

Powered by FluxBB