You are not logged in.

#1 2005-01-18 22:22:30

alexmat
Member
Registered: 2004-12-31
Posts: 100

XFCE 4.2 shadows and transperancy

First off I'd like to say I'm extremely impressed with how nice everything looks and how well things work "out of the box". Thanks to Arch, xfce, and too many other great projects to mention I have completely ditched windows.

I just installed xfce 4.2 along with the recent (8.8.25) ati radeon driver. Everything is working great, but I would like to try shadows and transparency. I tried searching around but didn't find any obvious answers.

Is the pacman version of xfce 4.2 compiled with shadow and/or transparency support? If so do i need to put the setting in explicitly into my xorg.conf file? The reason I ask is this comes up in the Xorg.0.log:

(II) fglrx(0): Acceleration enabled
(II) fglrx(0): X context handle = 0x00000001
(II) fglrx(0): [DRI] installation complete
(II) fglrx(0): Direct rendering enabled
(II) Loading extension FGLRXEXTENSION
(II) Loading extension ATITVOUT
(==) RandR enabled
(II) Setting vga for screen 0.
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE

So it looks like everything is turned on already and the video card is working fine, now how do I actually activate it?

I hope it's nothing too obvious, but I'm betting it is...  lol

Offline

#2 2005-01-18 22:34:48

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: XFCE 4.2 shadows and transperancy

this is all I have found so far..
http://www.fedoraforum.org/forum/showthread.php?t=21809
http://blog.xfce.org/index.php?cat=1 (11/10/2004)
I haven't tried either of them yet though..


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#3 2005-01-18 23:37:07

mico
Member
From: Slovenia
Registered: 2004-02-08
Posts: 239

Re: XFCE 4.2 shadows and transperancy

From http://xfce.org/index.php?page=document … xcomposite

The composite extension has to be activated in you /etc/X11/xorg.conf using the following section:

Section "Extensions"
    Option "Composite" "Enable"
EndSection

Xfwm4 has to be built with the --enable-compositor configure option, since it's not enabled by default. If you installed Xfce using binaries provided for your distribution, you'll probably have to rebuild xfwm4.

I think you have to rebuild if you want transparency & shadows because there is no --enable-compositor:

 grep configure /var/abs/extra/xfce4/xfwm4/PKGBUILD
  ./configure --prefix=/opt/xfce4 

Offline

#4 2005-01-18 23:43:38

skoal
Member
From: Frequent Flyer Underworld
Registered: 2004-03-23
Posts: 612
Website

Re: XFCE 4.2 shadows and transperancy

It's pretty simple actually.  I'm running XFCE4.2 right now, with all those fancy shadows and such.

Check out this Wiki excerpt.

What's that you say?  You don't believe me?  Ahh, feast your eyes on this:

[URL=http://img25.exs.cx/my.php?loc=img25ℑ=screen12wd.png]screen13wd.th.png[/URL]

* Don't forget the "xapps" package.  You won't get a thing without it.  By the way, I don't use composite anymore.  It's been sometime since I've used it, and I just turned it back on so you could see it's possible.  It will slow things down a tad, and some windows get a little funky at times.

Offline

#5 2005-01-19 01:31:15

alexmat
Member
Registered: 2004-12-31
Posts: 100

Re: XFCE 4.2 shadows and transperancy

Thanks for the replies everyone.

Skoal: I can't believe I missed that wiki, hehe, but it did the trick. I got everything running, but it was painfully slow. Maybe someday. For now I couldn't be happier with what I already have.

mico: It looks like the composite support is built into the pacman version of xfce, I wonder why it didn't show up in the config...


Even though I can't run it, it looked amazing (as long as I didn't move my mouse around  lol

Offline

#6 2005-01-19 02:55:37

skoal
Member
From: Frequent Flyer Underworld
Registered: 2004-03-23
Posts: 612
Website

Re: XFCE 4.2 shadows and transperancy

alexmat wrote:

[...]mico: It looks like the composite support is built into the pacman version of xfce, I wonder why it didn't show up in the config...[...]

At one time, while building some of the "rc"/"beta" versions, I checked out the source and their usage of compositor didn't even seem to use the X extension.  They apparently rendered their own drop shadows and stuff.

However, it looks like they've changed that now and are using that extension.  Furthermore, I think it would be safe to build "xfwm4" with the "--enable-compositor" flag, since you can pass a command line option to "xfwm4":

--compositor=off|on|auto

I haven't rebuilt "xfwm4" or made my own custom pkg's yet to try this out, but you should be able to safely rebuild "xfwm4" with this enabled, turning it off or on (as you wish) by just passing this argument to:

"/opt/xfce4/etc/xdg/xfce4/xinitrc" or
your custom "xinitrc" (in your home directory)

If I get around to it, I'll test just that, if Aurelein hasn't already.

Offline

#7 2005-01-19 11:53:30

mico
Member
From: Slovenia
Registered: 2004-02-08
Posts: 239

Re: XFCE 4.2 shadows and transperancy

alexmat wrote:

I got everything running, but it was painfully slow.

It worked fine on my machine when I tested that yesterday (I was just curious how it all looks like, then I went back to normal xfwm4 and xorg.conf). I did exactly like I suggested in previous post, and I also added this:

Option      "RenderAccel" "true"

to Section "Device" as is suggested on the xfce page for nvidia cards:

It's known to work well with NVidia cards and NVidia drivers, especially if you add the Option "RenderAccel" "true" option in the Device section of your xorg.conf file.

If you don't have nvidia card, that could be the reason for slow running. These features are still under development and not all cards work well (yet).

Offline

#8 2005-01-19 19:37:57

alexmat
Member
Registered: 2004-12-31
Posts: 100

Re: XFCE 4.2 shadows and transperancy

If you don't have nvidia card, that could be the reason for slow running. These features are still under development and not all cards work well (yet).

Yeah I'm running an ATI Radeon Mobility 9700 (~1400fps in glxgears), however, I did not try setting the RenderAccel Option because I got the impression that it was an Nvidia only thing. Maybe I'll give it a try later today and see if it runs any smoother.

Offline

#9 2005-01-20 05:20:44

skoal
Member
From: Frequent Flyer Underworld
Registered: 2004-03-23
Posts: 612
Website

Re: XFCE 4.2 shadows and transperancy

Don't feel left out just because you're using an ATI card instead of Nvidia.  I have a fairly good one, a Ti-4600.  It tops out at around 7500 fps in "glxgears". 

However, while running the "composite" extension, windows draw slower, sometimes slow enough to notice.  Also, occassionally I'm left with an old video page buffer covering up half a window, and I have to reload it or close out the window entirely.  I guess that's why it's still a "work in progress".  It's nice "eye candy", but it tastes like an "apple sour" sometimes.

Offline

#10 2005-01-20 08:40:11

shadowhand
Member
From: MN, USA
Registered: 2004-02-19
Posts: 1,142
Website

Re: XFCE 4.2 shadows and transperancy

to enable the compositor, you have to recompile xfwm with the "--enable-compositor" option.

also, check the xfwm --help options, i think there is something in there having to do with the compositor. here's a link to my last screenshot of xfce. this one was xfce 4.1.99 (one of pre releases.)

there's no transset or xcompmgf being run either...

http://www.wgilk.com/linux/screenshots/ … 112704.jpg


·¬»· i am shadowhand, powered by webfaction

Offline

#11 2005-01-20 21:46:28

skoal
Member
From: Frequent Flyer Underworld
Registered: 2004-03-23
Posts: 612
Website

Re: XFCE 4.2 shadows and transperancy

How do you adjust the "transparency" without using "transet"?  I can barely make out the transparency in your terminal (from the screenshot).

Have you tried passing the "auto|on|off" switch to "xfwm4" yet?  Can you turn it off without problems using this switch?

I might just recompile mine if it's easy enough to turn off and on with a command line switch.

Offline

#12 2005-03-12 23:55:21

swim
Member
Registered: 2005-01-09
Posts: 25

Re: XFCE 4.2 shadows and transperancy

Has anyone gotten this to work? If so what are the files that I need? and how do I use them? smile hehe
thank you

Offline

#13 2005-03-14 19:01:49

shadowhand
Member
From: MN, USA
Registered: 2004-02-19
Posts: 1,142
Website

Re: XFCE 4.2 shadows and transperancy

Since people are STILL asking about this, even though it's been answered a few times in this thread, here are the exact steps to get Xfce working with pretty shadows and transparency.

The following is all done in the console while using root:

# pacman -S xapps
# abs
# cp -a /var/abs/extra/xfce4/xfwm4 /var/abs/local/
edit /var/abs/local/xfwm4/PKGBUILD with your favorite editor

change this line:   ./configure --prefix=/opt/xfce4
to this:   ./configure --enable-compositor --prefix=/opt/xfce4

# cd /var/abs/local/xfwm4
# makepkg

if xfwm4 is already installed:
# pacman -U xfwm4-[version].pkg.tar.gz

if not:
# pacman -A xfwm4-[version].pkg.tar.gz

------------------------------------------------

Edit your xorg.conf to make sure that COMPOSITE and RENDER are enabled in the extensions section.. If you have a nvidia card, add "Option" "RenderAccel" "True" to the Device section.

Then just restart xfce and look at the eye candy. Now if anyone reads this thread and can't figure it out, they deserve a good trout smacking. :twisted:


·¬»· i am shadowhand, powered by webfaction

Offline

#14 2005-04-22 01:01:56

TheRaginAsian
Member
From: Brooklyn MI
Registered: 2004-04-05
Posts: 70
Website

Re: XFCE 4.2 shadows and transperancy

thank you very much


John Gallias
Technician/Friend/Bassist
http://www.concretearmy.com
john@concretearmy.com
john.gallias@gmail.com
Arch Linux v0.7 (Wombat), XFce 4.2, XOrg, Firefox

Offline

#15 2005-04-22 04:03:47

shadowhand
Member
From: MN, USA
Registered: 2004-02-19
Posts: 1,142
Website

Re: XFCE 4.2 shadows and transperancy

Glad it works for you, too. smile


·¬»· i am shadowhand, powered by webfaction

Offline

#16 2005-04-22 17:40:58

d3c3it
Member
From: Manchester, UK
Registered: 2003-09-10
Posts: 112
Website

Re: XFCE 4.2 shadows and transperancy

shadowhand wrote:

Since people are STILL asking about this, even though it's been answered a few times in this thread, here are the exact steps to get Xfce working with pretty shadows and transparency.

The following is all done in the console while using root:

# pacman -S xapps
# abs
# cp -a /var/abs/extra/xfce4/xfwm4 /var/abs/local/
edit /var/abs/local/xfwm4/PKGBUILD with your favorite editor

change this line:   ./configure --prefix=/opt/xfce4
to this:   ./configure --enable-compositor --prefix=/opt/xfce4

# cd /var/abs/local/xfwm4
# makepkg

if xfwm4 is already installed:
# pacman -U xfwm4-[version].pkg.tar.gz

if not:
# pacman -A xfwm4-[version].pkg.tar.gz

------------------------------------------------

Edit your xorg.conf to make sure that COMPOSITE and RENDER are enabled in the extensions section.. If you have a nvidia card, add "Option" "RenderAccel" "True" to the Device section.

Then just restart xfce and look at the eye candy. Now if anyone reads this thread and can't figure it out, they deserve a good trout smacking. :twisted:

I get the error
checking for X... no

configure: error: X Window system libraries and header files are required
make: *** No targets specified and no makefile found.  Stop.
==> ERROR: Build Failed.  Aborting..

Any idea?


"Covered in blood, Cant understand" - Biffy Clyro

Offline

#17 2005-04-22 17:48:02

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: XFCE 4.2 shadows and transperancy

do you have X installed?
pacman -S xorg ?

Offline

#18 2005-04-22 17:52:22

d3c3it
Member
From: Manchester, UK
Registered: 2003-09-10
Posts: 112
Website

Re: XFCE 4.2 shadows and transperancy

strangely i compiled it with su and then it worked hmm


"Covered in blood, Cant understand" - Biffy Clyro

Offline

#19 2005-04-23 01:51:57

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: XFCE 4.2 shadows and transperancy

Im not all too sure why this wasnt compiled into the package....

I mean.... if you dont want compositing, just disable it in your X config.

Offline

#20 2005-04-28 11:53:38

d3c3it
Member
From: Manchester, UK
Registered: 2003-09-10
Posts: 112
Website

Re: XFCE 4.2 shadows and transperancy

stability problems with xfce? i see 4.2.1 is out now


"Covered in blood, Cant understand" - Biffy Clyro

Offline

#21 2005-04-28 12:15:48

miqorz
Member
Registered: 2004-12-31
Posts: 475

Re: XFCE 4.2 shadows and transperancy

iphitus wrote:

Im not all too sure why this wasnt compiled into the package....

I mean.... if you dont want compositing, just disable it in your X config.

How about this? Not everyone uses Xorg.  roll


http://wiki2.archlinux.org/

Read it. Love it. Live it. Or die.

Offline

#22 2005-04-28 21:31:13

d3c3it
Member
From: Manchester, UK
Registered: 2003-09-10
Posts: 112
Website

Re: XFCE 4.2 shadows and transperancy

miqorz wrote:
iphitus wrote:

Im not all too sure why this wasnt compiled into the package....

I mean.... if you dont want compositing, just disable it in your X config.

How about this? Not everyone uses Xorg.  roll

I thought Xorg was the default and only Xserver within Arch now? Least thats what pacman says


"Covered in blood, Cant understand" - Biffy Clyro

Offline

#23 2005-04-28 21:47:38

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: XFCE 4.2 shadows and transperancy

d3c3it wrote:

I thought Xorg was the default and only Xserver within Arch now? Least thats what pacman says

some still use XFree86 - don't ask why...

Offline

#24 2005-04-28 22:01:13

d3c3it
Member
From: Manchester, UK
Registered: 2003-09-10
Posts: 112
Website

Re: XFCE 4.2 shadows and transperancy

phrakture wrote:
d3c3it wrote:

I thought Xorg was the default and only Xserver within Arch now? Least thats what pacman says

some still use XFree86 - don't ask why...

Okeyyy...well each there own smile


"Covered in blood, Cant understand" - Biffy Clyro

Offline

#25 2005-10-26 23:18:45

Shofs
Member
From: Central Illinois
Registered: 2004-12-15
Posts: 184

Re: XFCE 4.2 shadows and transperancy

I see that XFCE is still not compiled with the composite extension enabled. I do not have a flyspry account, would someone check to see if a bug report has been filed.

Offline

Board footer

Powered by FluxBB