You are not logged in.

#1 2005-01-20 19:27:58

Registered: 2003-08-22
Posts: 14

Problem with /dev/modem (bad address)

I recently updated a bunch of packages on my system, one being kernel26-2.6.10.  After doing so, when I try to connect to the Internet using wvdial, I get the following messages:

Cannot open /dev/modem: Bad address
Cannot open /dev/modem: Bad address
Cannot open /dev/modem: Bad address

I have an Intel 536ep modem, and have the latest driver package installed.  I think this might be kernel related, but I'm not sure.  This happens whether or not I run udev, and I tried disabling hotplug also. 

Does anyone have ideas about what might be causing this?



#2 2005-05-22 04:00:38

From: Cairns, Australia
Registered: 2005-05-11
Posts: 37

Re: Problem with /dev/modem (bad address)

Got same sort of problem here. I create a symbolic link ln-s /dev/modem /dev/ttySx; the /dev/ttySx is shown in the boot up with dmesg. I use wvdial to create a isp dialup profile where modem = /dev/ttySx. But the problem I have is that I must define the sym link every time I boot up! Let me know if you ever get a fix for this.


#3 2005-05-22 15:09:12

From: Poland
Registered: 2003-10-28
Posts: 1,274

Re: Problem with /dev/modem (bad address)

Why don't you reconfigure wvdial device in /etc/wvdial.conf?

Perhaps you've overwritten your previous config during last upgrade? (ls /etc/*.pac*)

It's also easy to create /dev/modem rule for udev but it's safer to just use /dev/ttySx in /etc/wvdial.conf (in case you have several modems - theoretically :-) - you should rather create /dev/modems/modem1 etc. or something like this).


Board footer

Powered by FluxBB