You are not logged in.

#1 2010-03-22 11:09:07

Registered: 2008-12-01
Posts: 6

xorg.conf for Matrox G200


I'm having trouble configuring X on a Dell PowerEdge T110. The card in question is

06:03.0 VGA compatible controller: Matrox Graphics, Inc. MGA G200eW WPCM450 (rev 0a)

which is quite old (1998). I'm using the driver from xf86-video-mga. Running X without a configuration file, the screen goes black and I can only recover by logging in via ssh and killing X. The errors are

[jostein@myhost ~]$ grep "(EE)" /var/log/Xorg.0.log
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(EE) MGA(0): Static buffer allocation failed, not initializing the DRI
(EE) MGA(0): Need at least 15360 kB video memory at this resolution, bit depth

This is not surprising, given that the card has only 8MB memory. Using the xorg.conf generated by "X -configure" with "DefaultDepth 16" in the "Screen" section (reduces memory requirements), the new error is

[jostein@myhost ~]$ grep "(EE)" /var/log/Xorg.0.log
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(EE) MGA(0): [drm] Direct rendering only supported with G200/G400/G450/G550.


Option "DRI" "Off"

in the "Screen" section of the generated results in the same behaviour (blank screen; can only kill X using ssh login), but not a single error in Xorg.0.log. The warnings are

(WW) The directory "/usr/share/fonts/TTF" does not exist.
(WW) The directory "/usr/share/fonts/Type1" does not exist.
(WW) The directory "/usr/share/fonts/TTF" does not exist.
(WW) The directory "/usr/share/fonts/Type1" does not exist.
(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
(WW) Disabling Mouse0
(WW) Disabling Keyboard0
(WW) MGA(0): Direct rendering disabled

A fedora 12 live cd succeeds in starting X. I grabbed the config from the log file and tried it in Arch, with the same symptoms as before and the errors were the same as the first listing given above. I have also tried different "vga=..." options on the kernel command line as I got some errors about /dev/fb0 missing at some point. The tests given above were done with "vga=0x0318". As there are no more errors, I'm a little unsure about what to try next. Anyone have any ideas or suggestions?

The full fedora Xorg.0.log can be found here:
The full Xorg.0.log from the last failing test (DRI disabled):



#2 2010-11-09 00:35:29

Registered: 2009-04-10
Posts: 42

Re: xorg.conf for Matrox G200

I have the same card

VGA compatible controller: Matrox Graphics, Inc. MGA G200eW WPCM450 (rev 0a)

And I have it working with a screen up to 1152x864. I haven't been able to use it at 1440x900 but for whatever reason I can make it work at 1280x960 without complaining about the vertical resolution (which is higher than the actual vertical screen resolution).

Do you still have problems with this card? What is the maximum resolution you get? Using which depth?

Best regards


#3 2010-11-09 02:05:58

From: Portugal
Registered: 2008-06-19
Posts: 301

Re: xorg.conf for Matrox G200

I think that card is an agp card (i have one matrox g100 here agp1x, powerful stuff 8mb xD).
There's an option called Agp aperture size in your bios... since you almost dont have any video ram memory avaiable, increase that value to at least 128mb and you should be able to do something with that... (you need to have at least 128mb of ram).
8mb isn't enough to have high resolutions with 24bit depth. just do "(resolution x bit depth) /  (100000 * 8)" -> that will give you in MBytes the amount of vram that you need. For example, 1280x1024 @ 24bits needs 4mb. *i cant confirm if what i said is correct, but im almost sure that this is the math that you have to do*

.::. TigTex @ Portugal .::.


Board footer

Powered by FluxBB