You are not logged in.

#1 2010-04-02 10:56:32

Dinth
Member
From: London
Registered: 2009-03-02
Posts: 224

TP-Link WN422G v2 - it WORKS !

I was fighting to run TP-LINK WN422G v2 usb wifi adapter for a long time. I know that there is ar9170usb and ath9k_hw drivers, which should support it, but there isnt for now. Ive even tried to compile git kernel, with my patch on ar9170usb, which adds usbid of my card to this driver, but still it didnt worked. It loaded without error, but there wasnt any network interface made by it. Also official Ndiswrapper wiki told me that ndiswrapper dont work with this card.

Also i found lots of forum/newsgroup/blog posts about linux unsupporting this card in any way, and dont found even one, which tells about installing this adapter on linux successfully.

But today i tried to run this adapter one more (and last) time. This time with ndiswrapper. Ive installed driver from CDROM (ver. 7.7.0.51), but ndiswrapper didnt see any adapters. So ive manually paired adapter with driver, by doing:

sudo ndiswrapper -a 0cf3:1006 netathuw
sudo ndiswrapper -m
sudo ndiswrapper -ma
sudo ndiswrapper -mi

and after system reboot ... IT WORKS. I did not encountered any probles, or dmesg errors for now, even when downloading torrents from lots of seeds, and later i will test it with networkmanager.

local/ndiswrapper 1.56-1
local/kernel26 2.6.32.10-1 (base)

Good luck owners of this adapter!

PS. Anybody knows how to _easly_ compile ndiswrapper with git kernel from aur ?
PS2. Could somebody post this on ndiswrappers wiki? As You see, my english is too poor to write anything on driver official wiki by myself.

Last edited by Dinth (2010-04-02 11:01:12)

Offline

#2 2010-04-04 03:15:17

aldeano
Member
Registered: 2009-09-04
Posts: 22

Re: TP-Link WN422G v2 - it WORKS !

In wireless.kernel.org there is a driver for this adapter, supposedly it works when you install the last compat wireless package published (2010-04-03) and download the firmware. I've tried (make & sudo make install & sudo make unload & reboot) but i don't get any new interface when clicking iwconfig .

Gonna try your method with ndiswrapper.

UPDATE

After done everything you posted, i've got an error in dmesg:

ndiswrapper version 1.56 loaded (smp=yes, preempt=yes)
usbcore: registered new interface driver ndiswrapper
ndiswrapper (link_pe_images:565): fixing KI_USER_SHARED_DATA address in the driver
ndiswrapper: driver netathuwx (,07/08/2009,7.7.0.51) loaded
ndiswrapper (NdisWriteErrorLogEntry:190): log: C0001389, count: 4, return_address: ffffffffa022540e
ndiswrapper (NdisWriteErrorLogEntry:193): code: 0xae4dd400
ndiswrapper (NdisWriteErrorLogEntry:193): code: 0xa
ndiswrapper (NdisWriteErrorLogEntry:193): code: 0x0
ndiswrapper (NdisWriteErrorLogEntry:193): code: 0x0
ndiswrapper (wrap_cancel_irp:238): urb ffff8800aebd2b40 can't be canceled: 2
ndiswrapper (mp_init:219): couldn't initialize device: C000009A
ndiswrapper (pnp_start_device:435): Windows driver couldn't initialize the device (C0000001)
ndiswrapper (mp_halt:262): device ffff8800ae859680 is not initialized - not halting
ndiswrapper: device eth%d removed
ndiswrapper: probe of 2-1:1.0 failed with error -22

With arch64 and driver for winxp64.

Last edited by aldeano (2010-04-04 03:44:11)

Offline

#3 2010-04-06 11:07:52

ammon
Member
Registered: 2008-12-11
Posts: 413

Re: TP-Link WN422G v2 - it WORKS !

I used winxp64 drivers on arch64, they do load and usb is working but it is not usable. It could not connect to AP standing 3m from it. Signal was @40%, on internal wireless (iwl4695) is 98%.

Offline

#4 2010-04-08 08:52:10

Dinth
Member
From: London
Registered: 2009-03-02
Posts: 224

Re: TP-Link WN422G v2 - it WORKS !

im using i686 system. Maybe it dont works with x64 by now. Now im using kernel26-git (2.6.45-rc3+) and ndiswrapper compiled from ABS, and it still works for me.

[dinth@dinth-linux share]$ dmesg | grep ndiswrapper
ndiswrapper version 1.56 loaded (smp=yes, preempt=yes)
ndiswrapper: driver netathuw (,07/08/2009,7.7.0.51) loaded
usbcore: registered new interface driver ndiswrapper
[dinth@dinth-linux share]$ lsusb
Bus 002 Device 004: ID 0cf3:1006 Atheros Communications, Inc.
[dinth@dinth-linux share]$ iwconfig
lo        no wireless extensions.

wlan0     IEEE 802.11g  ESSID:"brooklyn"  
          Mode:Managed  Frequency:2.427 GHz  Access Point: 00:14:BF:93:BE:61   
          Bit Rate=54 Mb/s   
          Power Management:off
          Link Quality:40/100  Signal level:-70 dBm  Noise level:-96 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Connection is perfectly stable for me. iwlist scan detects even networks which are located few km from my home. Ive also posted this information on my new blog: http://dinthsblog.blogspot.com/2010/04/ … 2g-v2.html

Last edited by Dinth (2010-04-08 08:54:28)

Offline

#5 2010-06-26 13:14:00

Dehir
Member
From: Finland
Registered: 2009-11-08
Posts: 25

Re: TP-Link WN422G v2 - it WORKS !

And about those atheros ar9170usb drivers. Iw been using them for while and my card is DLINK dwa-160 rev a1 which has this atheros chip. I guess that rev a2 has other chip.

But anyways. The driver seem to let me down . What helps for me is tho unplug the usb wifi card and replug it after sometime of waiting, you need to unload module also to get effect and that doesnt help everytime so still quite unstable driver for dlink.

problem appears when it tries to authenticate with my wpa2 network. My wlan-ap is DLINK dir-825.

Offline

Board footer

Powered by FluxBB