You are not logged in.

#1 2010-04-09 15:37:32

Registered: 2010-04-01
Posts: 621

[SOLVED] Lotus Notes 32 chroot problem -> howto

Edit 1: shortened... perhaps the length was a turn off
Edit 2: changed the title to be more specific (Lotus Notes vs. generic chroot issues)

My plot:
- followed the wiki instructions for setting up a 32bit chroot env so I can run IBM Lotus Notes on 64bit Arch
- on the chroot, I have base, base-devel, xorg, xfce4, xf86-video-intel/vesa, xf86-input-keyboard, xf86-input-mouse, and everything that comes with doing 'yaourt -S lotus-notes-base' installed
- also installed rpm so that I could install the Lotus Notes 8.5 trial in rpm format (has worked on previous Linux distros, so I stuck with rpm (over deb))
- I am able to start Notes, but get a partial frame instead of an actual window (more next post)

One question is what exactly one needs to install to be able to run something from 32bit chroot. It is not exactly clear in the wiki. My gut after fiddling for a long time is that one needs all replacement libs that the program needs to run. This is how I've been approaching things.


Last edited by jwhendy (2010-04-21 00:19:43)


#2 2010-04-09 23:08:20

Registered: 2010-04-01
Posts: 621

Re: [SOLVED] Lotus Notes 32 chroot problem -> howto

Here's the udpate with some more help, perhaps:

- Screenshots:
--- Start notes from command line (all looks good to me): PIC
--- License screen pops up (looks like it always has): PIC
--- Reminder about trial pops up (looks like it always has): PIC
--- Then the 'window' pops up... but it's crippled: PIC

What's up with that?

- List of what I have on my chroot (from yaourt -Q): arch32.txt

- What's currently mounted: mount.txt

Hmmm... anything else that would help trouble shoot a chroot? I did try installing firefox and it works. Does this just mean it's something goofy with Lotus Notes? Is there any way to tell what it wants to run?

Someone obviously did this already as evidenced by the existence of lotus-notes-base in the AUR. The only package that fails is eel. I can't find it via pacman or in the AUR... Is this significant?

That's about all for now. Any help?



#3 2010-04-09 23:54:19

Forum Fellow
From: Between Thailand and Singapore
Registered: 2009-03-17
Posts: 7,336

Re: [SOLVED] Lotus Notes 32 chroot problem -> howto

Dumb question which may be tangential, do you have your video drivers installed in the chroot? For example, if you have nvidia on your system you'd probably need nvidia installed in the system as well.

Allan-Volunteer on the (topic being discussed) mailn lists. You never get the people who matters attention on the forums.
jasonwryan-Installing Arch is a measure of your literacy. Maintaining Arch is a measure of your diligence. Contributing to Arch is a measure of your competence.
Griemak-Bleeding edge, not bleeding flat. Edge denotes falls will occur from time to time. Bring your own parachute.


#4 2010-04-10 02:04:59

Registered: 2010-04-01
Posts: 621

Re: [SOLVED] Lotus Notes 32 chroot problem -> howto

Not a dumb question at all...

My graphics card is an Intel 945 which uses xf86-video-intel.

Just to help the case, though, I diff-ed the output of pacman -Q on both the chroot and 64 systems. The results are here:
- arch32.txt (the chroot env installed packages)
- arch64.txt

- diff --side-by-side arch32.txt arch64.txt | grep xf86 yields identical packages except that 64bit has xf86-input-synaptics, which shouldn't affect the video at all...

- scanning through the whole diff doesn't give me anything that would make me suspicious, although this isn't the same as comparing to the packages/libraries present on a computer it does actually work on. I guess I can check that out by comparing the libraries present to my Zenwalk installation.

On the other hand, it's able to display windows as shown in the screenshots I took. I can't see any reason why it could create a fully functioning frame in one instance (actually 2 -- the license screen and the 89 day trial warning) but not in another (whatever should be coming up next). There are also no errors to stdout when I run from the command line.

Any further thoughts?

As an aside, how would I try the alternative multilib approach? I installed the lib32 group which seems to have shown up in /opt/lib32 but Lotus Notes complained that it couldn't find the native libraries and had a bunch of ELFCLASS=64 errors... I'm guessing I have to set this up in env somewhere?

I was not able to install CAD on my system, so I'm pretty close to just going i686, especially after getting a no-go from hulu last night. What the hell?? Computers and applications are in such an annoying state right now... I've been toying with 64bit for at least a year or so now and always get bitten by some stupid app that isn't 64 bit yet.



#5 2010-04-12 01:22:36

Registered: 2010-04-01
Posts: 621

Re: [SOLVED] Lotus Notes 32 chroot problem -> howto

Sorry to bump... it's ben 48 hrs and since this is work related (whether I can get my work email program up or not), I would like to collect any final suggestions before moving toward i686. I'm going to try one last thing before I call it quits on 64bit: I'll cross reference everything on my Zenwalk install in /usr/lib with that in /opt/arch32/usr/lib to see if I'm missing anything obvious.

Lastly, as previously asked: any thoughts on going about this with multilib instead? I installed lib32 which was put in /opt/lib32, but I did not see anything in the wiki the popped out at me as to how to link to it or direct programs to use those libraries?



#6 2010-04-20 15:03:52

Registered: 2010-04-01
Posts: 621

Re: [SOLVED] Lotus Notes 32 chroot problem -> howto

I think I'm almost there but am definitely stuck!

I've not gotten much response here, but hey: Notes is not that common. I'll bump/ask about this one more time, but then I think I'm forced to go i686 which is a true bummer given that I specifically chose Arch for 64 bit so I could run CAD. Without email, though, I'm nowhere considering this is for work...

Here's the update:
- Setup 32bit chroot per ArchWiki with base and base-devel
- Installed the libs that would come with the x86_64 lib32 group into my chroot
- Carefully read, checked, and installed the lotus notes dependencies from here
- Executed 'yaourt -S lotus-notes-base' just to see if I missed anything (only package not found is eel -- seems to not exist anywhere in Arch anymore?)
- Executed 'pacman -S font-bh-ttf' per reading through this
- Installed Notes with 'sudo rpm -ivh --nodeps ibm_lotus_notes-8.5.1.i586.rpm'

Everything starts up, I get to accept the license, then fill in my info and all that jazz... but things don't work very well at that point:
- Output from first start: firstStart.txt
- Output from subsequent starts: subsequent.txt
- Getting started screen: gettingStarted.png
- Home screen: home.png
- Calendar: calendar.png
- Note: I didn't want to take a shot of my inbox; it should suffice to say that the list is perfect, but the preview pane is just white
- Note: When opening emails into another tab of their own, either it's only white/nothing or all black like the calendar

My post on the IBM boards is HERE

It's ridiculously close to working and there just has to be some weird tidbit or library I'm missing but cant' figure out. I'd like to get this solved and then write this up on the ArchWiki with Notes on 64bit with 32bit chroot instructions so no one has to endure this again!

Any thoughts?

Best regards,


#7 2010-04-21 00:18:34

Registered: 2010-04-01
Posts: 621

Re: [SOLVED] Lotus Notes 32 chroot problem -> howto

Got it!

Here's a howto for anyone who stumbles across this. I also plan to put it up on the wiki when I hear back from the maintainer I contacted.

1. Follow the instructions for setting up a 32bit chroot on x86_64 Arch found HERE. In short, this means:
- create /opt/arch32, setup pacman on the chroot, link the necessary files between /etc and /opt/arch32/etc and sync the chroot's pacman
- install base and base-devel on the chroot
- start the daemon with '/etc/rc.d/arch32 start' and 'xhost +local:'
- add 'arch32' to /etc/rc.conf in the daemons section for future reboots

2. Get Lotus Notes in rpm format for Linux
- Grab the official version from Passport Advantage or your Notes admin
--- Get fixpack 2 from HERE (be sure to get the one for Notes, not Domino)
- As an alternative, the demo version of 8.5 is HERE
--- Get fixpack 1 from HERE

3. chroot into /opt/arch32

$ sudo linux32 chroot /opt/arch32
$ su your-username

###Everything from this point forward will assume that you are in the 32bit chroot. Be sure of this!!!###

4. install yaourt
- follow the instructions on the ArchWiki
- if you run into issues with package-query trying to pull the 64bit version, look HERE

5. install rpm

yaourt -S rpm

6. install necessary Lotus Notes packages:

pacman -S gdb tcsh libart-lgpl alsa-lib atk libbonobo libbonoboui gconf gtk2 libgnome libgnomecanvas libgnomeprint libgnomeprintui libgnomeui gvfs libice libjpeg orbit2 pango libpng libsm libx11 libxcursor libxext libxft libxi libxkbfile libxml2 libxrender libxss libxt libxtst font-bh-ttf audiofile esound gnome-menus libgail-gnome startup-notification gnome-desktop gtk-xfce-engine xterm

- I use xfce. Without gtk-xfce-engine, the selection boxes and some other things didn't look very good. Perhaps the equivalent on KDE would be to install gtk-qt-engine(?) and on gnome to install something like gtk-engine-murrine(?). I don't have enough experience to know this, though.

7. install lotus notes

$ cd /dir/with/ibm_lotus_notes.rpm
$ sudo rpm -ivh --nodeps ibm_lotus_notes.rpm
$ sudo rpm -ivh --nodeps ibm_lotus_notes-fixpack.rpm

8. add some custom libraries to /opt/ibm/lotus/notes
- download THIS
--- if this link is broken at some future date, contact me and I can send the tarball myself (email list below in P.S.)
- then:

$ tar -xvzf notes_libs_karmic.tgz
$ sudo cp /opt/ibm/lotus/notes/

- then do:

$ cd /opt/ibm/lotus/notes
$ sudo chown root:wheel libg*
$ sudo chmod 755 libg*

9. start notes

$ /opt/ibm/lotus/notes/notes

10. setup
- should get a white screen where you accept the license by entering '1' and then pressing enter
- setup your server and user id file

11. post setup
- you can remove xterm with 'pacman -Rs xterm' after accepting the license. It is only needed for that popup window
- the getting started screen will not display properly and I have not figured out how to get it to stop showing up. Everything else I've played with in my short time thus far has worked: general email, calendar, a database...

12. Other helpful references on Lotus Notes and Linux:
- IBM Forum howto
- Howto for Ubuntu
- Another Ubunto howto
- Sys requirements: this is how I put together the list above for which packages to install
--- I also created a list of the output from 'sudo rpm -ivh ibm_lotus_notes.rpm' which will given an error as Arch is not rpm based so none of the dependencies show up as being installed
--- This let me check deps first hand with a lot of 'pacman -Qo /usr/lib/filename' on the 64bit install to see what packages were needed to produce the libraries Notes wanted to have around

Good luck! I do hope to get this on the wiki so that it is preserved in better form that this post...


P.S. For personal contact, use the forums or feel free to email: jw [dot] hendy [at] gmail [dot] com


Board footer

Powered by FluxBB