You are not logged in.

#1 2005-01-28 02:15:46

From: Slovenia
Registered: 2004-02-08
Posts: 247

Parallel port scanner

I can't get it to work with kernel 2.6 and udev.

Modules loaded: parport_pc, parport, lp

bash-3.00# dmesg | grep parport
parport: PnPBIOS parport detected.
parport0: PC-style at 0x378, irq 7 [PCSPP,TRISTATE,EPP]

bash-3.00# ls -l /dev/par* /dev/lp*
ls: /dev/par*: No such file or directory
crw-rw----  1 root users 6, 0 2005-01-28 03:00 /dev/lp0

Which node is actually the parallel port in udev? I got the impression it should be /dev/parport0, but I don't have anything like that. When I run:
xsane umax_pp:/dev/lp0
I get:

Failed to open device `umax_pp:/dev/lp0`: Invalid argument.

Same for other devices I tried.

The scanner worked with kernel 2.4 and devfs, I just had to load module ppdev and run
xsane umax_pp:/dev/parports/0


#2 2005-01-28 22:38:17

From: Slovenia
Registered: 2004-02-08
Posts: 247

Re: Parallel port scanner

Got it. Had to compile my own freakin' kernel, though. The module ppdev is obviously intended to use also with 2.6 kernels, but for some unknown reason the Arch's kernel26 is compiled without it, while kernel24 has it compiled as module. And without ppdev there is no /dev/parport* (the /dev/lp* won't work), at least not on my system.

I found this post, looks like 2.6 has been without ppdev for quite some time. Doesn't anybody use the parallel port anymore?

Oh, this was my first time to compile the kernel. I did it with abs (makepkg) with files in /var/abs/kernels/kernel26/, only changed the /var/abs/kernels/kernel26/config so it has this line:


Is this ok, although it says:

# Automatically generated make config: don't edit

in that file?


Board footer

Powered by FluxBB