You are not logged in.

#1 2005-02-01 19:45:05

Nickm
Member
From: Netherlands
Registered: 2003-02-25
Posts: 104

rxvt problem

I have a problem in rxvt, whenever i type a ' character I get a ` character
and whenever i type " I get ¨. This does not happen in xterm or konsole.
I hope someone can explain why this happens and how to fix this, Thanks in advance, Nick


Who is peer, and why is he resetting my connection ??

Offline

#2 2005-02-01 20:07:57

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: rxvt problem

I would assume it's a locale setting.... not sure on the exacts...

Offline

#3 2005-02-01 21:31:23

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: rxvt problem

as phrakture says, it could be a locale setting,
I use urxvt and it uses LC_CTYPE

here is my ~/.bashrc

alias ls='ls --color=auto'
PS1='[u@h W]€ '
export BROWSER='mozilla-firefox'
export LC_CTYPE='sv_SE.UTF-8'
export LANG='en_GB'

I don't remember in my head how to make a locale now but there are threads about localedef in the forum,
maybe we should make wiki about it,


arch + gentoo + initng + python = enlisy

Offline

#4 2005-02-01 22:13:24

i3839
Member
Registered: 2004-02-04
Posts: 1,185

Re: rxvt problem

It could also be a $TERM problem: Make sure that $TERM is set to "rxvt" (which, sadly, doesn't happen by default).

I use my .Xdefaults file for such config stuff, for rxvt I have the following:

rxvt.termName:          rxvt
rxvt.background:        black
rxvt.foreground:        white
rxvt.saveLines:         1000

Offline

#5 2005-02-02 14:21:11

Nickm
Member
From: Netherlands
Registered: 2003-02-25
Posts: 104

Re: rxvt problem

I've changed those thing, but still unsuccesfull,
here's a few variables from my environment (executed within rxvt);

[nick@Nick ~]$ set |grep TERM
COLORTERM=rxvt
TERM=rxvt

[nick@Nick ~]$ set |grep LC
LC_ALL=nl_NL
LC_COLLATE=C
LC_CTYPE=en_GB
MAILCHECK=60

the inputdevice section from xorg.conf

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "logiinkse"
        Option      "XkbLayout" "us_intl"
EndSection


whole enviroment:

[nick@Nick ~]$ set
BASH=/bin/bash
BASH_VERSINFO=([0]="3" [1]="00" [2]="0" [3]="2" [4]="release" [5]="i686-pc-linux-gnu")
BASH_VERSION='3.00.0(2)-release'
CLASSPATH=:/opt/java/jre/lib
COLORFGBG='15;0'
COLORTERM=rxvt
COLUMNS=80
DIRSTACK=()
DISPLAY=:0.0
EUID=1000
GROUPS=()
HISTFILE=/home/nick/.bash_history
HISTFILESIZE=500
HISTSIZE=500
HOME=/home/nick
HOSTNAME=Nick
HOSTTYPE=i686
HUSHLOGIN=FALSE
HZ=100
IFS=$' tn'
INPUTRC=/etc/inputrc
J2REDIR=/opt/java/jre
JAVA_HOME=/opt/java/jre
KDEDIR=/opt/kde
KDEDIRS=/opt/kde:/usr
LANG=nl_NL
LC_ALL=nl_NL
LC_COLLATE=C
LC_CTYPE=nl_NL
LESS=-R
LESSCHARSET=latin1
LINES=24
LOGNAME=nick
MACHTYPE=i686-pc-linux-gnu
MAIL=/var/spool/mail/nick
MAILCHECK=60
MANPATH=/usr/man:/usr/X11R6/man:/opt/java/jre/man:/opt/kde/man:/opt/qt/man
MOZ_PLUGIN_PATH=/opt/mozilla-plugins
OPTERR=1
OPTIND=1
OSTYPE=linux-gnu
PATH=/bin:/usr/bin:/sbin:/usr/sbin:/usr/X11R6/bin:/opt/bin:/opt/bittorrent:/opt/java/jre/bin:/opt/kde/bin:/opt/qt/bin:/home/nick/bin:/opt/e17/bin:/home/nick/bin:/opt/e17/bin
PIPESTATUS=([0]="0" [1]="0")
PKG_CONFIG_PATH=:/opt/kde/lib/pkgconfig
PPID=25861
PS1='[u@h W]$ '
PS2='> '
PS4='+ '
PWD=/home/nick
QTDIR=/opt/qt
RESTART=1
SHELL=/bin/bash
SHELLOPTS=braceexpand:emacs:hashall:histexpand:history:interactive-comments:monitor
SHLVL=4
TERM=rxvt
UID=1000
USER=nick
WINDOWID=44040194
XAUTHORITY=/home/nick/.Xauthority
XDG_CACHE_HOME=/home/nick/.cache
XDG_CONFIG_DIRS=/etc/xdg:/opt/kde/etc/xdg
XDG_CONFIG_HOME=/home/nick/.config
XDG_DATA_DIRS=/usr/share:/opt/kde/share
XDG_DATA_HOME=/home/nick/.local/share


Who is peer, and why is he resetting my connection ??

Offline

Board footer

Powered by FluxBB