You are not logged in.

#1 2010-05-31 11:12:37

zawart
Member
Registered: 2009-11-29
Posts: 6

[Solved] Kernel panic - not syncing Attepmted to kill init!

Hi,
I have Arch x86 on my Via C3 Eden. Yesterday I made full system upgrade ( I regularly do this ) and I got while booting kernel message "Kernel panic - not syncing Attempted to kill init". Below is screen-shot with additional kernel booting options "debug initcalls_debug loglevel=7". Please help me solve me this smile
20100531003.jpg
Here is my cutting from pacman.log

[2010-05-30 23:41] synchronizing package lists
[2010-05-30 23:42] starting full system upgrade
[2010-05-30 23:42] upgraded linux-api-headers (2.6.33.2-1 -> 2.6.34-1)
[2010-05-30 23:42] warning: /etc/locale.gen installed as /etc/locale.gen.pacnew
[2010-05-30 23:43] upgraded glibc (2.11.1-3 -> 2.12-2)
[2010-05-30 23:43] upgraded binutils (2.20.1-2 -> 2.20.1-3)
[2010-05-30 23:43] upgraded dash (0.5.5.1-2 -> 0.5.6-1)
[2010-05-30 23:43] upgraded dialog (1.1_20100119-2 -> 1.1_20100428-1)
[2010-05-30 23:43] upgraded gcc (4.5.0-2 -> 4.5.0-3)
[2010-05-30 23:43] upgraded gcc-libs (4.5.0-2 -> 4.5.0-3)
[2010-05-30 23:43] upgraded libpng (1.4.1-1 -> 1.4.2-1)
[2010-05-30 23:43] upgraded openssh (5.4p1-4 -> 5.5p1-1)
[2010-05-30 23:43] warning: /etc/pam.d/login installed as /etc/pam.d/login.pacnew
[2010-05-30 23:43] upgraded shadow (4.1.4.2-2 -> 4.1.4.2-3)
[2010-05-30 23:43] upgraded splix (2.0.0-5 -> 2.0.0-6)
[2010-05-30 23:43] upgraded syslog-ng (3.1.0-1 -> 3.1.1-1)
[2010-05-30 23:43] upgraded tar (1.23-1 -> 1.23-3)

Solution
Downgrading these packages then rebuild initramfs and fsck on this drive smile

Last edited by zawart (2010-05-31 12:18:30)

Offline

#2 2010-06-01 13:00:56

jideel
Member
Registered: 2010-06-01
Posts: 1

Re: [Solved] Kernel panic - not syncing Attepmted to kill init!

Hi,

Exactly the same problem on a VIA Nehemiah CentaurHauls.
Can it be related to the problem found on this thread : http://www.gossamer-threads.com/lists/l … nel/949563
I don't want to downgrade packages, how to check that the mainstream kernel (2.6.33-4) has been built with CONFIG_X86_GENERIC ?
Any idea ?
Thank you.

Offline

#3 2010-06-01 17:31:34

zawart
Member
Registered: 2009-11-29
Posts: 6

Re: [Solved] Kernel panic - not syncing Attepmted to kill init!

[root@ zawart]# uname -r; zcat /proc/config.gz | grep CONFIG_X86_GENERIC
2.6.33-ARCH
CONFIG_X86_GENERIC=y

I downgraded linux-api-headers with all related packages (glibc, binutils,..).  Linux-api-headers is with higher number (2.6.34) then actually kernel in repository (2.6.33), mayby this is a causing this problem ?

Last edited by zawart (2010-06-01 17:38:01)

Offline

#4 2010-06-16 07:36:20

libretto
Member
Registered: 2010-05-18
Posts: 19

Re: [Solved] Kernel panic - not syncing Attepmted to kill init!

I got this same message when I try to boot on a transmeta (crusoe). When I try to reinstall it stop at /sbin/init not found. I got 238MB ram on this machine. Please help, been looking for solution for days. sad

Offline

#5 2010-06-24 00:54:37

synthead
Member
From: Seattle
Registered: 2006-05-09
Posts: 1,328

Re: [Solved] Kernel panic - not syncing Attepmted to kill init!

I'm getting this exact issue with 2.6.34 on a transmeta crusoe too.


Touch my kernel

Offline

#6 2010-06-30 12:15:54

tiny
Member
Registered: 2008-11-10
Posts: 11

Re: [Solved] Kernel panic - not syncing Attepmted to kill init!

bumpity bump
...
same here

Offline

#7 2010-06-30 14:21:01

schuay
Trusted User (TU)
From: Austria
Registered: 2008-08-19
Posts: 564

Re: [Solved] Kernel panic - not syncing Attepmted to kill init!

Offline

#8 2010-07-01 11:08:28

tiny
Member
Registered: 2008-11-10
Posts: 11

Re: [Solved] Kernel panic - not syncing Attepmted to kill init!

Nothing worked. Downgrading libc or patching kernel.

Offline

#9 2010-07-02 00:09:19

synthead
Member
From: Seattle
Registered: 2006-05-09
Posts: 1,328

Re: [Solved] Kernel panic - not syncing Attepmted to kill init!

So I compiled the entire base tree, including the kernel with the default kernel options from the PKGBUILD in the abs.  I used the -Os flag instead of -O2 because apparently, the Transmeta Crusoe processors do not have full i686 translation (read this http://en.gentoo-wiki.com/wiki/Safe_Cflags/Transmeta).  Unfortunately, it panicked exactly the same way.  However, I was able to successfully boot the system on a native Pentium i686 machine.  So obviously, this isn't working on this CPU.

I am compiling another base tree, this time for the i586 architecture.  I am hosting a repo of these packages if any of you would like to sync with it.  http://bbs.archlinux.org/viewtopic.php?id=99941 will tell you more about my project (but these scripts are out-of-date).

My i586 repo will be online in about an hour ish.  I'll post to this thread when it's up (I'm building the last dependency with my distcc cluster now).  Add...

Server=http://max-o.sytes.net/archlinux/$repo/os/i586

to your crusoe's mirrorlist and install the base packages in a chroot.  Reboot and cross your fingers.

Oh, and by the way, if you want the entire base tree (and some extras) for i686 compiled with "-march=i686 -Os -mmmx -pipe -fomit-frame-pointer", you're welcome to experiment with this mirror.  It did not boot on my Crusoe, but you can experiment with it on yours.

Server=http://max-o.sytes.net/crusoe/$repo/os/i686

Last edited by synthead (2010-07-02 00:14:05)


Touch my kernel

Offline

#10 2010-07-04 00:46:16

synthead
Member
From: Seattle
Registered: 2006-05-09
Posts: 1,328

Re: [Solved] Kernel panic - not syncing Attepmted to kill init!

Well, I build everything, and nothing has changed.  I have discovered that glibc is the culprit here though, and from my reading, it has to compile with -O2 atm.  I'm note sure how to fix this.  I am reading into it.  If anyone can chime in, I would be very happy, however!


Touch my kernel

Offline

#11 2010-07-04 04:49:43

synthead
Member
From: Seattle
Registered: 2006-05-09
Posts: 1,328

Re: [Solved] Kernel panic - not syncing Attepmted to kill init!

Alright, I think I found the culprit.  All this -O2/-Os business is really the issue at hand.  glibc must be compiled with -O2 or it fails, but we have to compile with the -Os flag.  We have a problem here.

However, there is apparently a patch floating around for the kernel that emulates NPOL instructions, which is exactly the difference between -O2 and -Os.  Instead of recompiling every title of software (like I did), we can simply patch the kernel to emulate these functions, therefore using the regular mirrors!

Read this: http://bugs.archlinux.org/task/19733
And most importantly, this: http://notes.osuv.de/doku.php?id=geode

I'm going to create a PKGBUILD for a kernel with ambiguous nopl emulation support (without any geode stuff) and throw it in the AUR if it works.  Here goes ...

By the way, I got my crusoe to run by installaing http://dev.archlinux.org/~allan/glibc-2 … pkg.tar.xz over a system installed with the "crusoe" mirror I detailed above!  There are some issues, but overall, the system is very stable.


Touch my kernel

Offline

#12 2010-07-04 23:21:50

synthead
Member
From: Seattle
Registered: 2006-05-09
Posts: 1,328

Re: [Solved] Kernel panic - not syncing Attepmted to kill init!

SUCCESS!  I have built a kernel that emulates nopl instructions!  What this means to you: install this kernel, boot into it, and you can now run the official packages from the regular mirrors. 

Differences between the new kernel, 'kernel26-crusoe', and the official kernel:

- The same nopl (long noop) emulation for the geode is specifically included in the transmeta crusoe section of the source
- The kernel's config file has been set to build for MCRUSOE instead of M686
- MCRUSOE has been patched to be recognized and treated as a full-fledged i686 CPU instead of an i586 CPU
- The PKGBUILD of 'kernel26-crusoe' is written with provides=('kernel26') which gives it 100% compatibility with the mainline kernel (including third-party modules)
- And of course the best part: it works with our mirrors!  The standard -O2 flag is supported!

I will have a PKGBUILD and a binary package uploaded tonight!  I am jumping the gun a little for I am installing the regular base packages to my system as we speak, but since I was able to successfully chroot into a system with these packages installed, I am expecting it to be flawless!  Cross your fingers!


Touch my kernel

Offline

#13 2010-07-07 09:07:32

tiny
Member
Registered: 2008-11-10
Posts: 11

Re: [Solved] Kernel panic - not syncing Attepmted to kill init!

From the point of the end user who's sick and tired of compiling stuff and just would like things to works as they used to can we expect this problem to be fixed in official releases? Where do I whine about this? LKML, glibc mailing list?

Offline

#14 2011-01-11 17:17:26

[KNS]Kumo
Member
Registered: 2009-11-06
Posts: 62
Website

Re: [Solved] Kernel panic - not syncing Attepmted to kill init!

Edit.

Last edited by [KNS]Kumo (2011-01-11 21:19:42)


Ore wa Kumo Da!
http://knsweb.net

Offline

Board footer

Powered by FluxBB