You are not logged in.

#1 2010-06-10 17:13:00

Registered: 2010-05-25
Posts: 19

[SOLVED] RAID0 Array - Unknown Partition Table

I recently reinstalled my Arch system with a RAID0 array, and I've noticed something different this time around during boot.

When the mdadm hook is initialized it will stop the array, check it, then start it. Once it's started it will say,

md0: unknown partition table

And continue to the next array.

I believe this is fine since the system doesn't stall or anything during bootup. The concern I have is when the system then tries to activate the RAID arrays. It will show,

Activating RAID Arrays         [FAIL]

I've looked this up, and apparently it's nothing to be worried about. However, it didn't do that when I had my system installed not 20 minutes before (up to date).

I've created the mdadm configuration file as such,

rm /mnt/etc/mdadm.conf
mdadm --examine --scan >> /mnt/etc/mdadm.conf

Apparently, this message can be removed so it doesn't show fail on startup by commenting out the part in /etc/rc.sysinit where it assembles the RAID, lines 121-123. I'm still uneasy with it though, I'm just looking for some further insight on this subject.

Why doesn't my md0 device have a partition table and what is the system doing that causes the assembly to fail?

Edit - It might be important to note that I'm trying to make 3 partitions of the following size,

/                      10GB
/home         ~4TB
/boot              50MB


Last edited by nerditup (2010-06-14 04:39:35)


#2 2010-06-14 04:37:47

Registered: 2010-05-25
Posts: 19

Re: [SOLVED] RAID0 Array - Unknown Partition Table

Update: This behaviour is normal.

The partition table for a RAID array is not specified anywhere because the partition table is setup on the actual devices. In my case I have two partition tables set on /dev/sda and /dev/sdb, therefore /dev/md0 doesn't need any partition table.

The code,

#If necessary, find md devices and manually assemble RAID arrays
if [ -f /etc/mdadm.conf -a "$(/bin/grep ^ARRAY /etc/mdadm.conf 2>/dev/null)" ];
                 status "Activating RAID arrays" /sbin/mdadm --assemble --scan

will check mdadm.conf for any arrays that are setup and try to assemble them. Since the arrays are assembled already by the mdadm hook, then the --assemble parameter will return an error. This is the reason for the [FAIL] message.

Since this is understood and not an actual "error", it is safe to comment out these lines in rc.sysinit. In fact, these lines are useless and should be taken out completely.

The reason why it didn't show up last time was because I didn't properly setup my mdadm.conf file on the previous install. This process made sure they were loaded, but if you follow the wiki and properly setup the mdadm.conf file then you don't need this line of code at all in your rc.sysinit.

Last edited by nerditup (2010-06-14 04:39:21)


Board footer

Powered by FluxBB