You are not logged in.

#1 2010-06-24 11:07:34

dcc24
Member
Registered: 2009-10-31
Posts: 723

[SOLVED] pm-hibernate broke after update

Note: I've searched the forums and the only solution I could find was related to a grep bug, so please don't tell me to search smile

Yesterday I -Syu'ed and the following got updated:

[2010-06-23 22:01] installed poppler-data (0.4.2-1)
[2010-06-23 22:01] upgraded poppler (0.12.4-1 -> 0.14.0-1)
[2010-06-23 22:01] upgraded poppler-glib (0.12.4-1 -> 0.14.0-1)
[2010-06-23 22:01] upgraded evince (2.30.1-2 -> 2.30.2-1)
[2010-06-23 22:01] upgraded glibc (2.12-2 -> 2.12-3)
[2010-06-23 22:01] upgraded gstreamer0.10-bad (0.10.18-5 -> 0.10.19-1)
[2010-06-23 22:01] upgraded gstreamer0.10-bad-plugins (0.10.18-5 -> 0.10.19-1)
[2010-06-23 22:02] upgraded gstreamer0.10-ugly (0.10.14-5 -> 0.10.15-1)
[2010-06-23 22:02] upgraded gstreamer0.10-ugly-plugins (0.10.14-5 -> 0.10.15-1)
[2010-06-23 22:02] upgraded gtk-doc (1.14-1 -> 1.14-2)
[2010-06-23 22:02] upgraded libtool (2.2.8-1 -> 2.2.10-1)
[2010-06-23 22:02] upgraded pm-quirks (0.20100316-1 -> 0.20100619-1)
[2010-06-23 22:02] upgraded pm-utils (1.3.0-2 -> 1.4.0-1)
[2010-06-23 22:02] upgraded rpmextract (1.0-3 -> 1.0-4)
[2010-06-23 22:02] upgraded setuptools (0.6c11-1 -> 0.6c11-2)

As you can see pm-utils and pm-quirks got update. After this update I can no longer hibernate. "pm-hibernate" only restarts my X session. Any ideas? hmm

Last edited by dcc24 (2010-07-03 15:57:37)


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

#2 2010-06-24 14:07:00

anti-destin
Member
Registered: 2009-02-14
Posts: 234

Re: [SOLVED] pm-hibernate broke after update

have you checked pm-suspend.log for errors?

Offline

#3 2010-06-24 14:27:38

dcc24
Member
Registered: 2009-10-31
Posts: 723

Re: [SOLVED] pm-hibernate broke after update

Yeah, nothing there.


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

#4 2010-06-25 06:46:39

dcc24
Member
Registered: 2009-10-31
Posts: 723

Re: [SOLVED] pm-hibernate broke after update

OK, now I see the following in pm-suspend.log:

Fri Jun 25 09:45:31 EEST 2010: performing hibernate
s2disk: Could not stat the resume device file. Reason: No such file or directory
Fri Jun 25 09:45:31 EEST 2010: Awake.

Any ideas?


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

#5 2010-06-26 14:22:23

spidernik84
Member
From: Italy
Registered: 2009-12-26
Posts: 30

Re: [SOLVED] pm-hibernate broke after update

Some problems here as well, altough the system appears to be hibernating correctly:

[CUT]
/usr/lib/pm-utils/sleep.d/90clock hibernate hibernate: success.
Running hook /usr/lib/pm-utils/sleep.d/94cpufreq hibernate hibernate:

/usr/lib/pm-utils/sleep.d/94cpufreq hibernate hibernate: success.
Running hook /usr/lib/pm-utils/sleep.d/95led hibernate hibernate:

/usr/lib/pm-utils/sleep.d/95led hibernate hibernate: success.
Running hook /usr/lib/pm-utils/sleep.d/98video-quirk-db-handler hibernate hibernate:
ATI Catalyst driver detected, not using quirks.

/usr/lib/pm-utils/sleep.d/98video-quirk-db-handler hibernate hibernate: success.
Running hook /usr/lib/pm-utils/sleep.d/99video hibernate hibernate:

/usr/lib/pm-utils/sleep.d/99video hibernate hibernate: success.
Sat Jun 26 16:11:34 CEST 2010: performing hibernate

And this is a dmesg.log excerpt:

sd 0:0:0:0: [sda] Attached SCSI disk
PM: Starting manual resume from disk
PM: Resume from partition 8:17
PM: Checking hibernation image.
PM: Error -22 checking image file
PM: Resume from disk failed.
EXT4-fs (sda1): INFO: recovery required on readonly filesystem
EXT4-fs (sda1): write access will be enabled during recovery

I can confirm that the problem didn't occur before last update. Something has changed, since i noticed that s2disk started to show system output during hibernation (hibernation progress percentage, etc), while before i only had a blinking cursor.

Last edited by spidernik84 (2010-06-26 14:25:53)

Offline

#6 2010-06-26 14:23:18

spidernik84
Member
From: Italy
Registered: 2009-12-26
Posts: 30

Re: [SOLVED] pm-hibernate broke after update

*sorry, double post roll

Last edited by spidernik84 (2010-06-26 14:23:40)

Offline

#7 2010-07-02 19:16:46

spidernik84
Member
From: Italy
Registered: 2009-12-26
Posts: 30

Re: [SOLVED] pm-hibernate broke after update

Hello dcc24, did you manage to solve this? I'm still struggling to find a way to fix this problem.

Offline

#8 2010-07-02 19:17:38

dcc24
Member
Registered: 2009-10-31
Posts: 723

Re: [SOLVED] pm-hibernate broke after update

Nope, still the same issue. Since there are no logged errors or something, I have no idea how to proceed. hmm


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

#9 2010-07-02 20:12:26

spidernik84
Member
From: Italy
Registered: 2009-12-26
Posts: 30

Re: [SOLVED] pm-hibernate broke after update

Thanks anyway, i'll keep investigating smile

Offline

#10 2010-07-02 23:10:18

zukka
Member
From: Bologna Italy
Registered: 2006-06-27
Posts: 26

Re: [SOLVED] pm-hibernate broke after update

on my eeepc I had to insert

SLEEP_MODULE="kernel"

in /etc/pm/config.d/defaults to revert to the old behaviour, it seems that  pm utils changed the tefault to uswsusp which wants the uresume hook in mkinitcpio instead of the resume hook
I hope it'll help

Offline

#11 2010-07-03 10:16:52

spidernik84
Member
From: Italy
Registered: 2009-12-26
Posts: 30

Re: [SOLVED] pm-hibernate broke after update

zukka wrote:

on my eeepc I had to insert

SLEEP_MODULE="kernel"

in /etc/pm/config.d/defaults to revert to the old behaviour, it seems that  pm utils changed the tefault to uswsusp which wants the uresume hook in mkinitcpio instead of the resume hook
I hope it'll help

You are the man! Adding the string in "defaults" fixed my problem. I'll check with the uresume hook as well!
Was this change reported during upgrade? I probably missed it, in that case tongue

Thanks for your help, i'd thank you with a button if that was present big_smile

Last edited by spidernik84 (2010-07-03 10:17:24)

Offline

#12 2010-07-03 13:20:09

dcc24
Member
Registered: 2009-10-31
Posts: 723

Re: [SOLVED] pm-hibernate broke after update

I can confirm this as well. Thanks for posting this zukka! smile


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

#13 2010-07-03 15:55:07

spidernik84
Member
From: Italy
Registered: 2009-12-26
Posts: 30

Re: [SOLVED] pm-hibernate broke after update

dcc24 wrote:

I can confirm this as well. Thanks for posting this zukka! smile

Good! big_smile
Shall we mark this as [solved] for the joy of the readers, then? tongue:D

Offline

#14 2010-07-03 15:57:46

dcc24
Member
Registered: 2009-10-31
Posts: 723

Re: [SOLVED] pm-hibernate broke after update

Well, of course big_smile


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

Board footer

Powered by FluxBB