You are not logged in.

#1 2011-09-26 23:47:42

toofishes
Developer
From: Chicago, IL
Registered: 2006-06-06
Posts: 602
Website

Postgresql 9.1.1 packages available in [testing]

The primary packages are now following the 9.1 major release branch. Some init script tweaking has been done to implement FS#25209. FS#25975 was also fixed, and psql is now in the postgresql-libs package rather than postgres if you only need a client-side install.

postgresql-old-upgrade is bumped to 9.0.5 and you can follow the upgrade instructions from the wiki.

Let me know if you have any problems with them, and better yet, if they just happen to work perfectly so I can feel confident moving them out of [testing].

Offline

#2 2011-10-06 21:54:08

ostroffjh
Member
From: Southeast Connecticut, USA
Registered: 2009-11-13
Posts: 19

Re: Postgresql 9.1.1 packages available in [testing]

Well, I didn't pay sufficient attention, and something (posgresql-libs?) conflicted with posgresql, so pacman asked to delete it, and I said yes.  However, it did delete the package, but it did so without shutting down the server.  Fortunately, installing the new version and the -old-upgrade allowed me to shut down the server before attempting the upgrade.  Note:  I don't have any important data to migrate, so I can easily purge it all and start again, and this is probably why I didn't pay enough attention.  However, I would expect a database server to be shut down before its software is uninstalled, or at least offer an opportunity to shut it down myself before it does the deletion.

Offline

#3 2011-10-06 23:25:33

toofishes
Developer
From: Chicago, IL
Registered: 2006-06-06
Posts: 602
Website

Re: Postgresql 9.1.1 packages available in [testing]

We NEVER EVER mess with running things on your system. Ever.

Your insufficient attention hurts here; I'm not sure what kind of conflict you would have seen in this upgrade, as the packages have been split pre-9.1 release.

Offline

#4 2011-10-07 00:21:32

ostroffjh
Member
From: Southeast Connecticut, USA
Registered: 2009-11-13
Posts: 19

Re: Postgresql 9.1.1 packages available in [testing]

OK - I accept that the uninstall doesn't mess with running things - would it be reasonable to issue a warning before removing a package that provides a service that is still running, or should you I just understood that once I have absorbed the arch way?

As far as the conflict, prior to the upgrade I had postgresql and postgresql-libs 9.0.4-3.  I now have postgresql and postgresql-libs 9.1.1-2.  postgresql IS in IgnorePkg in /etc/pacman.conf, but postgresql-libs is not.  Could pacman have wanted to upgrade postgresql-libs, and told me it couldn't with the old postgres there?

I assume what I should have done was cancel pacman, and install postgresql-old-upgrade, However, what is the recommended way to upgrade both postgresql and -libs?  Temporarily comment the IgnorePkg line in pacman.conf?  Manually delete and then install postgresql?  The wiki upgrade instructions don't really address this, and they don't mention the -libs package.

Offline

#5 2011-10-07 14:38:02

toofishes
Developer
From: Chicago, IL
Registered: 2006-06-06
Posts: 602
Website

Re: Postgresql 9.1.1 packages available in [testing]

ostroffjh wrote:

OK - I accept that the uninstall doesn't mess with running things - would it be reasonable to issue a warning before removing a package that provides a service that is still running, or should you I just understood that once I have absorbed the arch way?

The general understanding in Arch is we never ever touch your services. Look at what is being upgraded, and you will need to perform restarts or config changes as appropriate. Note that in 90% of cases, these upgrades are safe and don't require a restart until you want them to happen.

ostroffjh wrote:

As far as the conflict, prior to the upgrade I had postgresql and postgresql-libs 9.0.4-3.  I now have postgresql and postgresql-libs 9.1.1-2.  postgresql IS in IgnorePkg in /etc/pacman.conf, but postgresql-libs is not.  Could pacman have wanted to upgrade postgresql-libs, and told me it couldn't with the old postgres there?

If you are putting postgresql in IgnorePkg, you should have postgresql-libs there too.

ostroffjh wrote:

I assume what I should have done was cancel pacman, and install postgresql-old-upgrade, However, what is the recommended way to upgrade both postgresql and -libs?  Temporarily comment the IgnorePkg line in pacman.conf?  Manually delete and then install postgresql?  The wiki upgrade instructions don't really address this, and they don't mention the -libs package.

Update your IgnorePkg line to hold both as I mentioned above. Then after an -Syu where you notice these are being ignored, and are ready to do the upgrade, do an explicit `pacman -Sy postgresql postgresql-libs postgresql-old-upgrade`, and follow the upgrade instructions with pg_upgrade.

Please update the wiki if necessary if this makes sense and it is out of date.

Offline

#6 2011-10-07 20:12:32

ostroffjh
Member
From: Southeast Connecticut, USA
Registered: 2009-11-13
Posts: 19

Re: Postgresql 9.1.1 packages available in [testing]

Toofishes: It isn't so much that the wiki is out of date, but I updated anyway to be a bit more explicit and hopefully give a bit more guidance to less experienced users.  However, it's my first wiki edit, so I'm open to corrections or suggestions on improved wording.  Hopefully I've helped more than I've annoyed here.  Thanks for the support.

Jack

Offline

Board footer

Powered by FluxBB