You are not logged in.

#1 2011-07-22 00:24:52

JackH79
Member
From: Australia
Registered: 2009-06-18
Posts: 663
Website

[SOLVED] KDE: How to turn off notifications about Nepomuk

I've been trying to turn off the semantic dektiop features as they don't offer me any functionality I would find useful. So what I did is:

1. Disable Semantic Desktop
a: System Settings -> Desktop Search -> Basic Settings, unticked Nepomuk and Strigi
b: System Settings -> Desktop Search -> Desktop Query, unticked "Index files on removable media" and unticked every folder under "Customise index folders..."
c: System Settings -> Desktop Search -> Backup, set "Backup frequency" to Disable

2. Disable Notifications:
a: System Settings -> Application and System Notifications -> Manage Notifications, unticked all the "Show me a message in a popup" under "Desktop Search" and Semantic Desktop"

Problem:
I still get notfification popups every now and then saying:

Nepomuk Indexing Disabled
Nepomuk Indexing Agnets Have Been Disabled
The Nepomuk service is not available or fully operational and attempts to rectify this have failed. Theref...

The following problems were detected:

- Nepomuk not running.

Additional help can be found here:
userbase.kde.org/Akonadi

Could it be that it's Akonadi? I'm not quite sure about the connection between Nepomuk and Akonadi, but I'm assuming that I can run Akonadi without Nepomuk (don't want to turn off Akonadi).
Anyone know what I'm missing. Thanks

Last edited by JackH79 (2011-07-24 06:28:02)

Offline

#2 2011-07-22 01:06:00

smakked
Member
From: Gold Coast , Australia
Registered: 2008-08-14
Posts: 419

Re: [SOLVED] KDE: How to turn off notifications about Nepomuk

Try this

System Settings > Applications and system Notifications > Event Source > Desktop search

And turn off what you dont want


Certified Android Junkie
Arch 64

Offline

#3 2011-07-22 01:57:05

JackH79
Member
From: Australia
Registered: 2009-06-18
Posts: 663
Website

Re: [SOLVED] KDE: How to turn off notifications about Nepomuk

Thanks, but I've tried that already:

JackH79 wrote:

2. Disable Notifications:
a: System Settings -> Application and System Notifications -> Manage Notifications, unticked all the "Show me a message in a popup" under "Desktop Search" and Semantic Desktop"

Offline

#4 2011-07-22 02:42:42

danym
Member
From: Saint-Hippolyte, Qc
Registered: 2007-05-14
Posts: 72
Website

Re: [SOLVED] KDE: How to turn off notifications about Nepomuk

Try to edit ~/.config/akonadi/akonadiserverrc and turn

StartServer=true

to

StartServer=false


(As it says in the wiki)


sin² x + cos² x = 1

Offline

#5 2011-07-22 05:39:43

JackH79
Member
From: Australia
Registered: 2009-06-18
Posts: 663
Website

Re: [SOLVED] KDE: How to turn off notifications about Nepomuk

Thanks mate, but I

JackH79 wrote:

don't want to turn off Akonadi

,
because it's necessary to run kmail and some other programs.

Just trying to find a way of getting rid of the notifications. Any other ideas?

Offline

#6 2011-07-22 07:01:21

mangus
Member
From: Bologna, Italy
Registered: 2007-04-07
Posts: 288

Re: [SOLVED] KDE: How to turn off notifications about Nepomuk

Sadly, I don't think you can run akonadi without nepomuk imho
try asking here https://bbs.archlinux.org/viewtopic.php?id=119693
Bash, the KDE mantainer, is surely much more competent.

Last edited by mangus (2011-07-22 07:05:40)

Offline

#7 2011-07-24 06:27:37

JackH79
Member
From: Australia
Registered: 2009-06-18
Posts: 663
Website

Re: [SOLVED] KDE: How to turn off notifications about Nepomuk

Thanks mangus for the suggestion, but I didn't want to bother a developer for this. Found some information on the KDE forum though.
Apparently

bcooksley (KDE forum) wrote:

Akonadi uses Nepomuk for searching information stored in it.

but

bcooksley (KDE forum) wrote:

The file indexer (Strigi) is not required.

Doesn't really solve my issue, but I'll mark it as solved anyway.

Offline

#8 2011-08-02 18:28:31

userlander
Member
Registered: 2008-08-23
Posts: 413

Re: [SOLVED] KDE: How to turn off notifications about Nepomuk

smakked's post helped me, thanx. I had turned off nepo, strigi, etc. but kept getting the notifications. disabling them in System Settings > Manage Notifications > Event Source: Desktop Search, and then unchecking the "Show message in popup" box after selecting each one seems to have solved it for me. cheers

Offline

#9 2011-08-02 22:41:26

matse
Member
Registered: 2011-04-27
Posts: 276

Re: [SOLVED] KDE: How to turn off notifications about Nepomuk

I remember having read on the KDE Forum, that the clock - or better the calendar part of it - in the taskbar might be the source of this thing and you can disable it via right clicking the clock -> settings -> calendar -> disable here the "show events" checkbox.
Haven't tried it though, since I just activated nepomuk to get rid of this message... even if I don't use or like it.
matse

Offline

#10 2011-10-08 10:13:08

ManuP
Member
Registered: 2009-10-18
Posts: 15

Re: [SOLVED] KDE: How to turn off notifications about Nepomuk

Thx matse I searched hours for why there were notifications regarding nepomuk.

Offline

Board footer

Powered by FluxBB