You are not logged in.

#1 2005-07-10 17:30:20


{SOLVED}YAUD (yet another udev/devfs) Qestion...

Upon a new install of Arch (I went distro hoppin' for a bit...had to check out all the hype around Ubuntu) if I disable devfs via the kernel line, Arch should default to using udev no?

If so, why then when I view my fstab are the entries in the syntax of devfs (diskx) as opposed to udev (hdx)?

If not, what is the best way to NOT use devfs or to USE udev...all the different links pointing to udev upgrades in the forum and wiki have left me perplexed.

Also, during the install I formatted 8 of my 9 partitions leaving the 9th alone (it's my...saved files partition). I added it to fstab but cannot browse to it (nautilus) or cd to it (cli). During the boot process Arch is unable to locate it. How do I find this partition?

One other thing. While using Ubuntu, one feature I really dug was if I were to place a CD in the drive or use a Pen Drive (affectionately monikered JPFD's by myself and co-workers to stand for Jump/Pen/Flash Drive) a nifty icon would appear on the (gnome) desktop ready for me to use (I'm assuming that is some sort of automount feature). How do I go about achieving this same end with Arch?

#2 2005-07-10 18:28:23

From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249

Re: {SOLVED}YAUD (yet another udev/devfs) Qestion...

if you add devfs=nomount to the kernel parameters you are using udev,
arch' default fstab is using devfs naming scheme just for beeing backwards compatible, if you're using udev(which you should) it's very important that you switch to /dev/hdx scheme in your bootmanagers conffile because that will be taken out of the kernel sooner or later,

arch + gentoo + initng + python = enlisy


#3 2005-07-10 18:52:42

From: Poland
Registered: 2004-11-30
Posts: 4,018

Re: {SOLVED}YAUD (yet another udev/devfs) Qestion...

If you actually have devfs=nomount option passed to kernel via bootloader (I guess devfs is still present in vanilla?), those devfs-like entries in /dev are just mere symlinks (check with ls -l). There also should be a line 'Starting udev daemon' during bootup. If you want to have automounting, you ought to enable dbus and hal (and install gnome-volume-manager for gnome? can't tell for sure, as I don't use gnome).


#4 2005-07-12 06:55:28


Re: {SOLVED}YAUD (yet another udev/devfs) Qestion...

Thanks for your input.


For those of you attempting a new install of Arch, if you DESELECT devfs from the base install and go with udev only....make sure to do the following

Do not append devfs=nomount to grub from the outset. Leave it as is. Let the system boot and at the login '/sbin/migrate-udev' then edit your grub file and append devfs=nomount; reboot.

Coming just recently from windows, after reading more of the forum and what you guys had to say, I went with the tried and true method of format/re-install for fear I had dorked my system up beyond (my) repair. I ran into this *little* problem and had to do quite a bit of searching to find the answer. Good thing I've got the "chainloader +1 makeactive" thing down pat or I would have been at a loss.

Arch looks quite promising but unfortunately for some of us it does not "just work" quite yet. However I will continue to fight the good fight and  with the help of people like you, I think it just might be possible.

Thanks'll be hearing from me soon as I've got much to learn.

Board footer

Powered by FluxBB