You are not logged in.

#1 2011-10-12 19:03:02

Registered: 2011-10-12
Posts: 3

HP Laptop Touchpad - possibly fixed (tm2t, 4320s)

Thank you to the author of … Working.5D

for confirming my problems with touchpad and Bluetooth. My machine is the HP tm2t, but he describes the problem exactly.

Fortunately, after two and a half months, I may have stumbled on a solution: a kernel parameter.

Check /usr/src/linux/Documentation/kernel-parameters.txt for a description of kernel parameters you can tweak

(I'm on openSUSE 11.4, kernel YMMV):

Included in the parameters described in that txt is one

            [MOUSE] Maximum time between finger touching and
            leaving touchpad surface for touch to be considered
            a tap and be reported as a left button click (for
            touchpads working in absolute mode only).

using the openSUSE yast2 bootloader function I added the following Optional Command Line Parameter to grub:


After booting with that the touch pad is now stable and all the buttons work correctly.

Now if we can solve bluetooth...

Thanks again, cheers to all.

Andy Lavarre


#2 2011-10-18 09:04:54

Registered: 2009-07-28
Posts: 14

Re: HP Laptop Touchpad - possibly fixed (tm2t, 4320s)

Dear Alavarre,
thanks for the reference.
I am still using the unfortunate HP4320S laptop.

I have more likely co-lived the clickpad problems, and I use basically a workaround. The clickpad forks like one big toch-area, and my buttons are mappet virtual. I really never use the real buttons. Instead I have
touch - as click;
two-finger touch - as right-click;
trhree-finger touch - as middle-click;
horiz, vert scrolls.
and thats all I need.

The bluetooth problem, however, is the most annoying now.
I noticed it was working and then not-working again. - I could never tell or distinguish the problem.
Now, it has stopped working altogether, probably becaus my switch to wi-fi module driver from "rt2860sta" to "rt2800pci". Before that, it sometimes worked.
I have the most annoying wireless networking card: Ralink corp. RT3090 Wireless 802.11n 1T/1R PCIe, it is a combo card with bluetooth.
Now the wi-fi part works alright, but the bluetooth is dead!

I too would like to see some help here.


#3 2012-03-14 23:13:18

Registered: 2011-10-12
Posts: 3

Re: HP Laptop Touchpad - possibly fixed (tm2t, 4320s)

I haven't given up. I did some system browsing and came across a YaST module for adding Kernel Settings. yast2 > system > Kernel Settings > PCI ID Setup offers the ability to add specific hardware setups either manually or from a list. Choosing From List indeed offers our contentious

Ralink RT3090 Wireless 802.11n 1T/1R PCIe (0000:03:00.0)

So I try to add it, but the wizard demands a SysFS Directory and driver name...

     locate ralink

only offers drivers for the pae and vanilla kernels, not the mainstream kernel. Does that mean that the ralink driver is included in the kernel, not as a module?

What answer do I give for SysFS directory and driver name???

Also, … =no#Ralink

says for the RT2800 (on which the RT3090 is based)

    'ralink-firmware' package required -> auto installed by YaST

but searching for ralink-firmware returns nothing...

Cheers, Andy


#4 2012-03-29 11:27:53

Registered: 2009-07-28
Posts: 14

Re: HP Laptop Touchpad - possibly fixed (tm2t, 4320s)

I am using Arch linux. I have tons of problems with this card, and the worst part is that the problems come and go.
Some time ago (6mth) i was using rt2800pci driver, and had to modprobe blacklist the other drivers for it to work, now (after kernel jump to >3.1) there is no precompiled driver anymore, so I had to download and compile the original Ralink driver (it never really compiled very good before). However this time it did compile, and it does work! Is it plitting bunch of messages in logfiles, (that can be silenced) and the powermeter in NetworkManager is showing wrong measurements. Sometimes the connection drops completely, and (strangely) it forgets the wpa password.- Well it doesn't really forget it, it runs out of wrong replies, and the keyring panics. Then I /etc/rc.d/networkmanager restart and it picks the connection back up.
Of course the bluetooth doesn's work. It never really did!
The only way to have it working, is to boot to windows, disable the hard-key for wireless device, then boot back to linux, and enable the key again. Then the driver somehow pcks up the bluetooth radio! It is annoying. I have also the rfkill package, but it doesn't do any good here either. I was playing with it trying to simulate what the hard-key does in windows, but did not win it.
So don't buy HP shit with Ralink shit! It will dissapoint you!


#5 2012-04-15 21:29:10

Registered: 2011-10-12
Posts: 3

Re: HP Laptop Touchpad - possibly fixed (tm2t, 4320s)

Thanks for the confirmation. Yes, the bluetooth has NEVER worked. But since I don't dual boot I can't use your method to disable bluetooth in Windows and reenable under Linux... :-(

I agree, don't buy HP.

I HAVE discovered something else that seems to tame the touchpad:

I moved to openSUSE 12.1 with all the same problems recurring. But I do not have an installed mouse, just the touchpad. But I got so frustrated that I installed a USB mouse.

And now things start working.

I uninstalled the mouse (yast2 mouse) and things went back to miserable.

So I have been experimenting: installing a separate mouse driver (with or without actually connecting a USB mouse) seems to interact with the touchpad driver. For example, if you set the mouse (yast2 mouse) to left handed then the touchpad becomes left handed so you have to change all the buttons.

So the two drivers definitely do interact. I am now playing with only installing a driver (yast2 mouse) and iterating through the various options. So far, the {Intelliwheel (USB)} driver seems to calm down the touchpad the most. It almost works normally.

Now if I could find a fix for the Bluetooth.

I DID have a series of Fujitsus that worked great, so am looking to moving to the T580. Anyone had any luck there with Linux?

Cheers, Andy


#6 2012-04-17 14:03:03

Registered: 2012-04-17
Posts: 2

Re: HP Laptop Touchpad - possibly fixed (tm2t, 4320s)

I have a HP 4520s
In the past, xf86-input-synaptics-clickpad (from AUR) worked as a charm.
But this packet disappeared.

I've tried to make a patch for xf86-input-synaptics- heavily inspired from the one made by Henry Hermawan at http://henryhermawan.blo

(edited part)

I feel stupid, I have just noticed Peter Hutterer made a fix for the touchpads recently.
You just need to add
Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
in your Xorg conf

Last edited by vins31 (2012-04-17 14:39:59)


Board footer

Powered by FluxBB