You are not logged in.

#1 2011-08-02 20:47:12

thim
Member
Registered: 2011-02-17
Posts: 3

System setting connection to server failure

When I try to get new plasma themes, windows decorations etc. through system settings I get an error:

Loading of providers from file: http://download.kde.org/ocs/providers.xml failed

I installed arch recently with kde-base package if it is important.
And I think my internet connection is working well.
Has anyone got any idea how to fix it? I'd be much grateful ;D


no Arch, no cry!

Offline

#2 2011-08-02 22:34:48

Kooothor
Member
From: Paname
Registered: 2008-08-02
Posts: 222
Website

Re: System setting connection to server failure

Offline

#3 2011-09-23 07:52:14

phobophile
Member
Registered: 2011-09-22
Posts: 1

Re: System setting connection to server failure

I've got the same problem here. Also with a fresh installation of Arch + KDE (meta, full)...
When can we expect this bug to be solved?

Last edited by phobophile (2011-09-23 11:46:57)

Offline

#4 2011-10-17 07:42:29

Greyletter
Member
Registered: 2011-10-17
Posts: 3

Re: System setting connection to server failure

I just installed Arch + KDE base a few days ago. I'm getting the same thing; any updates?

Offline

#5 2011-10-17 21:30:21

SolidSNK
Member
Registered: 2008-08-01
Posts: 10

Re: System setting connection to server failure

Same here. I looked in KDE bug reports but I found no solution to the problem.

Also, it would be nice if the title could change to something more precise like: "Get Hot New Stuff failure".

Last edited by SolidSNK (2011-10-17 21:38:09)

Offline

#6 2011-10-18 04:00:25

Greyletter
Member
Registered: 2011-10-17
Posts: 3

Re: System setting connection to server failure

I found this bug report, which seemed like it might be the problem. GetHotNewStuff started working after I visited that page. I didn't do anything, or change anything, but it started working. Computers are nuts sometimes.

edit: Also, I just changed my fstab and GRUB menu list from using device nodes to UUIDs... although that doesn't seem even a little bit related.

edit 2: And now it's back, after I changed nothing. sad  Any ideas?

Last edited by Greyletter (2011-10-18 07:13:47)

Offline

#7 2011-10-18 10:59:01

SolidSNK
Member
Registered: 2008-08-01
Posts: 10

Re: System setting connection to server failure

Ok I found a solution. Please tell me if it worked for you. Although I could connect and download providers.xml from my browser, it wasn't working when I tried to download it using wget (wget http://download.kde.org/ocs/providers.xml). It seemed like wget was resolving download.kde.org into an ipv6 address. It should have worked in the first place, but I decided to try the ipv4 address instead.

So, I added

46.4.90.84 download.kde.org

to my /etc/hosts and voila, it works big_smile

Offline

#8 2012-10-02 20:03:18

cybuch
Member
Registered: 2012-02-23
Posts: 28

Re: System setting connection to server failure

@up
Your solution didn't work for me (and I used different IP address, because it seems that it has changed). I'm pretty sure that we're missing some kde package (got installed few packages from kdebase group, whole kdeutils, whole kdeadmin).

Last edited by cybuch (2012-10-02 20:03:47)

Offline

Board footer

Powered by FluxBB