You are not logged in.

#1 2011-10-17 09:46:34

8472
Member
From: Slovakia
Registered: 2010-05-15
Posts: 47

setxkbmap variant Error loading new keyboard description

Hi,

Yesterday (after a week) I've performed upgrade (pacman -Syu).
Among many, there were also several xorg-* packages.
I'm using Openbox, with:

setxkbmap -option '' -option grp:switch,grp:alt_shift_toggle,lv3:ralt_switch,eurosign:e us,de,sk -variant ,qwerty,qwerty

for keyb. layout switching, which worked well till last friday when I used it for the last time.

Today (haven't needed the function to switch the layout in the weekend), I needed to switch my keyb. layout, when I noticed it ain't working.
I've started investigating in CLI, where I noticed, that there is some problem with setxkbmap's parameter "-variant ,qwerty,qwerty".
Error message in CLI is:

Error loading new keyboard description

Without this -variant parameter, including all the rest from mine command, it works fine.
Also if I keep there only one varian, e.g. " -variant qwerty" it works, but not as it worked before, which is the case what I need.

The /var/log/Xorg.0.log shows this sort of error at each attempt to run the command with that problematic -variant parameter:

[  9441.812] (EE) Error loading keymap /tmp/server-0.xkm


What has changed in e.g. xorg-server-common after the upgrade?
Or is this some sort of a bug?

Thank you in advance for any advice.
8472


Logic clearly dictates that the needs of the many outweigh the needs of the few.

Offline

#2 2011-10-17 10:59:27

raymondcal
Member
Registered: 2010-06-16
Posts: 45

Re: setxkbmap variant Error loading new keyboard description

Same thing here just after this morning update : my keyboard is set on French (variant) in Gnome system settings, but stays in English (USA) at every boot.
I have to use the ’setxkbmap fr’ command in order to have have a french layout…

Offline

#3 2011-10-17 11:18:45

8472
Member
From: Slovakia
Registered: 2010-05-15
Posts: 47

Re: setxkbmap variant Error loading new keyboard description

raymondcal wrote:

Same thing here just after this morning update : my keyboard is set on French (variant) in Gnome system settings, but stays in English (USA) at every boot.
I have to use the ’setxkbmap fr’ command in order to have have a french layout…

but do you get the same error messages as I, posted above?

EDIT: bug report created in here https://bugs.archlinux.org/task/26485

Last edited by 8472 (2011-10-17 11:58:22)


Logic clearly dictates that the needs of the many outweigh the needs of the few.

Offline

#4 2011-10-19 18:13:14

DojoMortal
Member
Registered: 2010-04-24
Posts: 12

Re: setxkbmap variant Error loading new keyboard description

Got exactly the same problem here: french bepo keyboard gives an error, obliged to force french latin9 keyboard. But I do not get any error message of the same nature in Xorg.log

Offline

#5 2011-10-19 21:18:15

8472
Member
From: Slovakia
Registered: 2010-05-15
Posts: 47

Re: setxkbmap variant Error loading new keyboard description

so, I've finally found the reason of mine error.
I was using the QWERTY variant for the DE layout, and this has changed with the xorg-* update.
in this file is also an list of variants "/usr/share/X11/xkb/rules/xorg.lst" , and the line with QWERTY for DE is gone.
but it was present before in the form of this entry: "qwerty          de: qwerty"

thus now I have to use the -variant in the form ",,qwerty":

setxkbmap -option '' -option grp:switch,grp:alt_shift_toggle,lv3:ralt_switch,eurosign:e us,de,sk -variant ,,qwerty

damn it, I want it back!
I'm curious, if this has been caused by decision at the Xorg devepers, or if this is an mistake of package maintainer?


Logic clearly dictates that the needs of the many outweigh the needs of the few.

Offline

#6 2011-10-25 17:12:38

raymondcal
Member
Registered: 2010-06-16
Posts: 45

Re: setxkbmap variant Error loading new keyboard description

Hi !
It seems you are right : the "français (variante)" (or "french (alternative)") keymap, wich I used to use, doesn’t work anymore. I have to choose the "français" one in the Gnome3 System Settings, and then it works.
Strange…

Offline

#7 2011-10-25 17:32:02

8472
Member
From: Slovakia
Registered: 2010-05-15
Posts: 47

Re: setxkbmap variant Error loading new keyboard description

hi,

thanks to help of JGC https://bugs.archlinux.org/task/26485#comment84729 , he discovered, that the mine one de(qwerty) has been removed on a purpose by developers of xkeyboard-config http://cgit.freedesktop.org/xkeyboard-c … 47476884af
perhaps similar step has been made also on other languages.


Logic clearly dictates that the needs of the many outweigh the needs of the few.

Offline

#8 2011-11-02 19:49:26

DojoMortal
Member
Registered: 2010-04-24
Posts: 12

Re: setxkbmap variant Error loading new keyboard description

Still does not work for me sad

I use fr(bepo), fr(variant) and en(us) and I just can't select them from GNOME menu. I'm obliged to use command line to change keyboard layout… Event worst, I notice when I click on the keyboard layout settings on the gnome bar and select a layout, the layout is not changed in the gnome bar itself !

I think something wrong with my configuration but I can't figure out where… Is there a way to put gnome in debug or verbose mode somehow ?

Offline

Board footer

Powered by FluxBB