You are not logged in.

#1 2011-10-16 22:06:18

Visc
Member
Registered: 2011-10-16
Posts: 4

[SOLVED]warning: local is newer than core

Hi!

I've got a problem with pacman. When i do:

pacman -Syu

I get the following errors:

warning: initscripts: local (2011.09.2-1) is newer than core (2011.07.3-1)
warning: kbd: local (1.15.3-2) is newer than core (1.15.3-1)

I've already tried to do:


pacman-db-upgrade
pacman -Syyu

With no result.

Also I generated new mirrorlist but I'm still getting these errors.
Any other solutions?

Thanks in advance for your help!

Last edited by Visc (2011-10-18 18:18:00)

Offline

#2 2011-10-16 22:14:48

karol
Archivist
Registered: 2009-05-06
Posts: 25,438

Re: [SOLVED]warning: local is newer than core

Both packages look like they're from [testing]. Have you been using [testing] repo? You can disable it and run 'pacman -Syuu' to downgrade.
Are you using any unofficial repositories?

Offline

#3 2011-10-18 17:45:09

Visc
Member
Registered: 2011-10-16
Posts: 4

Re: [SOLVED]warning: local is newer than core

I'm not using testing repo. I'm using only official repos.
This is my repos:

#[testing]
#Include = /etc/pacman.d/mirrorlist

[core]
Include = /etc/pacman.d/mirrorlist

[extra]
Include = /etc/pacman.d/mirrorlist

#[community-testing]
#Include = /etc/pacman.d/mirrorlist

[community]
Include = /etc/pacman.d/mirrorlist

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#[custom]
#Server = file:///home/custompkgs

Last edited by Visc (2011-10-18 17:47:43)

Offline

#4 2011-10-18 17:52:06

karol
Archivist
Registered: 2009-05-06
Posts: 25,438

Re: [SOLVED]warning: local is newer than core

Run 'pacman -Syuu' and then 'pacman -Syu' - do you still get these warnings?

Offline

#5 2011-10-18 17:55:30

Visc
Member
Registered: 2011-10-16
Posts: 4

Re: [SOLVED]warning: local is newer than core

Poblem solved! I generated new mirrorlist and then pacman -Syuu. Thanks for your answers.

Offline

#6 2011-10-18 18:15:53

karol
Archivist
Registered: 2009-05-06
Posts: 25,438

Re: [SOLVED]warning: local is newer than core

Remember to mark the thread as solved.

Offline

Board footer

Powered by FluxBB