You are not logged in.

#1 2011-10-31 19:07:13

Hossan
Member
Registered: 2011-10-31
Posts: 4

[SOLVED] Ctrl+Alt+T

hi guys

sorry if my question is repeated but I can't use Ctrl+Alt+T to launch terminal.

i use gnome 3.

thank you

Last edited by Hossan (2011-11-01 12:39:49)

Offline

#2 2011-11-01 00:47:58

ngoonee
Forum Fellow
From: Between Thailand and Singapore
Registered: 2009-03-17
Posts: 7,126

Re: [SOLVED] Ctrl+Alt+T

Set your keyboard shortcuts. No idea if its meant to be a default in gnome3, but as I recall gnome has always had a utility to set/change keyboard shortcuts.


Allan-Volunteer on the (topic being discussed) mailn lists. You never get the people who matters attention on the forums.
jasonwryan-Installing Arch is a measure of your literacy. Maintaining Arch is a measure of your diligence. Contributing to Arch is a measure of your competence.
Griemak-Bleeding edge, not bleeding flat. Edge denotes falls will occur from time to time. Bring your own parachute.

Offline

#3 2011-11-01 09:25:06

jv2112
Member
Registered: 2011-07-23
Posts: 154

Re: [SOLVED] Ctrl+Alt+T

System Settings --> Keyboard --> Shortcuts .... :-)


Life is pleasant. Death is peaceful. It's the transition that's troublesome. Isaac Asimov - / -  My Pastebin

Offline

#4 2011-11-01 10:56:24

Hossan
Member
Registered: 2011-10-31
Posts: 4

Re: [SOLVED] Ctrl+Alt+T

thank you guys

already did that, but my problem is I can't set Ctrl only Alt+T ?

Offline

#5 2011-11-01 11:27:46

RichAustin
Member
From: Wakefield, Yorkshire, England
Registered: 2011-07-27
Posts: 186

Re: [SOLVED] Ctrl+Alt+T

Hossan

I went to Activities and started typing in "keyboard". Click on the Keyboard icon and when the app' opens there on the Shortcuts tab is "Launch Terminal" which was disabled. I clicked on the disabled area, held down Ctrl + Alt + T. Exit out of there and Ctrl + Alt + T works perfectly to open Gnome Terminal. Admittedly it does only show "Alt + T" in the keyboard application but it works fine and Alt + T does not open the Terminal but Ctrl + Alt + T definitely works on my Gnome 3.

Last edited by RichAustin (2011-11-01 11:29:18)

Offline

#6 2011-11-01 12:34:18

Hossan
Member
Registered: 2011-10-31
Posts: 4

Re: [SOLVED] Ctrl+Alt+T

it's wroks, thank you RichAustin. smile

Offline

#7 2011-11-02 20:21:15

bmanuel
Member
Registered: 2011-10-06
Posts: 106

Re: [SOLVED] Ctrl+Alt+T

I've the same problem, can't set CTRL+<key>, SHIFT+<key> or CTRL+SHIFT+<key> combinations, CTRL get always filtered out.
Doing the terminal thing above, only ALT+T does open a terminal for me.

Also, recording shortcuts with function keys produce very odd results, such as:

SHIFT+F5 (or any other F-key)   =>   Shift+VoidSymbol

But if also pressing CTRL, the shortcut produced is:

CTRL+SHIFT+F5 (or any other F-key)   =>   Shift+F5

These shortcuts never work btw, not the key i recorded and not the key gnome seems to record and present you after.
I'm using a Logitech Illuminated Keyboard (italian layout) and gnome has been configured for two layout, en-US and it-IT, to be switched by ALT+CAPSLOCK: i tried everything (leaving one single layout, removing layout switch shortcut... nooone let the shortcuts being recorded correctly and working, only ALT+<key> combinations work).

Anyone with the same behavior?!
Is this the reason due to which i'm not able to get Thunderbird 7 to "get all messages for all accounts" via SHIFT+F5??! Does Gnome capture something for its own magic?!

Last edited by bmanuel (2011-11-02 20:35:38)

Offline

#8 2011-11-02 20:54:36

bmanuel
Member
Registered: 2011-10-06
Posts: 106

Re: [SOLVED] Ctrl+Alt+T

An update on my problem for others with the same: i managed to customize my keybindings via gconf-editor.
First, setup the shortcuts you want, then fire up gconf-editor, navigate to /desktop/gnome/keybindings/custom<n> and changes the keys there (<Ctrl>, <Shift> and <Alt>), this way they works fine and also shows up correctly in the keyboard settings (!).

Last edited by bmanuel (2011-11-02 21:04:24)

Offline

#9 2011-11-02 21:39:12

bmanuel
Member
Registered: 2011-10-06
Posts: 106

Re: [SOLVED] Ctrl+Alt+T

Just to add more to the odds, it appears that shortcuts belonging to the "Launchers" section will behave differently from those belonging to the "Custom Shortcuts" section when recording shortcuts: for me, recording  CTRL+ALT+T for "Launch Terminal" in the "Launchers" section will label it as an "ALT+T" but the original CTRL+ALT+T shortcut will work.
Creating a custom shortcut in "Custom Shortcuts" for doing the same thing will not work the same: it will still label it "ALT+T" but the original shortcut will not work and only ALT+T will work.

For instance, i can't set a shortcut as "SHIFT+F5" or "ALT+F5" in Eclipse (Window->Preferences->General->Keys) nor i can check Thunderbird7's mail for all my accounts at once (SHIFT+F5) so it seems SHIFT/ALT+fn get masked out for some reason under some circumstances in my setup (but Eclipse will capture an "SHIFT+ALT+F5" correctly as well as any other combination)..

Offline

#10 2011-11-13 03:35:13

csousa
Member
Registered: 2009-05-04
Posts: 32

Re: [SOLVED] Ctrl+Alt+T

I'm having the same issue with Shift+F* as bmanuel...

Offline

#11 2011-11-13 03:38:10

csousa
Member
Registered: 2009-05-04
Posts: 32

Re: [SOLVED] Ctrl+Alt+T

Offline

#12 2011-11-13 13:40:46

bmanuel
Member
Registered: 2011-10-06
Posts: 106

Re: [SOLVED] Ctrl+Alt+T

I tried this patch but it didn't solve the problem for me: however, the latest gnome-control-center did it (3.2.2-1) and now everything seems to work as it should, even capturing keys for shortcuts is working correctly.
Did you update it?

Offline

#13 2011-11-13 16:59:34

csousa
Member
Registered: 2009-05-04
Posts: 32

Re: [SOLVED] Ctrl+Alt+T

I'm using KDE...

Anyway, I downgrader xkeyboard-config from 2.4 to 2.2 which solve the problem.

Last edited by csousa (2011-11-13 17:31:08)

Offline

Board footer

Powered by FluxBB