You are not logged in.

#1 2011-11-12 19:56:20

moleschott
Member
Registered: 2011-11-12
Posts: 5

GNOME 3.2.1 always starts muted

This is a weird problem but i always have to unmute volume manually. System doesn't remember my volume level. What's wrong with my system. Can anyone help me ?

Offline

#2 2011-11-12 20:33:13

karol
Archivist
Registered: 2009-05-06
Posts: 25,432

Re: GNOME 3.2.1 always starts muted

Are you using ALSA, OSS, PulseAudio?
Was it working before and only later something broke?

Offline

#3 2011-11-12 20:39:13

moleschott
Member
Registered: 2011-11-12
Posts: 5

Re: GNOME 3.2.1 always starts muted

i think i'm using alsa. I mean i'm using default one, guessed to be ALSA. Yes it was working but something broke it. I'm not experienced linux user. I can't find the problem. I tried to solve it by dconf-editor but i could'nt find any settings for this problem.

Offline

#4 2011-11-12 20:39:30

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: GNOME 3.2.1 always starts muted

can you be more precise ? is muted where? gdm, your session?


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#5 2011-11-12 20:41:46

moleschott
Member
Registered: 2011-11-12
Posts: 5

Re: GNOME 3.2.1 always starts muted

wonder wrote:

can you be more precise ? is muted where? gdm, your session?

both of them. If i unmute volume, session is unmuted. But if i don't touch on gdm, session is muted too. It's not a big problem but weird and annoying.

Offline

#6 2011-11-12 20:42:43

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: GNOME 3.2.1 always starts muted

the idea is that pulseaudio(which gnome uses default unless you messed with it) restores the latest state from logout/shutdown/restart.


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#7 2011-11-12 20:48:20

moleschott
Member
Registered: 2011-11-12
Posts: 5

Re: GNOME 3.2.1 always starts muted

wonder wrote:

the idea is that pulseaudio(which gnome uses default unless you messed with it) restores the latest state from logout/shutdown/restart.

I can hear sounds now. Problem is when i restart the system, it starts muted. I have to touch the volume slider at the top right of the shell. Alsa it starts with muted icon. When i slide the volume bar, it returns normal and i can hear sounds

Offline

#8 2011-11-12 20:49:17

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: GNOME 3.2.1 always starts muted

delete ~/.pulse* and relogin


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#9 2011-11-13 01:01:58

bmanuel
Member
Registered: 2011-10-06
Posts: 103

Re: GNOME 3.2.1 always starts muted

You may need to install alsa-utils and also make sure to add alsa to the list of DAEMONS to start at boot in your /etc/rc.conf (wiki).

Offline

#10 2013-01-07 20:46:57

sistematico
Member
From: Campo Grande / MS / Brasil
Registered: 2008-07-26
Posts: 76
Website

Re: GNOME 3.2.1 always starts muted

Same here, Speaker channel always starts muted.


Lucas Saliés Brum
blog | medium | vk | twitter | github | .share
Forgive the spelling and grammar, English is not my native language.

Offline

#11 2013-02-21 13:57:16

arghhlinux
Member
Registered: 2013-02-20
Posts: 7

Re: GNOME 3.2.1 always starts muted

I had this same problem but it's gone. I did many things that I don' know what they mean, but I guess solve was pavucontrol or alsa-utils + weird systemctl commands i found with help of search engines. Volume is mute on login screen but goes on after login.

pacman -S pavucontrol
pavucontrol

and put volume up. If this doesn't help also try installing alsa-utils and

systemctl enable alsa-store.service

Last edited by arghhlinux (2013-02-21 14:02:41)

Offline

#12 2013-02-26 18:46:34

sistematico
Member
From: Campo Grande / MS / Brasil
Registered: 2008-07-26
Posts: 76
Website

Re: GNOME 3.2.1 always starts muted

I tried all this and more, none of this resolved.

This line on rc.local dont work:

su --login lucas -c 'amixer set Speaker 100%'

Any help is welcome.

Last edited by sistematico (2013-02-26 18:48:50)


Lucas Saliés Brum
blog | medium | vk | twitter | github | .share
Forgive the spelling and grammar, English is not my native language.

Offline

#13 2013-02-26 19:10:47

MekkaGodzilla
Member
Registered: 2012-01-22
Posts: 9

Re: GNOME 3.2.1 always starts muted

Hi,
I had the same issue with a week-old install.

Solution that worked for me: install pavucontrol, launch it and set up your sound card with it.
Close pavucontrol, reboot, and you should see that the problem is solved.

Offline

#14 2013-02-27 01:10:17

sistematico
Member
From: Campo Grande / MS / Brasil
Registered: 2008-07-26
Posts: 76
Website

Re: GNOME 3.2.1 always starts muted

Fixed:

(lucas@ironhide ~):% diff /usr/share/pulseaudio/alsa-mixer/paths/analog-output.conf.orig /usr/share/pulseaudio/alsa-mixer/paths/analog-output.conf 
57c57
< volume = off
---
> volume = 100

Lucas Saliés Brum
blog | medium | vk | twitter | github | .share
Forgive the spelling and grammar, English is not my native language.

Offline

Board footer

Powered by FluxBB