You are not logged in.

#26 2011-06-21 16:25:14

viggee
Member
Registered: 2011-05-07
Posts: 22

Re: Gnome 3 Tearing

Good to hear that. Furthermore i noticed better performance with the current git versions from [testing] of intel-dri & mesa.

At the moment i'm not witnessing any problems at all, can't speak of gnome3 though.

Last edited by viggee (2011-06-21 16:26:10)

Offline

#27 2011-06-21 16:27:21

fadeddata
Member
Registered: 2011-05-07
Posts: 8

Re: Gnome 3 Tearing

Setting i915.semaphores=1 seems to resolve the issue. I'll be working all day in Arch so if there are any problems I'll probably be posting. Thanks again for all the help and support.

Offline

#28 2011-06-21 16:33:46

alexcriss
Member
Registered: 2010-05-24
Posts: 121

Re: Gnome 3 Tearing

I didn't notice problems yet, working all day as well smile At least we have a workaround till the drivers work ok.

The only small annoyance are some artefacts that don't want to disappear. They probably will be fixed when tearing is addressed in drivers.

Last edited by alexcriss (2011-06-21 17:08:48)

Offline

#29 2011-06-27 14:56:28

steffinger
Member
From: Munich/Beijing
Registered: 2011-02-07
Posts: 40

Re: Gnome 3 Tearing

Thanks for the workaround! I just installed Arch on my new Laptop (Nexoc S300) and with this workaround gnome runs like a charm.

Offline

#30 2011-06-27 16:08:25

fadeddata
Member
Registered: 2011-05-07
Posts: 8

Re: Gnome 3 Tearing

Definitely noticing artifacts. Sometimes while typing in terminal whole words will blink or disappear. Hopefully this will get resolved soon. I'm also looking at upgrading my graphics card. I'm thinking about going with an Nvidia and the proprietary drivers...

Offline

#31 2011-10-21 10:38:00

ulke
Member
Registered: 2011-04-29
Posts: 44

Re: Gnome 3 Tearing

i915.semaphores=1 changes nothing for me. The tearing does not disappear, but I'm not seeing any artefacts either. Arch AMD64, Gnome 3.2.1, intel-dri 7.11-2, xf86-video-intel 2.16.0-1, mesa 7.11-2.

I couldn't find a bug report on freedesktop.org. There is one here:
https://bugs.freedesktop.org/show_bug.cgi?id=37686
but that seems to be mainly/only about video playback. I'll write a new bug report when I find the time and post its URL here.

Offline

#32 2011-11-17 03:12:12

afonic
Member
Registered: 2007-06-21
Posts: 53

Re: Gnome 3 Tearing

Hi,

this topic is rather old but since this problem was bothering me for a while and I finally fould a solution I'd like to share it.

I am actually using Nvidia and I tried both the Nvidia and Nouveau driver neither of which didn't work on Gnome Shell (Kwin vsync was just fine) producing extreme tearing when moving windows and especially while wathing video.

Right now, given that your video card vsync works, the only way to make Gnome Shell (well Clutter actually) respect it would be:

1) Make sure vsync is enabled on your driver's options (there are directions in the wiki for that).

2) Edit /etc/enviroment and add the lines:

CLUTTER_PAINT=disable-clipped-redraws:disable-culling
CLUTTER_VBLANK=True

3) Reboot

You should have no tearing and artifacts problems should be fixed too.

If you have dual screen make sure both your screens have exactly the same frequency using xrandr. (even if the difference is very minor, like 59.8Hz and 60). You can add video modes using xrandr and gtf.


Your source for video guides!
My Linux reviews.
Currently using: Intel Core 2 Quad Q9300 @ 3.5GHz, 2GB RAM, Asus P5E, nVidia Geforce 8800GTS, Arch Linux

Offline

#33 2011-11-17 22:35:42

ulke
Member
Registered: 2011-04-29
Posts: 44

Re: Gnome 3 Tearing

The fix in #32 works for me, even though I'm using Intel Sandy Bridge. However, it makes the desktop strangely laggy. When I drag a window it always takes a moment to catch up with the mouse.

Offline

#34 2011-11-18 02:16:52

afonic
Member
Registered: 2007-06-21
Posts: 53

Re: Gnome 3 Tearing

It works without any lag in Nvidia. Maybe you can try disabling the 2nd command (CLUTTER_VBLANK=True) and try again.


Your source for video guides!
My Linux reviews.
Currently using: Intel Core 2 Quad Q9300 @ 3.5GHz, 2GB RAM, Asus P5E, nVidia Geforce 8800GTS, Arch Linux

Offline

#35 2011-11-27 16:17:32

gevan
Member
From: Thessaloniki, Greece
Registered: 2011-11-27
Posts: 1

Re: Gnome 3 Tearing

To afonic:

Thanks! You really rock. I've been searching for a solution for ages. In my case, the main problem was libreoffice+nvidia+mutter.  I had temporarily switched to my Debian installation, but once wheezy entered gnome3 the same problem appeared there, too.

Your fix works both in Arch and Debian. Archlinux forums and wiki are unparalleled.

Offline

#36 2011-11-27 18:27:57

David Batson
Member
Registered: 2011-10-13
Posts: 640

Re: Gnome 3 Tearing

afonic wrote:

Right now, given that your video card vsync works, the only way to make Gnome Shell (well Clutter actually) respect it would be:

1) Make sure vsync is enabled on your driver's options (there are directions in the wiki for that).

2) Edit /etc/enviroment and add the lines:

CLUTTER_PAINT=disable-clipped-redraws:disable-culling
CLUTTER_VBLANK=True

3) Reboot

You should have no tearing and artifacts problems should be fixed too.

I find the first line to work with my Intel HD 3000 gpu.  The second line doesn't seem to have any effect on my system.  Yes, that first line eliminates video tearing in Gnome 3 on my Fedora 15 install.  As an alternative: running Gnome Classic with Compiz also eliminates tearing on Fedora 15.

That first line is in a bug report on Gnome Bugzilla.
https://bugzilla.gnome.org/show_bug.cgi?id=657071

Offline

#37 2016-04-25 13:13:15

Akiaku_Honoyaki
Member
Registered: 2016-04-25
Posts: 2

Re: Gnome 3 Tearing

afonic wrote:

2) Edit /etc/enviroment and add the lines:

CLUTTER_PAINT=disable-clipped-redraws:disable-culling

3) Reboot

This worked perfectly, thanks!
ASUS X551MAV, Debian 8.

Offline

#38 2016-04-25 13:27:31

x33a
Forum Moderator
Registered: 2009-08-15
Posts: 3,424
Website

Re: Gnome 3 Tearing

@Akiaku_Honoyaki,

Please don't necrobump.

https://wiki.archlinux.org/index.php/Fo … bumping.22

Closing.

Offline

Board footer

Powered by FluxBB