You are not logged in.

#26 2011-11-26 11:04:31

desaparecido
Member
From: Liège, Belgium
Registered: 2010-03-14
Posts: 136

Re: [kde-unstable] KDE 4.8

Cdh wrote:

kmix keeps randomly starting to eat 100% cpu or just segfaulting with pulseaudio...

the same here, but for me, even if I need test it more, I had this problem with kmix during video-streaming (film online) in firefox.Before upgrade to 4.8b1 I never had that, so probably is about kmix-flashplayer or really only about kmix.  I will test that today witout flashplayer.


KF5 & Plasma5 (git versions) - Awesome WM
ASUS Sabertooth 990FX - AMD FX8350 - ATI Radeon HD 7970
[testing] repo

Offline

#27 2011-11-26 11:27:17

sl1pkn07
Member
From: Spanishtán
Registered: 2010-03-30
Posts: 312

Re: [kde-unstable] KDE 4.8

KCrash: Attempting to start /usr/bin/plasma-desktop from kdeinit
sock_file=/home/sl1pkn07/.kde4/socket-sL1pKn07/kdeinit4__0
KCrash: Application 'plasma-desktop' crashing...
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
sock_file=/home/sl1pkn07/.kde4/socket-sL1pKn07/kdeinit4__0
QSocketNotifier: Invalid socket 15 and type 'Read', disabling...


http://pastebin.com/xVpcjSnK

Offline

#28 2011-11-26 12:07:26

sxe
Member
From: Cologne
Registered: 2009-06-04
Posts: 93
Website

Re: [kde-unstable] KDE 4.8

Hey thx for the packages, looking good so far.

Anyway, i have these glitches:
(note: i'm not on testing repository maybe thats a problem?)

1. The plasma popups slide above the panel not behind them, like it should be.
2. In dolphin the filter ( ctrl+i ) does not work anymore. It seems like the strings you type will never executed.
3. The package "kdeplasma-addons-applets-icontasks-4.7.80-1" keeps crashing plasma. Using my own package "plasma-icontasks" from AUR works.

Thats all for now.

Offline

#29 2011-11-26 17:08:38

pano
Member
From: Stuttgart, Germany
Registered: 2008-09-08
Posts: 118

Re: [kde-unstable] KDE 4.8

I can confirm the KMix CPU issue and the icon-tasks plasmoid crashing Plasma.

Offline

#30 2011-11-26 18:25:30

SS4
Member
From: !Rochford, Essex
Registered: 2010-12-05
Posts: 699

Re: [kde-unstable] KDE 4.8

Is anyone else having problems with gwenview not loading?

[18:24:21]$  gwenview On6.png                                                                                                                                                              
gwenview(598)/kdeui (kdelibs): Attempt to use QAction "edit_redo" with KXMLGUIFactory!                                                                                                                     
gwenview(598)/kdeui (kdelibs): Attempt to use QAction "edit_undo" with KXMLGUIFactory!                                                                                                                     
gwenview(598) Gwenview::DocumentPanelPrivate::setCurrentView: No index found for current view                                                                                                              
KCrash: Application 'gwenview' crashing...                                                                                                                                                                 
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit                                                                                                                                     
sock_file=/home/lee/.kde4/socket-desktop/kdeinit4__0                                                                                                                                                                                                                                                                                       [1]+  Stopped                 gwenview On6.png                                                                                                                                                             
QSocketNotifier: Invalid socket 12 and type 'Read', disabling...                                                                                                              
 1]+  Exit 253                gwenview On6.png 

Rauchen verboten

Offline

#31 2011-11-26 19:33:43

sl1pkn07
Member
From: Spanishtán
Registered: 2010-03-30
Posts: 312

Re: [kde-unstable] KDE 4.8

gwenview no problem for me

but glitches/freeze/crash on plasma desktop make my live impossible :S (XD)

Offline

#32 2011-11-26 21:34:21

pano
Member
From: Stuttgart, Germany
Registered: 2008-09-08
Posts: 118

Re: [kde-unstable] KDE 4.8

gwenview works here too.

Offline

#33 2011-11-27 12:13:47

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: [kde-unstable] KDE 4.8

icontasks fixed in kdeplasma-addons-applets-icontasks 4.7.80-2.
No gwenview crash here.

My KMail had some minor bug (e.g. missing signature when reply), reverting the settings to default fixed it.

Offline

#34 2011-11-27 13:02:55

sl1pkn07
Member
From: Spanishtán
Registered: 2010-03-30
Posts: 312

Re: [kde-unstable] KDE 4.8

icontask fixed!

thanks bash

Offline

#35 2011-11-27 13:21:47

sl1pkn07
Member
From: Spanishtán
Registered: 2010-03-30
Posts: 312

Re: [kde-unstable] KDE 4.8

i found the plasmoid break my plasma

plasma-applet-sm_hdd.desktop (HDD status) (not this archive, all applet)

include in kdebase-workspace 4.7.80-1

Last edited by sl1pkn07 (2011-11-27 14:02:48)

Offline

#36 2011-11-28 09:39:26

ov1d1u
Member
Registered: 2011-05-30
Posts: 5

Re: [kde-unstable] KDE 4.8

On my system applications (even GTK ones) are crashing when pressing any key when using KDE 4.8 beta. If I start plasma-desktop & kwin manually the problem is solved. What could be the issue?

Last edited by ov1d1u (2011-11-28 09:50:26)

Offline

#37 2011-11-28 10:57:09

R3DKn16h7
Member
Registered: 2010-12-30
Posts: 13

Re: [kde-unstable] KDE 4.8

Very nice release... it's quite stable for a KDE beta.

I've notice issues with Rekonq, i.e. I cannot reply to forums and send things (it seems like that POST doesn't work...).
Icon Task is now  working very good (It's simply greath...)
I confirm KMix issues with CPU
Amarok crashes often when changes song...
And vistuoso seems to eat 50% CPU until I kill it.

Offline

#38 2011-11-28 10:59:25

HarD
Member
From: Russia
Registered: 2011-08-11
Posts: 30

Re: [kde-unstable] KDE 4.8

I have problem with Calligra write (from 2.3.81 to 2.3.84) .. It steel crashed always when i try insert a spreadsheet as objects.

Does anyone has such problem?

Offline

#39 2011-11-28 12:12:07

SS4
Member
From: !Rochford, Essex
Registered: 2010-12-05
Posts: 699

Re: [kde-unstable] KDE 4.8

Rolling back gwenview to the version in [extra] works.


Rauchen verboten

Offline

#40 2011-11-28 13:23:41

adee
Member
From: The Moon
Registered: 2009-11-10
Posts: 107

Re: [kde-unstable] KDE 4.8

- Gwenview segfault in nouveau_dri.so, switching to binary nvidia driver solves this (looks like the new fade effect for image switching + nouveau is the problem), but it produces other crashes too
- The QML-rewritten device notifier crashes plasma-desktop when unmounting my usb flash drive
- The new box-switcher lacks the accelerator key setup, i changed alt+tab to another effect and now I can't switch it back... classy.

+ other little Dolphin issues, so there is still work to do for the final version.

Last edited by adee (2011-11-28 13:24:15)

Offline

#41 2011-11-28 15:19:50

sl1pkn07
Member
From: Spanishtán
Registered: 2010-03-30
Posts: 312

Re: [kde-unstable] KDE 4.8

other little issue

the preview images on ARK is broken (don't show images)

Offline

#42 2011-11-29 10:22:01

sxe
Member
From: Cologne
Registered: 2009-06-04
Posts: 93
Website

Re: [kde-unstable] KDE 4.8

I found an other bug. KMix resets "bass" and "treble" settings after each boot.

Offline

#43 2011-11-29 20:49:26

Akuma
Member
From: France
Registered: 2010-10-26
Posts: 30

Re: [kde-unstable] KDE 4.8

Just installed it.
I'm really impressed that it works really fine for a Beta.

However there's some issues:
- KMix hanging/crashing when new apps start/stop to output sound (with pulseaudio at least)
- (with fglrx) Window resizing is utterly sluggish, slow and burns all CPU especially when there's a lot of window content, regardless of the compositing state (try to resize the effect list window in systemsettings->desktop effects) -- (related to http://blog.martin-graesslin.com/blog/2 … -resizing/ ) ?
- The new QML splash screen testing doesn't work, but works when booting KDE.
- Some minor Dolphin issues like expanding a tree in detailed view doesn't work as expected in most of the cases.

The rest is running fine so far, plasma is really responsive and I feel KDE boots slightly faster than it used to.
Besides for the resizing window problem, Compositing feels slightly smoother too (with fglrx).
No crashes besides KMix.

Voilà for what I could notice so far.
Althought I would like to know if other people experience this sluggish window resizing issue I have, so I can know if it comes from fglrx or KDE...

Last edited by Akuma (2011-11-29 21:00:22)

Offline

#44 2011-11-30 00:04:47

desaparecido
Member
From: Liège, Belgium
Registered: 2010-03-14
Posts: 136

Re: [kde-unstable] KDE 4.8

hi, about kmix eating cpu, after some hours in the kernel 3.1.4-1-ARCH (from testing) all works fine, no kmix 99% CPU, stable.. probably only pure coincidence.but is better than desktop freezing during amarok plays big_smile


KF5 & Plasma5 (git versions) - Awesome WM
ASUS Sabertooth 990FX - AMD FX8350 - ATI Radeon HD 7970
[testing] repo

Offline

#45 2011-11-30 00:12:04

sl1pkn07
Member
From: Spanishtán
Registered: 2010-03-30
Posts: 312

Re: [kde-unstable] KDE 4.8

desaparecido wrote:

hi, about kmix eating cpu, after some hours in the kernel 3.1.4-1-ARCH (from testing) all works fine, no kmix 99% CPU, stable.. probably only pure coincidence.but is better than desktop freezing during amarok plays big_smile

for me kmix make segfault during boot kde XD

Offline

#46 2011-12-03 21:19:19

darehanl
Member
Registered: 2006-09-08
Posts: 24

Re: [kde-unstable] KDE 4.8

Most of KDE 4.8 seem quite stable, enough for me to be using it for general daily use. However, Gwenview brings the entire desktop to a crawl when running fullscreen and eventually crashes (maybe due to the fade effect that @adee mentioned?).

Offline

#47 2011-12-04 15:26:06

Pyruzan
Member
Registered: 2010-10-19
Posts: 34

Re: [kde-unstable] KDE 4.8

Hey all,

I had the kmix problem too, but haven't seen it for a while, don't know exactly since when!

@Akuma

Regarding sluggish window resizing I hadn't noticed anything till I saw your post and checked out the cpu consumption while resizing windows, it's between 13 to 17 percent, I have an Intel Core i7 870 with HT enabled, it means 8 logical cores and 13 to 17 percent means more than a logical core occupied (for kmix it was 13 percent). So I got the same problem but not noticeable! I'm using catalyst 11.11 btw.

Offline

#48 2011-12-04 15:35:25

Pyruzan
Member
Registered: 2010-10-19
Posts: 34

Re: [kde-unstable] KDE 4.8

Oh, I forgot something, not sure if it was there before upgrading to 4.8 beta or not, but I get this trying to run digikam:

➜  ~  digikam                                          
digikam: error while loading shared libraries: libmarblewidget.so.12: cannot open shared object file: No such file or directory

Anyone else having the same problem?

KDE 4.8 beta is very responsive and stable as a beta release though smile

Offline

#49 2011-12-04 17:37:02

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,094

Re: [kde-unstable] KDE 4.8

Pyruzan wrote:

Oh, I forgot something, not sure if it was there before upgrading to 4.8 beta or not, but I get this trying to run digikam:

➜  ~  digikam                                          
digikam: error while loading shared libraries: libmarblewidget.so.12: cannot open shared object file: No such file or directory

Anyone else having the same problem?

This happens in every major KDE update. You need to recompile digikam against marble 4.8

Offline

#50 2011-12-04 22:04:53

pano
Member
From: Stuttgart, Germany
Registered: 2008-09-08
Posts: 118

Re: [kde-unstable] KDE 4.8

I think I solved my kmix problem by removing everything kmix related from the kde config folder.
At least right now, even though I started a Flash video, KMix does not consume 100% CPU.

edit:

Unfortunately the same problem just occurred again… So the statement above is invalid, please disregard it^^

Last edited by pano (2011-12-04 23:34:05)

Offline

Board footer

Powered by FluxBB