You are not logged in.

#1 2005-07-20 20:06:03

Greycloack
Member
Registered: 2004-03-05
Posts: 166

Cd audio problems

Hello, I recently tried to play audio cd's on my computer (didn't do it for a long time)
I installed apolos and it saw the disc, even downloaded the data from cddb. It seemed like it started playing, the time bar moved and all but no sound.
I checked my alsamixer - nothing muted - I checked it all.

Next thing I searched the forum and saw an old thread with a similar problem but no solution.

The only thing that managed to play the discs was xmms with "digital extraction" enabled.
The cdparanoia plugin only played 3 seconds of a song and then stuck.

If anyone has any insight on the subject I'd be very glad to hear...

Offline

#2 2005-07-20 23:24:28

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: Cd audio problems

What are your Master and CD volumes?

Offline

#3 2005-07-20 23:41:37

Stinky
Member
From: The Colony, TX
Registered: 2004-05-28
Posts: 187

Re: Cd audio problems

I saw this type of thing the other day and the CD input channel was muted.  Volume was all the way up, just muted.  Might double-check that.

Offline

#4 2005-07-21 05:42:56

scarecrow
Member
From: Greece
Registered: 2004-11-18
Posts: 714

Re: Cd audio problems

Is digital playback (not extraction) enabled for your device?


Microshaft delenda est

Offline

#5 2005-07-21 06:29:20

Greycloack
Member
Registered: 2004-03-05
Posts: 166

Re: Cd audio problems

Ok, checked the channels again and I guess I did miss something  :oops:

I have an intel sound card, one of those snd-intel8x0. It has a channel called "pcm out" that can be set to "post 3D" and "pre 3D".
When it's set to post, music (mp3s) sounds better (on my computer) but no cd sound.
When it's set to pre, in mp3s the singer sounds muted a bit but apolos plays the CD just fine

I have no idea what that means...

scareccrow : how do I enable digital playback?

Offline

#6 2005-07-21 11:08:02

scarecrow
Member
From: Greece
Registered: 2004-11-18
Posts: 714

Re: Cd audio problems

Greycloack wrote:

scareccrow : how do I enable digital playback?

It's already there, and used by default by the common sound engines (artsd, xine, etc). You have to use the setting within your frontend, e.g for "kscd" there is such a setting under "extras".
Make sure your current user belongs to the "optical" group (and "audio", of course).
Some old CD-ROMS create horrible noices (jitter) with it enabled- in that case you have to use an internal cable to the soundcard and bypass digital playback.


Microshaft delenda est

Offline

#7 2005-07-21 12:06:00

Greycloack
Member
Registered: 2004-03-05
Posts: 166

Re: Cd audio problems

Hmm...
As far as I know I don't really use a specific engine besides alsa.

I play my mp3's with MPD configured to alsa these days and before that I used BMP with alsa output...

I don't even have xine or arts installed :-)
Do you know of an option to enable digital playback in alsa?

I didn't see any option like that in apolos so maybe it doesn't support that option.

Also, I'm using a laptop, and it's rather new, so I guess no cable connecting for me  wink

Offline

Board footer

Powered by FluxBB