You are not logged in.

#1 2011-12-03 23:49:36

thehodapp
Member
Registered: 2010-11-08
Posts: 30

[SOLVED] pip doesn't install applications correctly

I'm trying to install some programs with pip. However, there is something wrong with it because the programs I install do not work correctly and there are loads of syntax errors. I am not sure if the problem stems from python.

Here is the output from

pip install hyde
Downloading/unpacking hyde
  Real name of requirement hyde is hyde
  Running setup.py egg_info for package hyde
    
Requirement already satisfied (use --upgrade to upgrade): argparse in /usr/lib/python3.2/site-packages (from hyde)
Requirement already satisfied (use --upgrade to upgrade): commando in /usr/lib/python3.2/site-packages (from hyde)
Requirement already satisfied (use --upgrade to upgrade): jinja2 in /usr/lib/python3.2/site-packages (from hyde)
Requirement already satisfied (use --upgrade to upgrade): pyYAML in /usr/lib/python3.2/site-packages (from hyde)
Requirement already satisfied (use --upgrade to upgrade): markdown in /usr/lib/python3.2/site-packages (from hyde)
Requirement already satisfied (use --upgrade to upgrade): smartypants in /usr/lib/python3.2/site-packages (from hyde)
Requirement already satisfied (use --upgrade to upgrade): pygments in /usr/lib/python3.2/site-packages (from hyde)
Requirement already satisfied (use --upgrade to upgrade): typogrify-hyde in /usr/lib/python3.2/site-packages (from hyde)
Installing collected packages: hyde
  Running setup.py install for hyde
    
    Installing hyde script to /usr/bin
      File "/usr/lib/python3.2/site-packages/hyde/ext/templates/jinja.py", line 107
        print u"Requires AsciiDoc library to use AsciiDoc tag."
              ^
    SyntaxError: invalid syntax
    
      File "/usr/lib/python3.2/site-packages/hyde/ext/plugins/markings.py", line 27
        return u'^§§+\s*([A-Za-z0-9_\-]+)\s*$'
                                             ^
    SyntaxError: invalid syntax
    
      File "/usr/lib/python3.2/site-packages/hyde/ext/plugins/tagger.py", line 185
        meta_text = u''
                      ^
    SyntaxError: invalid syntax
    
      File "/usr/lib/python3.2/site-packages/hyde/ext/plugins/stylus.py", line 112
        except subprocess.CalledProcessError, e:
                                            ^
    SyntaxError: invalid syntax
    
      File "/usr/lib/python3.2/site-packages/hyde/ext/publishers/pypi.py", line 52
        print "Username: ",
                         ^
    SyntaxError: invalid syntax
    
      File "/usr/lib/python3.2/site-packages/hyde/ext/publishers/pyfs.py", line 50
        print "Username: ",
                         ^
    SyntaxError: invalid syntax
    
      File "/usr/lib/python3.2/site-packages/hyde/engine.py", line 40
        except HydeException, he:
                            ^
    SyntaxError: invalid syntax
    
      File "/usr/lib/python3.2/site-packages/hyde/lib/pygments/rst_directive.py", line 79
        parsed = highlight(u'\n'.join(self.content), lexer, formatter)
                               ^
    SyntaxError: invalid syntax
    
      File "/usr/lib/python3.2/site-packages/hyde/tests/ext/test_textlinks.py", line 46
        text = u"""
    {%% markdown %%}
    [[!!img/hyde-logo.png]]
    *   [Rich object model][hyde objects] and
        [overridable hierarchical metadata]([[ %(plugins)s ]]) thats available for use in
        templates.
    *   Configurable [sorting][], filtering and grouping support.
    
    [hyde objects]: [[ %(objects)s ]]
    [sorting]: [[%(sorter)s]]
    {%% endmarkdown %%}
    """
    
    
    
    
    
    
    
    
    
    
    
       ^
    SyntaxError: invalid syntax
    
      File "/usr/lib/python3.2/site-packages/hyde/tests/ext/test_syntext.py", line 35
        text = u"""
    ~~~~~~~~css~~~~~~~
    .body{
        background-color: white;
    }
    ~~~~~~~~~~~~~~~~~~
    """
    
    
    
    
    
    
       ^
    SyntaxError: invalid syntax
    
      File "/usr/lib/python3.2/site-packages/hyde/tests/ext/test_tagger.py", line 220
        print q
              ^
    SyntaxError: invalid syntax
    
      File "/usr/lib/python3.2/site-packages/hyde/tests/ext/test_images.py", line 53
        text = u"""
    <img src="/media/img/%s">
    """ % IMAGE_NAME
    
    
       ^
    SyntaxError: invalid syntax
    
      File "/usr/lib/python3.2/site-packages/hyde/tests/ext/test_markings.py", line 56
        text = u"""
    ===
    is_processable: False
    ===
    {% filter markdown|typogrify %}
    §§ heading
    This is a heading
    =================
    §§ /heading
    
    §§ content
    Hyde & Jinja
    §§ /
    
    {% endfilter %}
    """
    
    
    
    
    
    
    
    
    
    
    
    
    
    
    
       ^
    SyntaxError: invalid syntax
    
      File "/usr/lib/python3.2/site-packages/hyde/tests/test_fs.py", line 290
        utxt = u'åßcdeƒ'
                       ^
    SyntaxError: invalid syntax
    
      File "/usr/lib/python3.2/site-packages/hyde/tests/test_plugin.py", line 26
        print "NoReturnPlugin"
                             ^
    SyntaxError: invalid syntax
    
      File "/usr/lib/python3.2/site-packages/hyde/tests/test_jinja2template.py", line 50
        users = map(User, [u'John Doe', u'Jane Doe', u'Peter Somewhat'])
                                     ^
    SyntaxError: invalid syntax
    
      File "/usr/lib/python3.2/site-packages/hyde/plugin.py", line 340
        except subprocess.CalledProcessError, error:
                                            ^
    SyntaxError: invalid syntax
    
      File "/usr/lib/python3.2/site-packages/hyde/server.py", line 198
        except Exception, exception:
                        ^
    SyntaxError: invalid syntax
    
Successfully installed hyde
Cleaning up...

and if I try to run hyde:

Traceback (most recent call last):
  File "/usr/bin/hyde", line 9, in <module>
    load_entry_point('hyde==0.8.4', 'console_scripts', 'hyde')()
  File "/usr/lib/python3.2/site-packages/pkg_resources.py", line 337, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python3.2/site-packages/pkg_resources.py", line 2280, in load_entry_point
    return ep.load()
  File "/usr/lib/python3.2/site-packages/pkg_resources.py", line 1990, in load
    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
  File "/usr/lib/python3.2/site-packages/hyde/main.py", line 6, in <module>
    from hyde.engine import Engine
  File "/usr/lib/python3.2/site-packages/hyde/engine.py", line 40
    except HydeException, he:
                        ^
SyntaxError: invalid syntax

Now running

pip install wok

it doesn't even install and I get:

Downloading/unpacking wok
  Real name of requirement wok is wok
  Downloading wok-0.8.0.tar.gz
  Running setup.py egg_info for package wok
    Traceback (most recent call last):
      File "<string>", line 14, in <module>
      File "/home/dennis/build/wok/setup.py", line 5, in <module>
        from wok import version
      File "wok/__init__.py", line 1
        version = u'0.8.0'
                         ^
    SyntaxError: invalid syntax
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):

  File "<string>", line 14, in <module>

  File "/home/dennis/build/wok/setup.py", line 5, in <module>

    from wok import version

  File "wok/__init__.py", line 1

    version = u'0.8.0'

                     ^

SyntaxError: invalid syntax

----------------------------------------
Command python setup.py egg_info failed with error code 1
Storing complete log in /root/.pip/pip.log

Is this a problem with pip or python?

Last edited by thehodapp (2011-12-04 07:56:28)

Offline

#2 2011-12-04 00:22:12

foutrelis
Developer/TU
From: Athens, Greece
Registered: 2008-07-28
Posts: 675
Website

Re: [SOLVED] pip doesn't install applications correctly

You are trying to install Python applications that are not compatible with Python 3.

Try using the pip2 command from the python2-pip package.

Offline

#3 2011-12-04 07:54:20

thehodapp
Member
Registered: 2010-11-08
Posts: 30

Re: [SOLVED] pip doesn't install applications correctly

Does the trick! Thanks a lot!

Offline

Board footer

Powered by FluxBB