You are not logged in.

#1 2011-12-05 00:34:17

Larsson
Member
From: Sweden
Registered: 2010-03-22
Posts: 155

[SOLVED]Can't unblock wireless with rfkill on emachine e525

edit:  Had added acpi=off to fix a black screen, and this seemed to affect also the wireless. Booting without it made the screen go black but the wireless button works (the led is shining). So this is partly solved, only need to play around with acpi. :P

Installed arch on a emachine e525. The wireless device according to lspci is Atheros AR9285. The ath9k module is loaded correctly and iwconfig lists wlan0.
iwlist wlan0 scan fails saying that interface doesn't support scanning because the network is down. 

Now looking at rfkill list:

0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

So it seems that wifi is locked. Pressing the wifi button on the laptop does nothing (although it works in windows after installting the atheros drivers), and unblocking the hard block through rfkill is not possible.

I am thinking that perhaps there are some firmware missing. I've also read on some other thread (with a different laptop) saying that some modules conflict with ath9k, so I post the loaded modules just in case:

ipv6  ext2  joydev snd_hda_codec_realtek arc4 snd_hda_intel snd_hda_codec snd_hwdep snd_pcm snd_timer snd soundecore snd_page_alloc ath9k psmouse pcspkr serio_raw mac80211 ath9k_common intel_agp intel_gtt uvcvideo videodev evdev ath9k_hw ath video cfg80211 atl1c media agpgart i2c_i801 i2c_core iTCO_wdt iTCO_vendor_support rfkill ext4 mbcache jbd2 crc16 sr_mod cdrom sd_mod uhci_hcd ahci libahci libata ehci_hcd scsi_mod usbcore

Any ideas how to fix this?

Last edited by Larsson (2011-12-05 00:48:49)


"If the person you are talking to doesn't appear to be listening, be patient. It may simply be that he has a small piece of fluff in his ear." - A.A. Milne (Winnie-the-Pooh)

Offline

Board footer

Powered by FluxBB