You are not logged in.

#1 2011-04-17 18:35:47

hoschi
Member
From: Ulm (Germany)
Registered: 2008-11-03
Posts: 356
Website

[solved] Crash with newest ati-dri and all OpenGL-Applications

Hi,
since the last update to the ati-dri-package (git) in testing, my system always hangs in glxgears or ioquake3 after some seconds. The gnome-shell from Gnome3 itselfs runs smooth and without problems.

Can anyone confirm?

dmesg after ioquake3 freaks out...

radeon 0000:02:00.0: GPU lockup CP stall for more than 10004msec
------------[ cut here ]------------
WARNING: at drivers/gpu/drm/radeon/radeon_fence.c:246 radeon_fence_wait+0x2f1/0x350()
Hardware name: Aspire 3820                    
GPU lockup (waiting for 0x0000C966 last fence id 0x0000C962)
Modules linked in: uvcvideo
Pid: 1635, comm: Xorg Not tainted 2.6.39-rc2 #5
Call Trace:
 [<ffffffff810447fb>] ? warn_slowpath_common+0x7b/0xc0
 [<ffffffff810448f5>] ? warn_slowpath_fmt+0x45/0x50
 [<ffffffff8136f971>] ? radeon_fence_wait+0x2f1/0x350
 [<ffffffff81060420>] ? add_wait_queue+0x60/0x60
 [<ffffffff8133abca>] ? ttm_bo_wait+0xba/0x1c0
 [<ffffffff8133bd53>] ? ttm_bo_reserve+0x83/0xb0
 [<ffffffff813884f9>] ? radeon_gem_wait_idle_ioctl+0x89/0x120
 [<ffffffff813273ec>] ? drm_ioctl+0x3cc/0x490
 [<ffffffff81388470>] ? radeon_gem_busy_ioctl+0x150/0x150
 [<ffffffff8100b78f>] ? save_i387_xstate+0xef/0x200
 [<ffffffff81052632>] ? recalc_sigpending+0x12/0x50
 [<ffffffff81002478>] ? do_signal+0x478/0x740
 [<ffffffff810fe06e>] ? do_vfs_ioctl+0x8e/0x4f0
 [<ffffffff81002aec>] ? sys_rt_sigreturn+0x21c/0x230
 [<ffffffff810fe519>] ? sys_ioctl+0x49/0x80
 [<ffffffff816f507b>] ? system_call_fastpath+0x16/0x1b
---[ end trace 1339bdb65fdd8e02 ]---
radeon 0000:02:00.0: GPU softreset 
radeon 0000:02:00.0:   GRBM_STATUS=0xA20039A0
radeon 0000:02:00.0:   GRBM_STATUS_SE0=0x00000007
radeon 0000:02:00.0:   GRBM_STATUS_SE1=0x00000007
radeon 0000:02:00.0:   SRBM_STATUS=0x200000C0
radeon 0000:02:00.0:   GRBM_SOFT_RESET=0x00007F6B
radeon 0000:02:00.0:   GRBM_STATUS=0x00003828
radeon 0000:02:00.0:   GRBM_STATUS_SE0=0x00000007
radeon 0000:02:00.0:   GRBM_STATUS_SE1=0x00000007
radeon 0000:02:00.0:   SRBM_STATUS=0x200000C0
radeon 0000:02:00.0: GPU reset succeed
radeon 0000:02:00.0: WB enabled
[drm] ring test succeeded in 1 usecs
[drm] ib test succeeded in 1 usecs
radeon 0000:02:00.0: GPU lockup CP stall for more than 10060msec
------------[ cut here ]------------
WARNING: at drivers/gpu/drm/radeon/radeon_fence.c:246 radeon_fence_wait+0x2f1/0x350()
Hardware name: Aspire 3820                    
GPU lockup (waiting for 0x000133CC last fence id 0x000133C7)
Modules linked in: uvcvideo
Pid: 1635, comm: Xorg Tainted: G        W   2.6.39-rc2 #5
Call Trace:
 [<ffffffff810447fb>] ? warn_slowpath_common+0x7b/0xc0
 [<ffffffff810448f5>] ? warn_slowpath_fmt+0x45/0x50
 [<ffffffff8136f971>] ? radeon_fence_wait+0x2f1/0x350
 [<ffffffff81060420>] ? add_wait_queue+0x60/0x60
 [<ffffffff8133abca>] ? ttm_bo_wait+0xba/0x1c0
 [<ffffffff8133bd53>] ? ttm_bo_reserve+0x83/0xb0
 [<ffffffff813884f9>] ? radeon_gem_wait_idle_ioctl+0x89/0x120
 [<ffffffff813273ec>] ? drm_ioctl+0x3cc/0x490
 [<ffffffff81388470>] ? radeon_gem_busy_ioctl+0x150/0x150
 [<ffffffff8100b78f>] ? save_i387_xstate+0xef/0x200
 [<ffffffff81052632>] ? recalc_sigpending+0x12/0x50
 [<ffffffff81002478>] ? do_signal+0x478/0x740
 [<ffffffff810fe06e>] ? do_vfs_ioctl+0x8e/0x4f0
 [<ffffffff81002aec>] ? sys_rt_sigreturn+0x21c/0x230
 [<ffffffff810fe519>] ? sys_ioctl+0x49/0x80
 [<ffffffff816f507b>] ? system_call_fastpath+0x16/0x1b
---[ end trace 1339bdb65fdd8e03 ]---
radeon 0000:02:00.0: GPU softreset 
radeon 0000:02:00.0:   GRBM_STATUS=0xA20039A0
radeon 0000:02:00.0:   GRBM_STATUS_SE0=0x00000007
radeon 0000:02:00.0:   GRBM_STATUS_SE1=0x00000007
radeon 0000:02:00.0:   SRBM_STATUS=0x200000C0
radeon 0000:02:00.0:   GRBM_SOFT_RESET=0x00007F6B
radeon 0000:02:00.0:   GRBM_STATUS=0x00003828
radeon 0000:02:00.0:   GRBM_STATUS_SE0=0x00000007
radeon 0000:02:00.0:   GRBM_STATUS_SE1=0x00000007
radeon 0000:02:00.0:   SRBM_STATUS=0x200000C0
radeon 0000:02:00.0: GPU reset succeed
radeon 0000:02:00.0: WB enabled
[drm] ring test succeeded in 1 usecs
[drm] ib test succeeded in 1 usecs

// edit
Update fixed that issue.

Last edited by hoschi (2011-05-20 14:19:18)

Offline

#2 2011-12-06 06:34:03

hepinglu
Member
Registered: 2011-12-06
Posts: 1

Re: [solved] Crash with newest ati-dri and all OpenGL-Applications

How did you fix the issue? ati-dri-package updated?

Offline

Board footer

Powered by FluxBB