You are not logged in.

#226 2011-09-11 16:44:28

Doomcide
Member
Registered: 2011-08-22
Posts: 221

Re: The Console Display Manager

anonymous_user wrote:

I just realized that when using CDM, my .bash_profile does not get sourced. Any workaround for this (other than putting everything in .bashrc)?

Same here...

Edit: A workaround would be to add

source /home/USERNAME/.bash_profile

to ~/.xinitrc

Last edited by Doomcide (2011-09-11 19:06:48)

Offline

#227 2011-09-11 23:39:29

Mektub
Member
From: Lisbon /Portugal
Registered: 2008-01-02
Posts: 647

Re: The Console Display Manager

Doomcide wrote:
anonymous_user wrote:

I just realized that when using CDM, my .bash_profile does not get sourced. Any workaround for this (other than putting everything in .bashrc)?

Same here...

Edit: A workaround would be to add

source /home/USERNAME/.bash_profile

to ~/.xinitrc

My .bash_profile gets sourced. I have an 'echo' at the beginning of ~/.bash_profile and ~/.bashrc and on a terminal I get:

IN /home/john/.bash_profile
IN /home/john/.bashrc

Using cdm 0.5.3-1 on linux 3.0.4-1

Mektub


Follow me on twitter: https://twitter.com/johnbina

Offline

#228 2011-09-13 20:28:31

Doomcide
Member
Registered: 2011-08-22
Posts: 221

Re: The Console Display Manager

^Could you please explain this?
With echo do you mean something like this?

# echo ~/.bash_profile

That doesn't work for me either.
Also: What command gives you

Mektub wrote:
IN /home/john/.bash_profile
IN /home/john/.bashrc

?

Offline

#229 2011-09-13 22:36:27

Mektub
Member
From: Lisbon /Portugal
Registered: 2008-01-02
Posts: 647

Re: The Console Display Manager

Doomcide,

in my ~/.bash_profile I have as first lines:

#!/bin/sh
# .bash_profile

echo "IN $HOME/.bash_profile"

So I know it gets executed.
Apart from that I have several initializations that get done correctly.

Perhaps the /etc/cdmrc configuration as influence on this ?
In particular I have in there:

consolekit=no

Mektub


Follow me on twitter: https://twitter.com/johnbina

Offline

#230 2011-10-08 02:11:41

denstark
Member
Registered: 2005-08-05
Posts: 15
Website

Re: The Console Display Manager

I've been using CDM for a while now, and am totally loving it.

I have encountered an odd issue.. any user past the first to log in, the X session just won't spawn. I tried to look for some log files but didn't see any relating to cdm. When the second user logs in, the menu comes up and I select xfce (which works for this same user if they are the first to log in) and then the screen flashes, and then they're put back to a login prompt. I haven't changed my cdmrc recently so I'm not sure what's caused this -- any ideas?

/etc/cdmrc: http://pastebin.ca/2087874

both users .xinitrc: http://pastebin.ca/2087875

Thank you!

Edit:

After thinking a bit, I wanted to see what was running when the second user was logging in, so I set up a ps loop w/ grep and found out that when cdm was starting the xsession, it was trying to do so on :0 again, even though it should have auto incremented. I am going to try to use locktty for the time being, but if anyone knows why this may be happening, I'd like to get it back to the autoincrement.

The line I grabbed from ps:

xinit /home/cathy/.xinitrc startxfce4 -- /usr/bin/X :0 -nolisten tcp -dpi 96 vt7 -auth /tmp/serverauth.i5FI4sPelP

Last edited by denstark (2011-10-09 06:37:27)

Offline

#231 2011-11-07 07:09:17

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 18,051
Website

Re: The Console Display Manager

Anyone else seeing this sort of b0rked rendering?
cdm.png

I downgraded to dialog-1.1_20110707-1 and that fixes it...


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#232 2011-11-07 08:16:19

Diaz
Member
From: Lisbon, Portugal
Registered: 2008-04-16
Posts: 361
Website

Re: The Console Display Manager

Those look like shadows problems... make sure you have the Composite extension loaded and... oh wait, nevermid tongue


Owner of Asus 1215B :: User of Xfce :: Vasco Dias @blog

Offline

#233 2011-11-07 12:54:23

markoer
Member
Registered: 2010-12-15
Posts: 55

Re: The Console Display Manager

jasonwryan wrote:

Anyone else seeing this sort of b0rked rendering?
http://dl.dropbox.com/u/261312/cdm.png

I downgraded to dialog-1.1_20110707-1 and that fixes it...

you don't need to downgrade dialog, the white lines are not defined in your theme upon new dialog release, because developers added few new variables , so just add these two and customize it to your need's

border2_color = 
menubox_border2_color = 

Offline

#234 2011-11-07 17:16:40

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 18,051
Website

Re: The Console Display Manager

Thanks markoer smile

I read the changelog but it didn't mention any new properties...


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#235 2011-11-29 10:46:13

Mr. Alex
Member
Registered: 2010-08-26
Posts: 623

Re: The Console Display Manager

I didn't read the whole discussion but I guess I can't enter login and password with CDM?

Offline

#236 2011-12-07 01:08:29

TheShadowFog
Member
Registered: 2011-11-24
Posts: 21
Website

Re: The Console Display Manager

Does anyone no where I can download this? the PKGBUILD doesn't work because of a dead link.

edit: Found: https://github.com/ghost1227/cdm

Last edited by TheShadowFog (2011-12-07 01:20:16)

Offline

#237 2011-12-07 09:59:10

Mr. Alex
Member
Registered: 2010-08-26
Posts: 623

Re: The Console Display Manager

Install "cdm-git" from AUR.

Offline

#238 2011-12-16 22:35:21

Teyras
Member
Registered: 2010-07-14
Posts: 36

Re: The Console Display Manager

Hi, is there any "proper" way to start KDE from CDM? If I try it using consolekit, it just waits until the timer goes out and if I try to use xinit, I'm returned instantly to the login prompt. I'd prefer consolekit, is there any way to fix this? Anyway, my config is vanilla (except the kde entry ofc).

Offline

#239 2011-12-17 05:15:42

flaque
Member
From: Rosario, Argentina
Registered: 2011-04-15
Posts: 22

Re: The Console Display Manager

Teyras wrote:

Hi, is there any "proper" way to start KDE from CDM? If I try it using consolekit, it just waits until the timer goes out and if I try to use xinit, I'm returned instantly to the login prompt. I'd prefer consolekit, is there any way to fix this? Anyway, my config is vanilla (except the kde entry ofc).

Months ago when I used CDM, I had to use .xinitrc to start sessions using consolekit (look for the corresponding line in cdmrc) as the alternative ways wouldn't work.

I believe you should have no problem doing the same thing right now smile

Offline

#240 2011-12-17 20:48:42

Teyras
Member
Registered: 2010-07-14
Posts: 36

Re: The Console Display Manager

flaque wrote:
Teyras wrote:

Hi, is there any "proper" way to start KDE from CDM? If I try it using consolekit, it just waits until the timer goes out and if I try to use xinit, I'm returned instantly to the login prompt. I'd prefer consolekit, is there any way to fix this? Anyway, my config is vanilla (except the kde entry ofc).

Months ago when I used CDM, I had to use .xinitrc to start sessions using consolekit (look for the corresponding line in cdmrc) as the alternative ways wouldn't work.

I believe you should have no problem doing the same thing right now smile

Well, I wish you were right, but when trying to start KDE, it just waits for the timeout for consolekit to register an X session and then logs me into a console...

Offline

#241 2012-03-02 13:53:12

flako
Member
Registered: 2008-10-24
Posts: 56

Re: The Console Display Manager

I've been trying to make CDM work with console-kit, and udisks to enable automounting but it just doesn't work. No matter what I do, the console-kit-session doesn't wrap properly. I changed my cdmrc to call my xinit, and it still won't work.
I checked the source and tried to run the command

nohup startx awesome -- -nolisten tcp -dpi 96 &> /dev/null &

from console and it just starts the xinitrc located in /etc/X11/xinit/

But if I run this instead

nohup xinit awesome -- -nolisten tcp -dpi 96 &> /dev/null &

then everything works as it should. So I tried changing the code in CDM to use xinit instead of startx (what's the difference anyway?) but that didn't work either. So I'm kind of stuck here.

Here are my config files

#!/bin/sh
#
# ~/.xinitrc
#
# Executed by startx (run your window manager from here)

#if [ -d /etc/X11/xinit/xinitrc.d ]; then
#  for f in /etc/X11/xinit/xinitrc.d/*; do
#    [ -x "$f" ] && . "$f"
#  done
#  unset f
#fi

# exec gnome-session
# exec startkde
# exec startxfce4
# ...or the Window Manager of your choice
exec ck-launch-session dbus-launch $1
############################
### GLOBAL CONFIGURATION ###
############################

# Set CDM theme and dialog options
theme=cdm
countfrom=1

# List all WM binary names
wmbinlist=(ratpoison openbox-session awesome)

# List all WM display names
wmdisplist=(Ratpoison Openbox Awesome) 

# Allow console login?
allowconsole=yes

# Allow shutdown?
allowshutdown=yes
shutdowncommand='sudo shutdown -h now'
rebootcommand='sudo shutdown -r now'

# Allow suspend?
# Note that this option requires pm-utils
# to be installed and properly configured.
allowsuspend=no
suspendcommand='sudo pm-suspend'
allowhibernate=no
hibernatecommand='sudo pm-hibernate'

# Set configuration for specific users?
userconfig=(courtney)

##########################
### USER CONFIGURATION ###
##########################

courtney() {
        # Set CDM theme
        theme=lime

        # List user allowed WM binary names
        wmbinlist=(openbox-session)

        # List user allowed WM display names
        wmdisplist=(Openbox)

        # Allow console login?
        allowconsole=yes

        # Allow shutdown?
        allowshutdown=no

        # Set specific display for user
        # (Not honored unless locktty=yes)
        # display=1
}

############################
### SYSTEM CONFIGURATION ###
############################

# Set default display
display=0

# Where should first X tty be spawned?
xtty=7

# Restrict tty? (By default, cdm increments X tty, this setting
# allows administrators to lock users into one specific tty by
# setting the display=N option on a per-user basis.)
locktty=no

# Enable login shell (fixes issues with some keymaps, uses bash).
# Note that your bash scripts won't have any terminal as stdin when
# started in this way. This may break some commands, including stty,
# unless you explicitly check for [ -t 0 ] or that every login shell
# is also interactive. However, we're sending stdout and stderr to
# /dev/null, so you won't see the complaints.
loginshell=no

# The use of consolekit has recently become manditory with hal. However,
# some users might prefer not using either one. If you don't want to
# use consolekit, set the following variable to "no".
consolekit=no

# Timeout for waiting for X session to register with consoleKit
consolekittime=30

# Additional arguments to pass to X server
# When usexinit=yes, we use ~/.xinitrc when it exists or /etc/X11/xinit/xinitrc
# when it doesn't. These are passed the chosen window manager as $1; note that
# the stock /etc/X11/xinit/xinitrc ignores this and always starts twm and three
# xterms. Your custom xinitrc should start the window manager supplied as $1
# instead. There is a sample xinitrc included at /usr/share/cdm/xinitrc.skel.
# If usexinit=no, then we instead call the chosen window manager directly.
usexinit=yes

# Additional arguments to pass to X server; it will be called as:
#        exec /usr/bin/X :$display $serverargs vt$((xtty+display))
serverargs="-nolisten tcp -dpi 96"

Offline

#242 2012-03-07 15:43:26

Foucault
Member
From: Athens, Greece
Registered: 2010-04-06
Posts: 209

Re: The Console Display Manager

I know this is probably a long shot but I will ask anyway. Is there a way to unlock the gnome LOGIN keyring upon login? Supposedly this is possible if one adds

session   optional    pam_gnome_keyring.so auto_start
auth      optional    pam_gnome_keyring.so

in /etc/pam.d/login.

Indeed if I start the session with startx after logging in in console I can see through ps that the gnome keyring daemon (gkd for short) is running on TTY1 as gnome_keyring_daemon --daemonize --login. And yes, the keyring is automatically unlocked since at login the password is passed to gkd which in turn unlocks the keyring. So with startx everything works as expected

However when I start my session with CDM, it seems that the gkd that is started at login is getting killed and a new one is started by the xfce session. The problem with this is that the newly launched gkd does not know anything about my password and therefore it cannot unlock its login keyring.

My naive assumption is that gkd is getting killed after TTY1 (or from the tty it has been launched upon login) is getting detached, since TTY1 is again available for a new login using CDM. So my question is, it possible to unlock the gnome keyring when starting my DE (xfce) through CDM, or preserve the process of the original keyring daemon that is launched upon login?

Offline

#243 2012-03-08 10:45:31

flako
Member
Registered: 2008-10-24
Posts: 56

Re: The Console Display Manager

I solved my problem. I followed Profjim's advice in this thread and added "set -x" near the end of my /usr/bin/cdm which showed that the command actually running was:

nohup startx thexinitrcfile awesome -- :0 -nolisten tcp -dpi 96 vt7 &> /dev/null &

But while error-checking I added a "sleep 20" to the end of /usr/bin/cdm so I could actually see the output before the screen was wiped. And that sleep solved the issue, so now console-kit-session wraps as it should. Seems that the reason it doesn't work from scratch is that you have to run dbus-launch after ck-launch-session, which isn't done by default and this is what I added to my .xinitrc . But just executing the .xinitrc without waiting for the console-kit-session to wrap means it won't work. By default this waiting is done when calling ck-launch-session, but if you disable consolekit in CDM and launch it from .xinitrc this won't happen. So to have console-kit-session working properly with CDM:

* add

ck-launch-session dbus-launch

to your .xinitrc
* set consolekit=no in /etc/cdmrc
* set usexinit=yes in /etc/cdmrc
* add

sleep 20

just before

exit 0

in /usr/bin/cdm

I don't know if a 20 second sleep is optimal, but for me that solution works. I don't understand exactly how consolekit is called in CDM, but it seems the issue has more to do with dbus and consolekit than CDM itself, as stated here: https://bugs.archlinux.org/task/25031

Offline

#244 2012-04-08 15:49:13

DexterLB
Member
Registered: 2011-06-20
Posts: 38

Re: The Console Display Manager

Hi
Just dropping by to say thank you - amazing display manager, worked out of the box, exactly what I needed! Superb! smile

Last edited by DexterLB (2012-04-08 15:49:34)


The best solution to a problem is usually the easiest one.

Offline

#245 2012-06-10 19:12:04

tinySpark
Member
Registered: 2012-06-09
Posts: 19

Re: The Console Display Manager

I just installed cdm-git this morning and while everything is functional, the menu is not displaying properly:

Pic 1
Pic 2

Clearly I've missed a step or something somewhere. I added

border2_color = 
menubox_border2_color = 

to the lime theme and gave it some values as per markoer's post about wonky display but that didn't seem to change anything. Aside from that the only change I've made is to add my two installed DE's to the /etc/cdmrc file.

# List all WM binary names
wmbinlist=(awesome openbox-session gnome-session-cinnamon startxfce4)

# List all WM display names
wmdisplist=(Awesome Openbox Cinnamon Xfce)

Any ideas? Don't be afraid to suggest something obvious, I've been using Arch for less than 48 hours.

Last edited by tinySpark (2012-06-10 20:59:17)

Offline

#246 2012-06-11 10:26:19

bashnev
Member
Registered: 2012-06-11
Posts: 18

Re: The Console Display Manager

I have the same issue. I suspect its caused by recent changes in initscipts package. See the bug reports for the package
here.

Offline

#247 2012-09-14 11:59:47

basdi
Member
Registered: 2012-09-14
Posts: 15

Re: The Console Display Manager

hello,

i've got a problem with cdm, which appeared after an upgrade i think. after the login i get a message which is something like cdm: unknown flag '. i can't get the exact message because it only appears very shortly before getting back to the login prompt.
i don't know what to do because i can't log into the sytem. i tried also on tty2, tty3,..
any suggestions on how to repare this? or is there any way to get around cdm and go directly to console?

thank you!
basdi

Offline

#248 2012-09-14 17:43:36

Mektub
Member
From: Lisbon /Portugal
Registered: 2008-01-02
Posts: 647

Re: The Console Display Manager

It happened to me, also.

I started a rescue system, mounted de ARCH partition, and changed the name /etc/profile.d/zzz-cdm-profile.sh to zzz-cdm-profile.sh.bad

This disables cdm-git.

Mektub


Follow me on twitter: https://twitter.com/johnbina

Offline

#249 2012-09-14 18:47:05

basdi
Member
Registered: 2012-09-14
Posts: 15

Re: The Console Display Manager

hey!!

nice! that worked for me. thank you

well, i think there is a new config file. in /etc you have cdmrc.pacnew or something like this..
but i couldn't really figure out how to configure it..

but i found (here) a nice way to put the .xinitrc. maybe it's not really the topic but i still would like to share it with you:

case "$1" in
fluxbox) exec startfluxbox ;;
awesome) exec awesome ;;
esac

so typing 'xinit awesome' you start awesome and with 'xinit fluxbox' fluxbox, etc.

bas

Offline

#250 2012-09-14 20:14:35

jakob
Member
From: Berlin
Registered: 2005-10-27
Posts: 419

Re: The Console Display Manager

Are you guys using cdm-git?

Offline

Board footer

Powered by FluxBB