You are not logged in.

#1 2011-12-26 00:48:13

.:B:.
Forum Fellow
Registered: 2006-11-26
Posts: 5,819

Xbmc with XvBA support in the AUR (XvBA git branch & Eden packages)

I took the liberty of adapting the excellent xbmc-git PKGBUILD for the brand spanking new XvBA branch and putting it in AUR.

For those interested, make sure to build xvba-sdk in accordance with my comment - headers should go in /usr/include/amd/ and not /usr/include; not just Xbmc's configure script expects them there, there are hardcoded references in Xbmc's DVDPlayer source code as well. I hope the maintainer improves the package quickly.

Currently you cannot take libva (and VA-API) out of the equasion; if the Xbmc diagnostic overlay shows you're using VA-API, disable it in Xbmc's settings (and make sure XvBA is enabled). Catalyst 11.11 or higher is advised (I only tested myself with Catalyst 11.12, 12.4, 12.6 beta and an E-350 (HD6310) and a HD6950). For High@L5.1 support, at least 12.4 seems to be necessary.

The Xbmc forum thread discussing direct XvBA support is here. If you have any XvBA-related issues, please post them there - it's in everyone's interest they get fixed smile. This thread is mainly intended for raising awareness about the feature and Issues with the PKGBUILD.

Enjoy smile. I'm am - obviously wink - open to suggestions for improvement of the PKGBUILD.

Last edited by .:B:. (2012-06-29 15:45:48)


Got Leenucks? :: Arch: Power in simplicity :: Get Counted! Registered Linux User #392717 :: Blog thingy

Offline

#2 2011-12-31 14:08:25

.:B:.
Forum Fellow
Registered: 2006-11-26
Posts: 5,819

Re: Xbmc with XvBA support in the AUR (XvBA git branch & Eden packages)

Well so far for the enthusiastic response tongue.

I have added a package based on the first Xbmc Eden beta in the meantime, with XvBA support as well (integration courtesy of Stephan Raue of the OpenELEC project). The intention is to maintain a stable package next to the one based on the XvBA git tree.

You can find it here.

Last edited by .:B:. (2012-01-03 10:11:17)


Got Leenucks? :: Arch: Power in simplicity :: Get Counted! Registered Linux User #392717 :: Blog thingy

Offline

#3 2012-02-04 00:59:55

.:B:.
Forum Fellow
Registered: 2006-11-26
Posts: 5,819

Re: Xbmc with XvBA support in the AUR (XvBA git branch & Eden packages)

A slight update.

With the libpng 1.5 rebuild pending, i hacked together a patch (based on xbmc git commits) for xbmc so it builds against libpng 1.5.

Patch can be grabbed here, for those running on [Testing]:

http://sprunge.us/Ydci

This is mostly meant for the people using my xbmc-xvba package, which is based on the Eden betas (and eventually Eden release). However, from the comments on Xbmc's Github it looks like libpng 1.5 support has not been integrated yet in git either.

Last edited by .:B:. (2012-02-04 01:01:41)


Got Leenucks? :: Arch: Power in simplicity :: Get Counted! Registered Linux User #392717 :: Blog thingy

Offline

#4 2012-04-12 16:00:05

.:B:.
Forum Fellow
Registered: 2006-11-26
Posts: 5,819

Re: Xbmc with XvBA support in the AUR (XvBA git branch & Eden packages)

The git package has been updated to use the Eden branch instead of the XvBA one. The libpng patch is no longer needed with that branch, and that's the one you want if you want a functional PVR and XvBA build. Master is not intended to be fully functional (or stable, for that matter).

If you have further questions, join #xbmc-xvba on Freenode.

Last edited by .:B:. (2012-04-12 16:01:34)


Got Leenucks? :: Arch: Power in simplicity :: Get Counted! Registered Linux User #392717 :: Blog thingy

Offline

#5 2012-06-28 11:20:07

.:B:.
Forum Fellow
Registered: 2006-11-26
Posts: 5,819

Re: Xbmc with XvBA support in the AUR (XvBA git branch & Eden packages)

There's some pretty big news today - the XvBA developers have discovered a way to unlock High@L5.1 support in the AMD driver. Instructions on how to do it can be found here.

Should be working with 12.4 and 12.6, if you get older drivers working, please report in that thread or on #xbmc-xvba on Freenode.


Got Leenucks? :: Arch: Power in simplicity :: Get Counted! Registered Linux User #392717 :: Blog thingy

Offline

#6 2012-06-28 12:44:03

masteryod
Member
Registered: 2010-05-19
Posts: 433

Re: Xbmc with XvBA support in the AUR (XvBA git branch & Eden packages)

Good job.

Offline

#7 2012-06-29 15:32:59

.:B:.
Forum Fellow
Registered: 2006-11-26
Posts: 5,819

Re: Xbmc with XvBA support in the AUR (XvBA git branch & Eden packages)

Yes indeed. The packages in the AUR have been updated to accomodate High@L5.1 support; you still need to enable it yourself (the file in question is part of the catalyst package), but XBMC will now use the 5.1 profile when the file has been encoded as h.264 High@L4.1 but is out of spec (too many reference frames etc.).

Keep in mind this will *only* work when you have enabled High@L5.1 support.

Last edited by .:B:. (2012-06-29 15:33:28)


Got Leenucks? :: Arch: Power in simplicity :: Get Counted! Registered Linux User #392717 :: Blog thingy

Offline

#8 2013-02-26 21:20:00

wikavalier
Member
Registered: 2013-01-22
Posts: 18

Re: Xbmc with XvBA support in the AUR (XvBA git branch & Eden packages)

Hi there,

I been trying to install xbmc over arch64 on my e-350 without success. I tried community and AUR (yours/helios? included)  with and without xvba enabled, also disabling vaapi and vdpau manually in the PKGBUILD file. I always get a stutter playback, dropping almost a frame per second and a 100% cpu load.

Are you running xbmc-frodo on a e-350?

Sorry for the bump

Offline

#9 2013-03-10 17:46:47

Corpswalker
Member
Registered: 2010-06-10
Posts: 12

Re: Xbmc with XvBA support in the AUR (XvBA git branch & Eden packages)

Hi,

with the last package I got the same problems as wikavalier. Seems something broken with that version.
Despite the reported symptoms above, I noticed a >100% error rate on every TV channel (before it was 0%), a bigger delay switching channels and no DVXA Rendering option.
Running on A8-3870K with Catalyst driver.

Last edited by Corpswalker (2013-03-10 17:48:46)

Offline

#10 2013-03-10 23:35:45

wikavalier
Member
Registered: 2013-01-22
Posts: 18

Re: Xbmc with XvBA support in the AUR (XvBA git branch & Eden packages)

I found that the frame drop was related with "adjuts display refresh rate to match video" option. In ubuntu-xbmc (wsnipex) this option makes my TV start in 24hz and then switch to 50hz, so I guess it is also not working properly in this combo-build

However the cpu consumption is about two times in arch than in ubuntu (80-100% vs 30-40%), dirty regions and others options enabled in both.

@Corpswalker:
did you mean XVBA instead DVXA (direct x video acceleration = windows)? If I compile with --enable-xvba option in the PKGBUILD I can see the XVBA option in video/settings.

Last edited by wikavalier (2013-03-10 23:40:55)

Offline

#11 2013-03-11 17:46:34

Corpswalker
Member
Registered: 2010-06-10
Posts: 12

Re: Xbmc with XvBA support in the AUR (XvBA git branch & Eden packages)

@wikavalier
The Render Methods are: Software, basic shaders and advanced shaders. I mistaked them with the windows' DXVA Method.

So far, no solution for my choppy, ugly looking and CPU intense Playback.

*Update* Tested the xbmc-xvba package, same problem.  Looks like it`s likely caused by my catalyst update to 13.2-2. Now I can't find the 13.1 Version for downgrading. Doom-loop ^_^

Last edited by Corpswalker (2013-03-12 11:29:01)

Offline

#12 2013-03-13 11:54:56

wikavalier
Member
Registered: 2013-01-22
Posts: 18

Re: Xbmc with XvBA support in the AUR (XvBA git branch & Eden packages)

I also try compiling "Frodo" branch from FrenetMenta, instead default Master. Same issues.

Offline

#13 2013-03-19 08:19:05

Corpswalker
Member
Registered: 2010-06-10
Posts: 12

Re: Xbmc with XvBA support in the AUR (XvBA git branch & Eden packages)

After several version test, I think it hats something to do with the Catalyst driver.
I can't go back to my previous used version because it doesn't run stable anymore. That means it has something to do with the other Video related packages, but can't point at it.

I'm getting a strange behaviour on XBMC and X-Server. When shutting down XBMC, the Screen doesn't get refreshed and I have to switch to console and back to X to regain a normal working KDE Desktop.

I'll wait for further updates of Catalyst, too many possible culprits for me. ^_^

Offline

#14 2013-03-24 09:34:08

aphirst
Member
From: Munich, Germany
Registered: 2008-06-30
Posts: 56
Website

Re: Xbmc with XvBA support in the AUR (XvBA git branch & Eden packages)

EDIT: I've learned that the whole point of xbmc-xvba is to bypass vaapi and use XvBA directly; so my post was probably utterly irrelevant. I won't blank it, but sorry for misunderstanding. big_smile

Corpswalker wrote:

After several version test, I think it hats something to do with the Catalyst driver.
I can't go back to my previous used version because it doesn't run stable anymore. That means it has something to do with the other Video related packages, but can't point at it.

I'm getting a strange behaviour on XBMC and X-Server. When shutting down XBMC, the Screen doesn't get refreshed and I have to switch to console and back to X to regain a normal working KDE Desktop.

I'll wait for further updates of Catalyst, too many possible culprits for me. ^_^

Not sure if this will help, but when I use the new (i.e. >13.1) Catalyst packages either from the AUR or from Vi0L0's repository, if I also use his xvba-video package I get horrendously garbled video. By removing that version, and installing xvba-video-open from community(?) it started working perfectly. Maybe this bears some relevance to your situation.

Last edited by aphirst (2013-03-27 14:18:16)


ArchLinux | x86_64 | linux-ck-sandybridge
OpenBox3 | tint2 | sakura | PCManFM | Pale Moon | FossaMail | Code::Blocks | GCC
Lenovo Thinkpad T430 | 14.1" | i7-3540M (2.5GHz) | HD 4000 | 16GB (1066MHz) | 256GB mSATA SSD | 1TB HDD | 500GB HDD

Offline

Board footer

Powered by FluxBB