You are not logged in.

#1 2012-01-01 22:05:43

a271828
Member
Registered: 2012-01-01
Posts: 6

Could not register -- is this a bug or a feature?

On "2012-01-01 12:20" the answer which I was getting for

What is the output of "date -u +%W$(uname)|sha256sum|sed 's/\W//g'"?

on my system was different from what was expected by registration.

I replaced your expression with:

echo 52Linux|sha256sum|sed 's/\W//g'

and finally was able to register. Looks to me like a bug in registration.

Offline

#2 2012-01-01 22:08:40

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,428
Website

Re: Could not register -- is this a bug or a feature?

Known issue.

Offline

#3 2012-01-01 22:10:35

/dev/zero
Member
From: Melbourne, Australia
Registered: 2011-10-20
Posts: 1,176
Website

Re: Could not register -- is this a bug or a feature?

I suspect it might be a time-zone thing. If you're in a different time-zone to the server, you will get different results. I suppose it could be handled better, but on the other hand, it's not really surprising.


Linux is NOT Windows | The Rootless Root
Toshiba Satellite i5-3230M 2.6GHz CPUs, 4Gb RAM, ArchLinux, wmii, nVidia GeForce GT 740M.

Offline

#4 2012-01-01 22:21:46

karol
Archivist
Registered: 2009-05-06
Posts: 25,432

Re: Could not register -- is this a bug or a feature?

Yeah, sorry about that.
Allan has already posted on the ML http://mailman.archlinux.org/pipermail/ … 22295.html

Offline

#5 2012-01-01 23:40:00

a271828
Member
Registered: 2012-01-01
Posts: 6

Re: Could not register -- is this a bug or a feature?

It does not look like timezone issue because of '-u' option for 'date'.

From "man date" (GNU coreutils 8.5 February 2011):
%W     week number of year, with Monday as first day of week (00..53)

However I get:
date -u +%W
00

Good that
info coreutils 'date invocation'

has valuable addition:
Days in a new year preceding the first Monday are  in week zero.

So, it registration does not calculate correct week number. They probably do not use posted expression, or their tool uses is of different version. Probably this issue happens only at the beginning of new year before first Monday.

Still this could be a hidden quiz for new users...

Offline

#6 2012-01-02 08:20:37

a271828
Member
Registered: 2012-01-01
Posts: 6

Re: Could not register -- is this a bug or a feature?

Now registration works fine, because we are now on first Monday of the year on GMT time.
If not fixed the issues may happen again next year.

Offline

#7 2012-01-21 14:15:45

karol
Archivist
Registered: 2009-05-06
Posts: 25,432

Re: Could not register -- is this a bug or a feature?

Status?

Offline

Board footer

Powered by FluxBB