You are not logged in.

#151 2012-01-05 20:51:13

1archgamenon2
Banned
Registered: 2011-07-12
Posts: 201

Re: [kde-unstable] KDE 4.8

1archgamenon2 wrote:

RC1: tiny buggy...all of u have to admit it!

I feel 99% better than rc1 this new release!

Offline

#152 2012-01-05 22:45:16

Akuma
Member
From: France
Registered: 2010-10-26
Posts: 30

Re: [kde-unstable] KDE 4.8

Freshly upgraded to RC2.

I also have the tar.gz creation/uncompress bug. libarchive 2.8.5-2.
KMix still not updating streams list in the tray tooltip.

Else everything seems to be working fine.

Offline

#153 2012-01-06 07:41:02

adee
Member
From: The Moon
Registered: 2009-11-10
Posts: 107

Re: [kde-unstable] KDE 4.8

About the Ark and libarchive bug:
[kde-unstable] requires [testing] enabled. Ark has been rebuilt to the new libarchive version already in testing. I don't experience any problems with it, so you should use testing and do a full update.

Last edited by adee (2012-01-06 07:41:17)

Offline

#154 2012-01-06 14:18:16

Pyruzan
Member
Registered: 2010-10-19
Posts: 34

Re: [kde-unstable] KDE 4.8

I can't change keyboard layouts after upgrading to RC2 and I currently have to use 'setxkbmap' command. That's the cause I think:

kl.png

Also pressing printscreen key doesn't trigger ksnapshot.

Offline

#155 2012-01-06 15:39:45

1archgamenon2
Banned
Registered: 2011-07-12
Posts: 201

Re: [kde-unstable] KDE 4.8

what theme is that?

Offline

#156 2012-01-06 16:03:04

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: [kde-unstable] KDE 4.8

Pyruzan wrote:

I can't change keyboard layouts after upgrading to RC2 and I currently have to use 'setxkbmap' command.
Also pressing printscreen key doesn't trigger ksnapshot.

Both, kcm_keyboard and ksnapshot work here.

Offline

#157 2012-01-06 17:29:55

sl1pkn07
Member
From: Spanishtán
Registered: 2010-03-30
Posts: 312

Re: [kde-unstable] KDE 4.8

virtuoso-t eats my pc since install rc2 :S

Offline

#158 2012-01-06 18:47:18

martin.k
Member
Registered: 2011-11-09
Posts: 5

Re: [kde-unstable] KDE 4.8

Is there a possibility of having digikam compiled against kde-unstable in the repo?  Digikam is broken due to ABI incompatibility between KDE 4.7 and 4.8..

Offline

#159 2012-01-06 19:29:57

Pyruzan
Member
Registered: 2010-10-19
Posts: 34

Re: [kde-unstable] KDE 4.8

1archgamenon2 wrote:

what theme is that?

Hey buddy, the theme is mine and I'm probably gonna release it soon (in a few days), here is a full screenshot: http://pyruzan.deviantart.com/art/Modest-277795955
You can also check my gallery if you want: http://pyruzan.deviantart.com
Sorry for off topic.

bash wrote:

Both, kcm_keyboard and ksnapshot work here.

Okey, I'm using radeon repo and libgl is a part of mesa-full meta package which was upgraded alongside KDE, perhaps that's where the problem comes from. Thanks for the reply smile

martin.k wrote:

Is there a possibility of having digikam compiled against kde-unstable in the repo?  Digikam is broken due to ABI incompatibility between KDE 4.7 and 4.8..

This should have been done a lot sooner, now KDE 4.8 final is just a few days away and digikam would be updated as soon as 4.8 hits the extra repo.

Offline

#160 2012-01-07 00:06:35

ChemBro
Member
Registered: 2008-10-22
Posts: 674

Re: [kde-unstable] KDE 4.8

Pyruzan wrote:

Also pressing printscreen key doesn't trigger ksnapshot.

Pressing print screen to trigger ksnapshot is not enabled by default, as far as I know. At least last time I had default settings, it worked that way.

Offline

#161 2012-01-07 04:00:29

Pyruzan
Member
Registered: 2010-10-19
Posts: 34

Re: [kde-unstable] KDE 4.8

ChemBro wrote:

Pressing print screen to trigger ksnapshot is not enabled by default, as far as I know. At least last time I had default settings, it worked that way.

As long as I remember pressing print-screen has been always firing up ksnapshot in KDE (if it is installed of course) smile

As I guessed the cause of both problems (changing keyboard layouts and triggering ksnapshot) was libgl in the new mesa-full group from radeon repo. I removed it and installed the packages from extra repo, everything's fine now big_smile

Last edited by Pyruzan (2012-01-07 04:05:04)

Offline

#162 2012-01-07 10:05:48

desaparecido
Member
From: Liège, Belgium
Registered: 2010-03-14
Posts: 138

Re: [kde-unstable] KDE 4.8

Pyruzan wrote:
1archgamenon2 wrote:

what theme is that?

Hey buddy, the theme is mine and I'm probably gonna release it soon (in a few days), here is a full screenshot: http://pyruzan.deviantart.com/art/Modest-277795955
You can also check my gallery if you want: http://pyruzan.deviantart.com
Sorry for off topic.

bash wrote:

Both, kcm_keyboard and ksnapshot work here.

Okey, I'm using radeon repo and libgl is a part of mesa-full meta package which was upgraded alongside KDE, perhaps that's where the problem comes from. Thanks for the reply smile

martin.k wrote:

Is there a possibility of having digikam compiled against kde-unstable in the repo?  Digikam is broken due to ABI incompatibility between KDE 4.7 and 4.8..

This should have been done a lot sooner, now KDE 4.8 final is just a few days away and digikam would be updated as soon as 4.8 hits the extra repo.


Hi, I build digikam 2.5.0 from sources with "yaourt -Sb digikam" successfully, and works fine now.


KF5 & Plasma5 (git versions) - Awesome WM
ASUS Sabertooth 990FX - AMD FX8350 - ATI Radeon HD 7970
[testing] repo

Offline

#163 2012-01-07 10:35:28

teekay
Member
Registered: 2011-10-26
Posts: 270

Re: [kde-unstable] KDE 4.8

desaparecido wrote:

Hi, I build digikam 2.5.0 from sources with "yaourt -Sb digikam" successfully, and works fine now.

You didn't have any issues with boost-1.48? Do you use 32bit or 64bit?
I had to build boost-1.47 before I was able to build digikam 2.5.0 (x86_64 here).

https://bugs.kde.org/show_bug.cgi?id=287772
Fixed now, but was still present in 2.5.0 here.

EDIT: nevermind. Just realized the patched 2.5.0 version in extra. Nice!

Last edited by teekay (2012-01-07 10:46:13)

Offline

#164 2012-01-07 11:01:30

desaparecido
Member
From: Liège, Belgium
Registered: 2010-03-14
Posts: 138

Re: [kde-unstable] KDE 4.8

teekay wrote:
desaparecido wrote:

Hi, I build digikam 2.5.0 from sources with "yaourt -Sb digikam" successfully, and works fine now.

You didn't have any issues with boost-1.48? Do you use 32bit or 64bit?
I had to build boost-1.47 before I was able to build digikam 2.5.0 (x86_64 here).

https://bugs.kde.org/show_bug.cgi?id=287772
Fixed now, but was still present in 2.5.0 here.

EDIT: nevermind. Just realized the patched 2.5.0 version in extra. Nice!

I have boost-1.48 from [extra] repo and [testing] repo activated and all was ok to build-it.  I have x86_64 version

Last edited by desaparecido (2012-01-07 11:02:20)


KF5 & Plasma5 (git versions) - Awesome WM
ASUS Sabertooth 990FX - AMD FX8350 - ATI Radeon HD 7970
[testing] repo

Offline

#165 2012-01-07 11:42:54

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: [kde-unstable] KDE 4.8

sl1pkn07 wrote:

virtuoso-t eats my pc since install rc2 :S

Confirmed. Seems that virtuoso-t uses 60-70% CPU again!!! sad
I didn't find the kde bug report yet.

Offline

#166 2012-01-07 16:54:22

Damnshock
Member
From: Barcelona
Registered: 2006-09-13
Posts: 414

Re: [kde-unstable] KDE 4.8

bash wrote:
sl1pkn07 wrote:

virtuoso-t eats my pc since install rc2 :S

Confirmed. Seems that virtuoso-t uses 60-70% CPU again!!! sad
I didn't find the kde bug report yet.

Do you have email indexing enabled in "Desktop Search" ?


My blog: blog.marcdeop.com
Jabber ID: damnshock@jabber.org

Offline

#167 2012-01-07 17:03:41

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: [kde-unstable] KDE 4.8

Damnshock wrote:

Do you have email indexing enabled in "Desktop Search" ?

Yes, I do.

EDIT: wait, everything's fine now. I guess it re-indexed some dir or something like that.

Offline

#168 2012-01-07 18:06:38

desaparecido
Member
From: Liège, Belgium
Registered: 2010-03-14
Posts: 138

Re: [kde-unstable] KDE 4.8

bash wrote:
sl1pkn07 wrote:

virtuoso-t eats my pc since install rc2 :S

Confirmed. Seems that virtuoso-t uses 60-70% CPU again!!! sad
I didn't find the kde bug report yet.

for me even with email-indexer all works fine, take I little bit more of resources when the start session, only the time to verify changes in the indexed files, for me is really performant in MEM and in CPU %


KF5 & Plasma5 (git versions) - Awesome WM
ASUS Sabertooth 990FX - AMD FX8350 - ATI Radeon HD 7970
[testing] repo

Offline

#169 2012-01-07 18:57:49

1archgamenon2
Banned
Registered: 2011-07-12
Posts: 201

Re: [kde-unstable] KDE 4.8

desaparecido wrote:

"yaourt -Sb digikam"

Hi! what does 'b' mean on yaourt-Sb?

Offline

#170 2012-01-07 18:59:45

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: [kde-unstable] KDE 4.8

1archgamenon2 wrote:

Hi! what does 'b' mean on yaourt-Sb?

http://archlinux.fr/man/yaourt.8.html

Is the same of:

# abs
$ cp -r /var/abs/extra/digikam /tmp
$ cd /tmp/digikam
$ makepkg -sr
# pacman -U *.xz

Offline

#171 2012-01-07 19:41:14

desaparecido
Member
From: Liège, Belgium
Registered: 2010-03-14
Posts: 138

Re: [kde-unstable] KDE 4.8

1archgamenon2 wrote:
desaparecido wrote:

"yaourt -Sb digikam"

Hi! what does 'b' mean on yaourt-Sb?

it's to build from sources, you take the PKGBUILD and you build directly, like @bash explain too.


KF5 & Plasma5 (git versions) - Awesome WM
ASUS Sabertooth 990FX - AMD FX8350 - ATI Radeon HD 7970
[testing] repo

Offline

#172 2012-01-08 03:12:35

sl1pkn07
Member
From: Spanishtán
Registered: 2010-03-30
Posts: 312

Re: [kde-unstable] KDE 4.8

desaparecido wrote:
bash wrote:
sl1pkn07 wrote:

virtuoso-t eats my pc since install rc2 :S

Confirmed. Seems that virtuoso-t uses 60-70% CPU again!!! sad
I didn't find the kde bug report yet.

for me even with email-indexer all works fine, take I little bit more of resources when the start session, only the time to verify changes in the indexed files, for me is really performant in MEM and in CPU %

2days non-stop :S (email indexer ON, file indexer OFF, memmory option 1GB) with 70-80% CPU

Offline

#173 2012-01-08 12:21:19

swiftscythe
Member
From: Rennes, France
Registered: 2009-04-28
Posts: 129
Website

Re: [kde-unstable] KDE 4.8

Anyone else having a crash when doing:
System Settings -> Workspace appearance -> Window Decorations -> Configure Decoration -> Window-Specific Overrides -> Add

Couldn't find a bug report for that.

Offline

#174 2012-01-08 13:41:53

SPK201
Member
Registered: 2011-12-20
Posts: 13

Re: [kde-unstable] KDE 4.8

swiftscythe wrote:

Anyone else having a crash when doing:
System Settings -> Workspace appearance -> Window Decorations -> Configure Decoration -> Window-Specific Overrides -> Add

Couldn't find a bug report for that.

Yeah. Same here.

Offline

#175 2012-01-08 13:55:53

sxe
Member
From: Cologne
Registered: 2009-06-04
Posts: 93
Website

Re: [kde-unstable] KDE 4.8

swiftscythe wrote:

Anyone else having a crash when doing:
System Settings -> Workspace appearance -> Window Decorations -> Configure Decoration -> Window-Specific Overrides -> Add

Couldn't find a bug report for that.

Yes, happens here too.

Offline

Board footer

Powered by FluxBB