You are not logged in.

#1 2012-01-12 22:32:13

kabbalah
Member
Registered: 2011-08-23
Posts: 125

Issue updating with Testing active

This is my issue: Posted a mantenedor de b43 firmware

1. b43-firmware, is impossible install!
When update with testing include, ultimately it tell me:
b43-firmware: necesita linux<3.2
error: error al preparar la transacción (no se pudieron satisfacer las dependencias)

2. I erase b43-firmware, for I will can install linux 3.2-2, since I can't update, then it tell me "b43 necesita linux 3.2"

2. I installed linux 3.2-2 since pkgbuild, now when want install b43-firmware since Aur, it tell me that it need as dependence: b43-firmware: necesita linux<3.2
error: error al preparar la transacción (no se pudieron satisfacer las dependencias)

3. edited the pkgbuild of b43, to change linux 3.2 by linux 3.2-2 but nothing appear the same error.

Then with Testing active I can't update archlinux.
------------------------------------------------------------------------------------------------------------------------------------------------------------

This an your answer:

Comentario de: Xavion el Tue, 10 Jan 2012 21:29:19 +0000

    This package currently requires Linux < v3.2, where '<' means "earlier than". In other words, you should install the 'linux' package (v3.1.8) from the 'core' repository instead. After Linux v3.2 has been moved from 'testing' to 'core', I'll update this PKGBUILD accordingly.
----------------------------------------------------------------------------------------------------------------------------------------------------------

My answer:

Comentario de: kabbalah el Thu, 12 Jan 2012 04:40:43 +0000

    I not understand, when I updated my archlinux, no problem, but now you is tell me that "After Linux v3.2 has been moved from 'testing' to 'core', I'll update this PKGBUILD accordingly". Then, meantine I can't use Testing for realize my update?

    Please, explain me the reason for it decision.

    Cordially

    kabbalah
_____________________________________________________________________________________________________________

Answer of Xavion and muunleit:

Comentario de: Xavion el Thu, 12 Jan 2012 21:23:55 +0000

    Please note that the "b43-firmware-latest" PKGBUILD incorrectly lists Linux < v3.2 as a dependency. Until the maintainer of that package changes it to require Linux >= v3.2, anyone attempting to use it will need to do so themselves.

Comentario de: muunleit el Thu, 12 Jan 2012 06:42:13 +0000

    @kabbalah
    The reason is easy to explain. If Xavion would update the pkg now, everyone not using 'testing' could not use this pkg.
    In the mean time you can try the b43-firmware-latest-pkg https://aur.archlinux.org/packages.php?ID=52676 I guess.

____________________________________________________________________________________________________________

My answer:

Comentario de: kabbalah el Thu, 12 Jan 2012 22:11:14 +0000

    Ok, I use Testing since two years, and no problem updating my system, then now seem that every time that change the kernel, then b43-firmware will no allow that update my system, until the kernel has been moved from 'testing' to 'core'.

    How emerged this issue? Which is the solution for it? For all.

    Or, then I will need no use Testing?
_____________________________________________________________________________________________________________

Thank for any help, idea, solution for this issue.

Kabbalah

Offline

#2 2012-01-12 22:37:34

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: Issue updating with Testing active

just edit b43-firmware and change version to 5.100.138, remove the linux versioned dependency and generate md5sum (makepkg -g) and create and install the package with makepkg -i

then pacman -Syu && reboot.


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#3 2012-01-19 09:23:16

kennym
Member
From: Paraguay
Registered: 2011-09-04
Posts: 32
Website

Re: Issue updating with Testing active

wonder wrote:

just edit b43-firmware and change version to 5.100.138, remove the linux versioned dependency and generate md5sum (makepkg -g) and create and install the package with makepkg -i

then pacman -Syu && reboot.

Thanks, this worked perfectly.


Kenny

...and of course: FU Gnome 3 haters

Offline

#4 2012-01-20 08:33:50

karol
Archivist
Registered: 2009-05-06
Posts: 25,422

Re: Issue updating with Testing active

Please remember to mark the thread as solved.
Nah, you're not OP, sorry ;P

Last edited by karol (2012-01-20 08:34:40)

Offline

Board footer

Powered by FluxBB