You are not logged in.

#1 2012-01-13 18:05:07

tekstr1der
Member
Registered: 2009-03-18
Posts: 4

vboxdrv kernel module will not build on 3.1.9

After the update today to the lastest kernel 3.1.9, the virtualbox module will no longer build. Anyone else seeing this?

make -f /usr/src/linux-3.1.9-1-ARCH/scripts/Makefile.modpost
  scripts/mod/modpost -m  -i /usr/src/linux-3.1.9-1-ARCH/Module.symvers -I /tmp/vbox.0/Module.symvers  -o /tmp/vbox.0/Module.symvers -S -w  -s
FATAL: vmlinux is truncated. sechdrs[i].sh_offset=18446744071588955904 > sizeof(*hrd)=64
make[2]: *** [__modpost] Error 1
make[1]: *** [modules] Error 2
make: *** [vboxnetadp] Error 2

Offline

#2 2012-01-13 18:53:38

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: vboxdrv kernel module will not build on 3.1.9

you don't really need to rebuild modules if you use virtualbox-modules.

but i just tried it and modules compile just fine.


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#3 2012-01-13 18:55:08

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: vboxdrv kernel module will not build on 3.1.9

Offline

#4 2012-01-13 19:29:57

tekstr1der
Member
Registered: 2009-03-18
Posts: 4

Re: vboxdrv kernel module will not build on 3.1.9

@wonder: As I share some virtual machines amongst various platforms, I want to remain at Virtualbox 4.0.12 for the time being to keep them all stable and consistent. virtualbox-modules stays current/rolling with vbox releases.

I've had zero issues recompiling the kernel modules throughout each point release of 3.0.x series and 3.1.x series kernels using:

# /etc/rc.d/vboxdrv setup

@karol: Thank you. I'd seen that in searching prior to my post. Even though I didn't think that was the issue, I upgraded libarchive package in testing and I'm still seeing the same error in recompiling the module.

Offline

#5 2012-01-13 20:33:56

tekstr1der
Member
Registered: 2009-03-18
Posts: 4

Re: vboxdrv kernel module will not build on 3.1.9

I went ahead and installed the new LTS kernel (linux-lts 3.0.17-1) from testing. The virtualbox modules compile just fine with this kernel. Definitely something borked in 3.1.9-1.

Offline

#6 2012-01-13 21:20:26

maus
Member
Registered: 2012-01-13
Posts: 2

Re: vboxdrv kernel module will not build on 3.1.9

I had the same issue, with vboxdrv and with other modules as well. The only way to fix it was downgrading to linux-3.1.8

Last edited by maus (2012-01-13 21:20:53)

Offline

#7 2012-01-13 21:38:38

prometej
Member
From: Zagreb, Croatia
Registered: 2008-10-10
Posts: 19

Re: vboxdrv kernel module will not build on 3.1.9

Same problem here, same error message as tekstr1der's, but with a lot of other error messages.
After reverting back to kernel 3.1.8, everything works fine.

What could be the cause of this problem?


UTERE SED NE ABUTERE !!

Offline

#8 2012-01-13 23:23:41

rune0077
Member
Registered: 2009-04-11
Posts: 135

Re: vboxdrv kernel module will not build on 3.1.9

Yeah, same problem here after yesterdays update to 3.1.9.

Now one of life's great dillemas: to downgrade, or to wait it out and hope an update with a fix will come soon?

Offline

#9 2012-01-14 07:22:55

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,262

Re: vboxdrv kernel module will not build on 3.1.9

Will be fixed immediatly, sorry folks.

Offline

#10 2012-01-14 08:59:42

pomekewe
Member
Registered: 2012-01-14
Posts: 11

Re: vboxdrv kernel module will not build on 3.1.9

I'm also having problems installing the NVIDIA drivers: the modules fail to build, with a very non-specific error, since updating to 3.1.9 kernel.  All worked fine up until the update a few minutes ago.

Could this be related?

Cheers,
Pomekewe.

Offline

#11 2012-01-14 10:29:50

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,262

Re: vboxdrv kernel module will not build on 3.1.9

Until signoffs are coming in:
https://dev.archlinux.org/~tpowa/linux/

Offline

#12 2012-01-14 11:50:37

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,262

Re: vboxdrv kernel module will not build on 3.1.9

New kernel moved to core.

Offline

#13 2012-01-14 19:29:38

rune0077
Member
Registered: 2009-04-11
Posts: 135

Re: vboxdrv kernel module will not build on 3.1.9

tpowa wrote:

New kernel moved to core.

Sweet, it works just fine now.

On behalf of all of us from the highly revered and very popular school of to-lazy-to-downgrade I offer our sincere thanks for the quick response. Or, as the Buddha said: "When the devs work hard, you don't have to." (which, incidently, is also the motto of the aforementioned school).

Offline

#14 2012-01-14 20:03:43

lorin
Member
Registered: 2011-12-06
Posts: 27

Re: vboxdrv kernel module will not build on 3.1.9

rune0077 wrote:
tpowa wrote:

New kernel moved to core.

Sweet, it works just fine now.

On behalf of all of us from the highly revered and very popular school of to-lazy-to-downgrade I offer our sincere thanks for the quick response.

Seconded, thanks for the quick fix!

Offline

#15 2012-01-14 23:23:00

prometej
Member
From: Zagreb, Croatia
Registered: 2008-10-10
Posts: 19

Re: vboxdrv kernel module will not build on 3.1.9

tpowa wrote:

New kernel moved to core.

Thank you for your effort. Updated kernel==vboxdrv successfully built.
Everything is now back to normal.


UTERE SED NE ABUTERE !!

Offline

#16 2012-01-15 04:43:05

android
Member
From: San Diego
Registered: 2003-04-18
Posts: 144

Re: vboxdrv kernel module will not build on 3.1.9

I also can't get vboxdrv to build, but it's complaining about "can't find kernel source.

I'm running the virtualbox-bin from AUR, so I can't install virtualbox-modules or virtualbox-source.

The actual error messages:

[root@aspiring mark]# cat /tmp/vbox-install.log 
Makefile:172: *** Error: unable to find the sources of your current Linux kernel. Specify KERN_DIR=<directory> and run Make again.  Stop.
cp: cannot stat `/tmp/vboxdrv-Module.symvers': No such file or directory
Makefile:94: *** Error: unable to find the sources of your current Linux kernel. Specify KERN_DIR=<directory> and run Make again.  Stop.
cp: cannot stat `/tmp/vboxdrv-Module.symvers': No such file or directory
Makefile:90: *** Error: unable to find the sources of your current Linux kernel. Specify KERN_DIR=<directory> and run Make again.  Stop.

Offline

Board footer

Powered by FluxBB