You are not logged in.

#1 2012-01-16 20:58:16

slughappy1
Member
Registered: 2009-03-20
Posts: 75

[SOLVED] Pacman wont upgrade any packages

EDIT: I was able to solve my problem by pacman -R yaourt package-query pacman-color, I was then able to update pacman. Since I like yaourt and wanted to keep it I follow the instructions on their page (http://archlinux.fr/yaourt-en#get_it). I added their repo to my /etc/pacman.conf and then installed yaourt from pacman and now everything works again like it should.


When I try to upgrade packages I get the following errors:

[jason@barnaby ~]$ sudo pacman -Su
:: The following packages should be upgraded first :
    pacman
:: Do you want to cancel the current operation
:: and upgrade these packages now? [Y/n] Y

resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: package-query: requires pacman<3.6
:: pacman-color: requires pacman<3.6
[jason@barnaby ~]$ sudo pacman -Su
:: The following packages should be upgraded first :
    pacman
:: Do you want to cancel the current operation
:: and upgrade these packages now? [Y/n] n

:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: package-query: requires pacman<3.6
:: pacman-color: requires pacman<3.6
[jason@barnaby ~]$ 

Last edited by slughappy1 (2012-01-17 18:07:42)

Offline

#2 2012-01-16 21:08:39

viking60
Member
From: Valhalla
Registered: 2010-08-02
Posts: 95
Website

Re: [SOLVED] Pacman wont upgrade any packages

I have it too. And you can add packagekit to the list of dependencies. I tried to remove the packages but gnome-packagekit requires packagekit and so on....So I gave that up.
Help!


"Common sense is not common"

Offline

#3 2012-01-16 21:13:19

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: [SOLVED] Pacman wont upgrade any packages

pacman 4 is in the repos, some packages are incompatible with it.
Have you tried package-query-git?

Offline

#4 2012-01-16 21:24:32

orneo1212
Member
Registered: 2012-01-16
Posts: 23
Website

Re: [SOLVED] Pacman wont upgrade any packages

its my problem too.

:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
:: The following packages should be upgraded first :
    pacman
:: Do you want to cancel the current operation
:: and upgrade these packages now? [Y/n] y

resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: packagekit: requires pacman<3.6.0

Last edited by orneo1212 (2012-01-16 21:25:42)

Offline

#5 2012-01-16 21:25:46

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: [SOLVED] Pacman wont upgrade any packages

You have to wait until packagekit gets updated to work with the new pacman or remove packagekit for now.
Have you tried packagekit-git https://aur.archlinux.org/packages.php?ID=16507 ?

Last edited by karol (2012-01-16 21:26:52)

Offline

#6 2012-01-16 21:26:55

orneo1212
Member
Registered: 2012-01-16
Posts: 23
Website

Re: [SOLVED] Pacman wont upgrade any packages

karol wrote:

You have to wait until packagekit gets updated to work with the new pacman or remove packagekit for now.

when i try remove it  gnome-settings-daemon require it then need to wait

Offline

#7 2012-01-16 21:27:15

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: [SOLVED] Pacman wont upgrade any packages

Have you tried packagekit-git https://aur.archlinux.org/packages.php?ID=16507 ?

Offline

#8 2012-01-16 21:27:48

orneo1212
Member
Registered: 2012-01-16
Posts: 23
Website

Re: [SOLVED] Pacman wont upgrade any packages

no I try dont use AUR apps

Offline

#9 2012-01-16 21:46:59

lordoftux
Member
Registered: 2011-12-27
Posts: 7

Re: [SOLVED] Pacman wont upgrade any packages

got this error too, when trying to update system.
75 updates waiting..
I'll wait a few days more before trying to update again big_smile

Offline

#10 2012-01-16 21:48:16

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: [SOLVED] Pacman wont upgrade any packages

Why wait?

Offline

#11 2012-01-16 21:54:33

Evilandi666
Member
Registered: 2010-10-28
Posts: 105

Re: [SOLVED] Pacman wont upgrade any packages

I used sudo pacman -Rdd package-query, then sudo pacman -Syu and reinstalled package-query manual afterwards.

And - of course - wait for your mirror to sync. For me pyalpm is still missing and can't be upgraded (for example).

Last edited by Evilandi666 (2012-01-16 22:13:28)

Offline

#12 2012-01-16 21:57:42

slughappy1
Member
Registered: 2009-03-20
Posts: 75

Re: [SOLVED] Pacman wont upgrade any packages

I tried to uninstall packagekit and failed, then I tried to install packagekit-git and that failed too.

[jason@barnaby ~]$ sudo pacman -R packagekit
Password: 
error: 'packagekit': target not found
[jason@barnaby ~]$ yaourt -S packagekit-git

==> Downloading packagekit-git PKGBUILD from AUR...
x ChangeLog
x PKGBUILD

Comment by: onestep_ua on Thu, 16 Sep 2010 23:56:56 +0000
Updated this to follow the change of GIT server.	

Comment by: nxarmada on Tue, 01 Feb 2011 06:01:55 +0000
== Installing missing dependencies...
error: 'gir-repository=0.6.6': could not find or read package
== ERROR: 'pacman' failed to install missing dependencies.


I assume this should be git-repository=0.6.6  Also I can find this package on Pacman or AUR	

Comment by: onestep_ua on Tue, 01 Feb 2011 09:27:06 +0000
This is obsolete dependency connected with gobject-introspection support. I think it can be removed without any problems. :)	

Comment by: nxarmada on Thu, 03 Feb 2011 18:40:37 +0000
So I am trying to compile but I get this....any ideas?


SyntaxError: invalid syntax
make[4]: *** [enums.py] Error 1
make[4]: Leaving directory `/home/ryan/Downloads/AUR/packagekit/src/packagekit-build/lib/python/packagekit'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/ryan/Downloads/AUR/packagekit/src/packagekit-build/lib/python'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/ryan/Downloads/AUR/packagekit/src/packagekit-build/lib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/ryan/Downloads/AUR/packagekit/src/packagekit-build'
make: *** [all] Error 2
Aborting...

Comment by: bash on Tue, 29 Mar 2011 00:57:10 +0000
these lines are needed before ./autogen.sh

sed -i -e s|#![ ]*/usr/bin/python$|#!/usr/bin/python2| \
-e s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2| \
$(find . -name '*.py')	

Comment by: bash on Tue, 29 Mar 2011 01:14:30 +0000
also ./autogen.sh must be replaced with:

PYTHON=/usr/bin/python2 ./autogen.sh	

First Submitted: Sun, 20 Apr 2008 23:33:58 +0000	
packagekit-git 20100917-1 
( Unsupported package: Potentially dangerous ! )
==> Edit PKGBUILD ? [Y/n] ("A" to abort)
==> ------------------------------------
==> n

==> packagekit-git dependencies:
 - dbus-glib>=0.86 (already installed)
 - polkit>=0.96 (already installed)
 - networkmanager>=0.8.1 (already installed)
 - pacman>=3.4.1 (already installed)
 - python>=2.6.5 (already installed)
 - sqlite3 (already installed)
 - git (already installed)
 - gnome-common (already installed)
 - intltool (already installed)
 - pm-utils (already installed)
 - libtar (package found)
 - gir-repository>=0.6.6 (building from AUR)
 - pacman-glib>=3.4.0 (building from AUR)


==> Continue building packagekit-git ? [Y/n]
==> ----------------------------------------
==> 
==> Building and installing package
==> Install or build missing dependencies for packagekit-git:
:: The following packages should be upgraded first :
    pacman
:: Do you want to cancel the current operation
:: and upgrade these packages now? [Y/n] Y

resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: package-query: requires pacman<3.6
:: pacman-color: requires pacman<3.6
==> Restart building packagekit-git ? [y/N]
==> ---------------------------------------

Offline

#13 2012-01-16 22:01:32

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: [SOLVED] Pacman wont upgrade any packages

You need to install the dependencies, that's quite obvious.

package-query won't work with pacman 4, IIRC package-query-git does.

Offline

#14 2012-01-16 22:12:19

Evilandi666
Member
Registered: 2010-10-28
Posts: 105

Re: [SOLVED] Pacman wont upgrade any packages

karol wrote:

You need to install the dependencies, that's quite obvious.

package-query won't work with pacman 4, IIRC package-query-git does.

That's wrong, package-query does now. See http://aur.archlinux.org/packages.php?ID=35915

Offline

#15 2012-01-16 22:13:11

lordoftux
Member
Registered: 2011-12-27
Posts: 7

Re: [SOLVED] Pacman wont upgrade any packages

karol wrote:

Why wait?

Well pacman should be upgraded first, no ?
Isn't there a chance to break packages if I do not upgrade it first ?

Sorry, it may be a silly question, but i'm new to arch, and, when
using others linux distros, when you didn't upgrade packages the
way they were supposed to be, you could end up with a broken system.

Ps: sorry for the english, I haven't practiced for years

Offline

#16 2012-01-16 22:15:20

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: [SOLVED] Pacman wont upgrade any packages

Sure, but if the mirrors you're using have already synced, you just install pacman, merge pacnew files, as reminded by the announcement [1] and update again - the rest of the packages.


[1] http://www.archlinux.org/news/pacman-4-moves-to-core/

Offline

#17 2012-01-16 22:17:06

cmlr
Member
From: Rochester, NY, USA
Registered: 2007-04-18
Posts: 96

Re: [SOLVED] Pacman wont upgrade any packages

Have you tried answering "n" to

:: Do you want to cancel the current operation
:: and upgrade these packages now? [Y/n] n

For me, this updated pacman and the other packages which were causing the problem.

Offline

#18 2012-01-16 22:17:21

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: [SOLVED] Pacman wont upgrade any packages

Evilandi666 wrote:
karol wrote:

You need to install the dependencies, that's quite obvious.

package-query won't work with pacman 4, IIRC package-query-git does.

That's wrong, package-query does now. See http://aur.archlinux.org/packages.php?ID=35915

Thanks for the info. They're sure quick to react :-)

Offline

#19 2012-01-16 22:18:49

Earnestly
Member
Registered: 2011-08-18
Posts: 802

Re: [SOLVED] Pacman wont upgrade any packages

:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...

Targets (1): fontforge-20111214-3

Total Installed Size:   26.92 MiB
Net Upgrade Size:       -0.02 MiB

Proceed with installation? [Y/n] y
(1/1) checking package integrity                                                                            [----------------------------------------------------------------] 100%
error: fontforge: signature from "Gaetan Bisson <gaetan.bisson@normalesup.org>" is unknown trust
error: failed to commit transaction (invalid or corrupted package (PGP signature))
Errors occurred, no packages were upgraded.

Pretty much sums up my current situation, any help?

Offline

#20 2012-01-16 22:19:30

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: [SOLVED] Pacman wont upgrade any packages

Please read the front page announcement http://www.archlinux.org/news/pacman-4-moves-to-core/

Offline

#21 2012-01-16 22:21:38

Earnestly
Member
Registered: 2011-08-18
Posts: 802

Re: [SOLVED] Pacman wont upgrade any packages

Ah, I did check the front page when upgrading (as usual) but the current news item at the time was still about udev changes. Thanks for the link.

Edit: Righto, temporarily disabled this nonsense until I can get my head around it. Thanks. (I did all the pacman-key --init and accepted the chaps key, but it still failed. Oh well.)

Last edited by Earnestly (2012-01-16 22:27:40)

Offline

#22 2012-01-16 22:30:37

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: [SOLVED] Pacman wont upgrade any packages

Did you edit pacman.conf and uncommented 'SigLevel = Optional TrustAll'?

Offline

#23 2012-01-16 22:35:41

orneo1212
Member
Registered: 2012-01-16
Posts: 23
Website

Re: [SOLVED] Pacman wont upgrade any packages

cmlr wrote:

Have you tried answering "n" to

:: Do you want to cancel the current operation
:: and upgrade these packages now? [Y/n] n

For me, this updated pacman and the other packages which were causing the problem.

Thats help  me thanks. I just answered no and update complete

Offline

#24 2012-01-16 22:37:09

viking60
Member
From: Valhalla
Registered: 2010-08-02
Posts: 95
Website

Re: [SOLVED] Pacman wont upgrade any packages

orneo1212 wrote:
cmlr wrote:

Have you tried answering "n" to

:: Do you want to cancel the current operation
:: and upgrade these packages now? [Y/n] n

For me, this updated pacman and the other packages which were causing the problem.

Thats help  me thanks. I just answered no and update complete

Helped me too - after I had removed pacman-color! Thanks!

Last edited by viking60 (2012-01-16 22:42:31)


"Common sense is not common"

Offline

#25 2012-01-16 22:43:13

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: [SOLVED] Pacman wont upgrade any packages

Your packages are your problem. If some of them are out of date you might end up in dependency hell.


Edit: Have you tried answering 'Yes'? It should work too: first you update pacman, merge pacnew files and run pacman again to update the rest of the system.

Last edited by karol (2012-01-16 22:44:15)

Offline

Board footer

Powered by FluxBB