You are not logged in.

#1 2012-01-16 06:12:21

From: Fredericton,Canada
Registered: 2009-10-01
Posts: 183

(SOLVED) Dual boot arch + backtrack

I'm trying to dual boot arch and backtrack but I'm getting an error:

:: Starting udevd...
:: Running hook [udev]
:: Triggering uevents...done.
/dev/sda3 looks like swapspace - not mounted
mount: you must specify the file system type
You are now being dropped into an emergency shell.
sh: can't access tty: job control turned off

Arch works fine by itself but once i install backtrack in the unpartition
space i run into this problem.I read somewhere that the uuid's can change
when dual booting with either arch or ubuntu so i checked the swap uuid with the
"blkid" command, it matches fstab.I'm not sure what else i can tell you so let me
know if you need more info.

Last edited by unilx (2012-01-17 20:49:08)


#2 2012-01-16 14:04:38

From: Alaska, USA
Registered: 2011-01-07
Posts: 87

Re: (SOLVED) Dual boot arch + backtrack

Well, could you give us the output of

sudo fdisk -l

so we can see how your harddrive is partitioned?

Some basic things to think on:
1) When you installed Backtrack, did you also install the grub2 bootloader from there?
2) Would it be possible to use /dev/sdax mountpoints instead of UUID?

Team Ignition Kernel Developer
linux-ideapad developer/maintainer
Flame Kernel developer for Galaxy Nexus and Galaxy S3
Want a cheap, reliable VPS with AWESOME customer service?


#3 2012-01-17 20:48:43

From: Fredericton,Canada
Registered: 2009-10-01
Posts: 183

Re: (SOLVED) Dual boot arch + backtrack

It was a mbr partitioning problem, so i switched  gpt...problem solved


Board footer

Powered by FluxBB