You are not logged in.

#1 2012-01-22 18:20:47

heitorpb
Member
Registered: 2012-01-21
Posts: 27

[solved] No sound with ALC269VB on asus 1215b EeePC

Hello,

I've just finished the basic install on a Asus Eee PC 1215B (with an APU C-50) and I'm having problems to make the sound work. I've googled around without succes...

  # aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: SB [HDA ATI SB], device 0: ALC269VB Analog [ALC269VB Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


 # cat /proc/asound/card1/pcm0p/info 
card: 1
device: 0
subdevice: 0
stream: PLAYBACK
id: ALC269VB Analog
name: ALC269VB Analog
subname: subdevice #0
class: 0
subclass: 0
subdevices_count: 1
subdevices_avail: 1


 # cat /etc/modprobe.d/modprobe.conf
blacklist radeon

option snd-hda-intel mode=auto 

I've runned alsaconf and rebooted several times and nothing helped...

When I run alsamixer, the default chip that appears is ATI R6xx HDMI, with only S/PDIF channel, when I change card to HDA ATI SB (chip Realtek ALC269VB) it appears the usual channels the change volume. Only mic is muted, the I run speaker-test:

 # speaker-test -c 1

speaker-test 1.0.24.2

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
Playback open error: -2,No such file or directory

I dont have ideas to solve this...

Could someone help me??

Gratefull,
Heitor.

Last edited by heitorpb (2012-01-22 20:00:19)

Offline

#2 2012-01-22 18:53:45

Gusar
Member
Registered: 2009-08-25
Posts: 3,431

Re: [solved] No sound with ALC269VB on asus 1215b EeePC

Try with this in /etc/modprobe.d/modprobe.conf:

options snd_hda_intel id=SB index=0

If that won't work you'll have to play around with .asoundrc

Offline

#3 2012-01-22 19:35:52

heitorpb
Member
Registered: 2012-01-21
Posts: 27

Re: [solved] No sound with ALC269VB on asus 1215b EeePC

With this in modprobe.conf I get the same output in speaker-test. But alsamixer has changed a little: default card has not changed (HD-Audio Generic, chip ATI R6xx HDMI), but it now have two channels: PCM and S/PIDF.

I tryed to play something in audacious and I get an error:

 snd_pcm_open failed: No such file or directory. 

Do you have any sugestions with .asoundrc??

Offline

#4 2012-01-22 19:52:17

Gusar
Member
Registered: 2009-08-25
Posts: 3,431

Re: [solved] No sound with ALC269VB on asus 1215b EeePC

New try. Check IDs with:

cat /proc/asound/card0/id
cat /proc/asound/card1/id

Then do something like

options snd-hda-intel id=SB,HDMI index=0,1

using the IDs you got with the commands above.

As for .asoundrc, I've seen one recently, but can't remember where. Edit - Found it:

pcm.!default {
  type hw
  card SB
}

ctl.!default {
  type hw
  card SB
}

However this will only play one sound at a time. Check here if you want to play around with this stuff: http://alsa.opensrc.org/FAQ026. Hopefully you won't need to.

Last edited by Gusar (2012-01-22 20:02:39)

Offline

#5 2012-01-22 19:59:36

heitorpb
Member
Registered: 2012-01-21
Posts: 27

Re: [solved] No sound with ALC269VB on asus 1215b EeePC

 # cat /proc/asound/card0/id
SB

# cat /proc/asound/card!/id
SB_1 

I changed in modprobe.conf and rebooted:

  # cat modprobe.conf
options snd-hda-intel id=SB_1 index=1 

And now it is working!

Thanks Gusar!

Offline

Board footer

Powered by FluxBB