You are not logged in.

#1 2012-01-28 16:33:50

Uchiha
Member
From: Sabará/MG - Brasil
Registered: 2011-09-07
Posts: 45

[SOLVED] KDE 4.8 crash!

Hi!

Yesterday, I updated my system, and installed the KDE 4.8.
Today, when I started my computer, the KDE was with a grey wallpaper and big red squares, showing that the widgets was crashed too.

I couldn't take screenshots, but I took some photos to show you. When I had the KDE 4.7, everything worked perfectly.
How can I fix it? Should I downgrade to KDE 4.7? How to do it?

Thanks!
Sorry the bad english.

FJ0lFs.pnglZ4V0s.pngKWQAqs.png

Last edited by Uchiha (2012-01-29 11:49:53)


Linux user #519886

Offline

#2 2012-01-28 16:43:16

JokerBoy
Member
From: România
Registered: 2009-09-24
Posts: 641
Website

Offline

#3 2012-01-28 17:12:07

Uchiha
Member
From: Sabará/MG - Brasil
Registered: 2011-09-07
Posts: 45

Re: [SOLVED] KDE 4.8 crash!

I tried the both commands, but now the screen is completly white!


Linux user #519886

Offline

#4 2012-01-28 17:19:56

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 13,408

Re: [SOLVED] KDE 4.8 crash!

Last time I checked, KDE 4.8 is in testing.  In fact it just moved from kde-unstable.

Moderator: Moved


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
You assume people are rational and influenced by evidence.  You must not work with the public much. -- Trilby
----
How to Ask Questions the Smart Way

Offline

#5 2012-01-28 17:20:31

JokerBoy
Member
From: România
Registered: 2009-09-24
Posts: 641
Website

Re: [SOLVED] KDE 4.8 crash!

You can try to disable the effects. https://wiki.archlinux.org/index.php/Composite

Or if you are using some widgets from aur, make sure they are updated for 4.8 series. if not remove them.

Also, in the last shot it says something, are you kind to translate into english!? smile


ewaller - kde 4.8 it's already in extra..

Last edited by JokerBoy (2012-01-28 17:22:06)

Offline

#6 2012-01-28 17:38:11

toad
Member
From: if only I knew
Registered: 2008-12-22
Posts: 1,775
Website

Re: [SOLVED] KDE 4.8 crash!

You could also try installing kde-extragear-plasmoids from the AUR


never trust a toad...
::Grateful ArchDonor::
::Grateful Wikipedia Donor::

Offline

#7 2012-01-28 18:45:08

Uchiha
Member
From: Sabará/MG - Brasil
Registered: 2011-09-07
Posts: 45

Re: [SOLVED] KDE 4.8 crash!

JokerBoy wrote:

You can try to disable the effects. https://wiki.archlinux.org/index.php/Composite

Or if you are using some widgets from aur, make sure they are updated for 4.8 series. if not remove them.

Also, in the last shot it says something, are you kind to translate into english!? smile


ewaller - kde 4.8 it's already in extra..

It means: "It's not possible to load the widget. It can't find the requested component."
I have a widget from AUR, the CWP, I'll try to remove!


Linux user #519886

Offline

#8 2012-01-28 18:50:40

canen
Member
From: Jamaica
Registered: 2008-11-28
Posts: 35

Re: [SOLVED] KDE 4.8 crash!

Don't forget to install the official package -  extra/kdeplasma-addons-applets-icontasks. It's now a part of KDE.

Offline

#9 2012-01-28 19:07:05

Uchiha
Member
From: Sabará/MG - Brasil
Registered: 2011-09-07
Posts: 45

Re: [SOLVED] KDE 4.8 crash!

I removed the CWP, but nothing changes. I'll try to install kde-extragear-plasmoids and kdeplasma-addons-applets-icontasks.


Linux user #519886

Offline

#10 2012-01-28 19:26:37

Cows
Member
From: Brooklyn, NY
Registered: 2007-05-20
Posts: 101

Re: [SOLVED] KDE 4.8 crash!

This happened to me as well, the thing was that I was playing around with the 4.7 PKGBUILDs to migrate to 4.8 by myself (Without depending on the Arch community + to learn more about PKGBUILDs), and I successfully compiled the packages, but I was mixing around kdelibs 4.8 with kdebase-workspace 4.7. This was the problem that gave me the same things you are mentioning. So make sure that your kdebase-workspace, kdelibs, and kdebase-runtime are all 4.8.

Offline

#11 2012-01-28 19:43:15

Uchiha
Member
From: Sabará/MG - Brasil
Registered: 2011-09-07
Posts: 45

Re: [SOLVED] KDE 4.8 crash!

Uchiha wrote:

I removed the CWP, but nothing changes. I'll try to install kde-extragear-plasmoids and kdeplasma-addons-applets-icontasks.

Nothing changed! =/

Cows wrote:

This happened to me as well, the thing was that I was playing around with the 4.7 PKGBUILDs to migrate to 4.8 by myself (Without depending on the Arch community + to learn more about PKGBUILDs), and I successfully compiled the packages, but I was mixing around kdelibs 4.8 with kdebase-workspace 4.7. This was the problem that gave me the same things you are mentioning. So make sure that your kdebase-workspace, kdelibs, and kdebase-runtime are all 4.8.

I checked them all with the pacman, and all are 4.8.0-1.

EDIT

I tried to reinstall the kde-base, and the terminal show me about 70mb to be downloaded, the update wasn't completed (weird, because yesterday, the terminal doesen't show me an error). I'll have to change the / partition size because it's full.

Last edited by Uchiha (2012-01-28 20:20:56)


Linux user #519886

Offline

#12 2012-01-28 22:09:40

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 13,408

Re: [SOLVED] KDE 4.8 crash!

JokerBoy wrote:

ewaller - kde 4.8 it's already in extra..

Well I'll be...
When I posted that, my mirror was still 4.7.  That was fast.

Thanks for the heads up, moving it back....   hmm


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
You assume people are rational and influenced by evidence.  You must not work with the public much. -- Trilby
----
How to Ask Questions the Smart Way

Offline

#13 2012-01-28 22:55:46

ssri
Member
Registered: 2010-02-16
Posts: 213

Re: [SOLVED] KDE 4.8 crash!

Try moving your ~/.kde4 -> ~/.kde4-bak and restart KDE.  Make sure that you updated all kdeplasma-addons-... to 4.8.  The problem could be some widgets that you were using were compiled against kdebase 4.7.x. through AUR or something....

EDIT: **sigh** I should learn to read... What Jokeboy said above...

Last edited by ssri (2012-01-28 22:57:58)

Offline

#14 2012-01-28 23:01:48

Primoz
Member
From: Ljubljana-Slovena-EU
Registered: 2009-03-04
Posts: 664

Re: [SOLVED] KDE 4.8 crash!

I get similar problem... But I have pinpointed it to lib mix-up. I've made an test account and that one works fine.
But my main account, is completely "f$$ed-up". When I logged in in TWM as my user and ran dolphin to pin/point it further, I've seen this error while dolphin started to run:

dolphin (3875)/kdecore (KSycoca) KSycocaPrivate::checkVersion: Found version 204, expecting version 205 or higher.
/this goes on.../
then I get to this:
kbuildsycoca4: ERROR creating database '/var/tmp/kdecache-primoz/ksycoca3'! Impossible to open temporary file.
ERROR: Running KSycoca failed (and then the top part of the error repeats itself.

So is there something wrong with my kdecache? Is the symlink to libcoca4 wrong? Help would be good.


Arch x86_64 ATI AMD APU KDE frameworks 5
---------------------------------
Whatever I do, I always end up with something horribly mis-configured.

Offline

#15 2012-01-28 23:09:09

Primoz
Member
From: Ljubljana-Slovena-EU
Registered: 2009-03-04
Posts: 664

Re: [SOLVED] KDE 4.8 crash!

Oh, I fixed it. It was what I thought it was... The permissions for kdecache-primoz were set wrong, I wasn't allowed to edit the contents of it.
I applied those changes, and it works now.
So Uchiha, hope that helps to solve your problem.


Arch x86_64 ATI AMD APU KDE frameworks 5
---------------------------------
Whatever I do, I always end up with something horribly mis-configured.

Offline

#16 2012-01-29 08:11:34

Subreptivus
Member
Registered: 2011-09-19
Posts: 1

Re: [SOLVED] KDE 4.8 crash!

Hello, Uchiha and everyone!

Last time I got this problem, there was a lack of free space on \, yes just that simple...
Hope this helps.

Offline

#17 2012-01-29 11:49:18

Uchiha
Member
From: Sabará/MG - Brasil
Registered: 2011-09-07
Posts: 45

Re: [SOLVED] KDE 4.8 crash!

Subreptivus wrote:

Hello, Uchiha and everyone!

Last time I got this problem, there was a lack of free space on \, yes just that simple...
Hope this helps.

Exactly how I saw! I put 3gb more in / partition and reinsatlled the kdebase. It's nice now!
Thank you very much for all the help guys! smile


Linux user #519886

Offline

Board footer

Powered by FluxBB