You are not logged in.

#1 2011-12-31 16:07:00

Registered: 2010-11-07
Posts: 19

laptop-mode: shutdown problem

I have HP Elitebook 8540W.
When I enable the laptop-mode on this computer, I can't shutdown it anymore.
When I shutdown my PC, everything goes well until it reaches "Remounting root filesystem readonly":

Remounting root filesystem readonly
[137.532383] ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
[137.532529] ata2.00: cmd a0/00:00:00:08:00/00:00:00:00:00/a0 tag 0 pio 16392
[137.532531]          res 40/00:02:00:00:02/00:00:00:00:00/00 Emask 0x4 (timeout)
[137.532813] ata2.00: status: {DRDY}
[142.849448] ata2.00: revalidation failed (errno=-5)

After this I have to shutdown my PC manually by pressing the power button for 5 seconds.
The ata2 in the logging above points to my BD-ROM drive (BC-5501H).

When I disable laptop-mode in rc.conf, the problem is gone.

Are there any "powersave options" I can disable for my BD-ROM somewhere in laptop-mode ?


#2 2012-02-03 19:28:17

Registered: 2012-02-03
Posts: 7

Re: laptop-mode: shutdown problem

Same problem here on HP Elitebook 6930p.

After some hours of googling & reading I found out that problem actually wasn't caused by BD, DVD, HDD, or anything ATA-related. The reason was e1000e ethernet driver combined with wicd & laptop-mode. Solution is simple: add this line to /etc/rc.local.shutdown

ifconfig eth0 down

Sorry for my bad English wink

Last edited by 12oz.oleg (2012-02-03 22:49:15)


#3 2012-02-07 01:04:41

doug piston
From: Seattle
Registered: 2011-09-11
Posts: 387

Re: laptop-mode: shutdown problem

I was getting this error not on shutdown but on booting. I implemented your fix and seems to have done the trick but I am more curious about what all of a sudden caused it? I do use WICD if that makes a difference.

Still get the error.

Last edited by doug piston (2012-02-08 01:15:52)


#4 2012-02-08 14:10:49

Registered: 2012-02-03
Posts: 7

Re: laptop-mode: shutdown problem

As I understood my problem was caused by Wake-on-LAN function. You can disable it in BIOS if you don't need it.
Also if you don't realy need ethernet connection you can remove eth0 from ethernet interface in wicd options, so wicd won't touch it anymore.
These solutions worked for me as well as one mentioned above, but now I just removed laptop-mode and using pm-utils powersave script. More information on
Battery life is now much longer than with laptop-mode and I didn't encounter shutdown problems yet.


#5 2012-03-25 12:15:54

Registered: 2004-03-06
Posts: 8

Re: laptop-mode: shutdown problem

Could you try to add:
to your kernel parameters in grub[2]?

In your case this would be:

It's a pretty long shot but here I had a similar issue with the powersavings stuff that I could resolve this way.


Board footer

Powered by FluxBB