You are not logged in.

#1 2005-08-02 20:30:28

ammiellodebar
Member
Registered: 2005-03-10
Posts: 23

Configuring Soundblaster Live 24-bit card....

I am having trouble configuring this card.. mainly im thinking because when i modprobe snd-ca0106 it says it doesnt exist....

Can anyone help me?

Thanks alot,
Mike

Offline

#2 2005-08-02 21:04:05

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: Configuring Soundblaster Live 24-bit card....

I think its emu10k1 either that or try emu10kx (for Dell OEM).
you can also run alsaconf and see what it brings up.

Offline

#3 2005-08-02 21:24:51

ammiellodebar
Member
Registered: 2005-03-10
Posts: 23

Re: Configuring Soundblaster Live 24-bit card....

wooh!!! I GOT IT WORKING!!

the solution was running alsaconf after turning off my onboard sound... i added some stuff about the ca106 card in modprobe.conf (or modules.conf) and bingo!!

works perfect!!


thanks anyways

Offline

#4 2005-08-03 01:55:23

ammiellodebar
Member
Registered: 2005-03-10
Posts: 23

Re: Configuring Soundblaster Live 24-bit card....

Ahh sad now i have a new problem,

the capture on my microphone is really scratchy into the soundcard (from a mixer into the soundcard), its all distorted and you have to shout to hear something...

Offline

#5 2005-08-03 02:57:25

max_sipos
Member
From: Ithaca, NY
Registered: 2004-10-31
Posts: 106
Website

Re: Configuring Soundblaster Live 24-bit card....

Try bringing up the volume with alsamixer.

Offline

#6 2005-08-03 03:37:57

ammiellodebar
Member
Registered: 2005-03-10
Posts: 23

Re: Configuring Soundblaster Live 24-bit card....

no thats not it, its choppy, and distorted and i have to really shout to get some sound out

Offline

#7 2005-08-03 14:36:28

KalephOne
Member
From: Fortaleza, Brasil
Registered: 2004-04-02
Posts: 99

Re: Configuring Soundblaster Live 24-bit card....

I have an onboard live 24bit (my mobo is a Msi k8n sli deluxe), and to use it i have to install alsa-lib 1.0.9 and put this asound.conf in /etc otherwise i cant play multiple sounds at the same time. I hope this helps someone smile

/etc/asound.conf

# Override the default output used by ALSA.
# If you do not override the default, your default
# device is identical to the (unmixed) analog device
# shown below.  If you prefer mixed and/or digital
# output, uncomment the appropriate four lines below
# (only one slave.pcm line).
pcm.!default {
  type plug
## Uncomment the following to use mixed analog by default
  slave.pcm "dmix-analog"
## Uncomment the following to use unmixed digital by default
#  slave.pcm "digital-hw"
## Uncomment the following to use mixed digital by default
#  slave.pcm "dmix-digital"
}

# Alias for analog output on the nForce2 (hw:0,0)
# - This is identical to the device named "default"--which
# always exists and refers to hw:0,0 (unless overridden)
# - Therefore, we can specify "hw:0,0", "default", or "analog"
# to access analog output on the nForce2
pcm.analog {
 type plug
 slave.pcm "analog-hw"
}

# Control device (mixer, etc.) for the nForce2 card
ctl.analog {
 type hw
 card 0
}

# Alias for (rate-converted) mixed analog output on the
# nForce2 (hw:0,0)
#  - This will accept audio input--regardless of rate--and
# convert to the rate required for the dmix plugin
# (in this case 48000Hz)
pcm.mixed-analog {
 type plug
 slave.pcm "dmix-analog"
}

# Control device (mixer, etc.) for the nForce2 card
ctl.mixed-analog {
 type hw
 card 0
}

# Alias for (rate-converted) digital (S/PDIF) output on the
# nForce2 (hw:0,2)
#  - This will accept audio input--regardless of rate--and
# convert to the rate required for the S/PDIF hardware
# (in this case 48000Hz)
pcm.digital {
 type plug
 slave.pcm "digital-hw"
}

# Control device (mixer, etc.) for the nForce2 card
ctl.digital {
 type hw
 card 0
}

# Alias for mixed (rate-converted) digital (S/PDIF) output on the
# nForce2 (hw:0,2)
#  - This will accept audio input--regardless of rate--and
# convert to the rate required for the S/PDIF hardware
# (in this case 48000Hz)
pcm.mixed-digital {
 type plug
 slave.pcm "dmix-digital"
}

# Control device (mixer, etc.) for the nForce2 card
ctl.mixed-digital {
 type hw
 card 0
}

# The following devices are not useful by themselves.  They
# require specific rates, channels, and formats.  Therefore,
# you probably do not want to use them directly.  Instead use
# of of the devices defined above.

# Alias for analog output on the nForce2 (hw:0,0)
# Do not use this directly--it requires specific rate,
# channels, and format
pcm.analog-hw {
 type hw
 card 0
 # The default value for device is 0, so no need to specify
}

# Control device (mixer, etc.) for the nForce2 card
ctl.analog-hw {
 type hw
 card 0
}

# Alias for digital (S/PDIF) output on the nForce2 (hw:0,2)
# Do not use this directly--it requires specific rate,
# channels, and format
pcm.digital-hw {
 type hw
 card 0
 device 2
}

# Control device (mixer, etc.) for the nForce2 card
ctl.digital-hw {
 type hw
 card 0
}

# Direct software mixing plugin for analog output on
# the nForce2 (hw:0,0)
# Do not use this directly--it requires specific rate,
# channels, and format
pcm.dmix-analog {
 type dmix
 ipc_key 1234
 slave {
   pcm "analog-hw"
   period_time 0
   period_size 1024
   buffer_size 4096
   rate 48000
 }
}

# Control device (mixer, etc.) for the nForce2 card
ctl.dmix-analog {
 type hw
 card 0
}

# Direct software mixing plugin for digital (S/PDIF) output
# on the nForce2 (hw:0,2)
# Do not use this directly--it requires specific rate,
# channels, and format
pcm.dmix-digital {
 type dmix
 ipc_key 1235
 slave {
   pcm "digital-hw"
   period_time 0
   period_size 1024
   buffer_size 4096
   rate 48000
 }
}

# Control device (mixer, etc.) for the nForce2 card
ctl.dmix-digital {
 type hw
 card 0
}

Kaleph
jabber: kaleph@jabber.org

Offline

#8 2005-08-03 17:12:10

Michel
Member
From: Belgium
Registered: 2004-07-31
Posts: 286

Re: Configuring Soundblaster Live 24-bit card....

Some possibilities:

* did you mute your microphone? It's better to mute it, but I've heard some people let it on a little bit, so that they can hear what they are saying or something.

* turn up the volume? of your capture-line
* turn up the volume of the pcm-line
* if you have a microphone-boost-option, turn it on.
* what command are you using to record? If you're recording 8-bit samples, try 16-bit samples or maybe even more.

Well,

I hope this helps you a little bit,

Michel

Offline

Board footer

Powered by FluxBB