You are not logged in.

#1 2012-02-09 04:49:20

soupcan
Member
From: ?
Registered: 2008-10-25
Posts: 264

wicd fails to connect/inconsistently connects, manual connect works.

Hi all, wicd is failing to connect after an update today. I've tried both my wired and wireless networks; it fails to connect to both for the majority of the time. I've been able to connect 1 or twice to both without failure, however. Manually running "sudo dhcpcd eth0" connects without issue. The issue seems to be with dhcpcd 5.5.4-1, as a downgrade to the [core] version (5.2.12-4) fixes the issue. Any ideas?

/var/log/errors.log:

Feb  8 23:37:53 localhost dhcpcd[5808]: dhcpcd not running
Feb  8 23:37:54 localhost dhcpcd[5814]: dhcpcd not running
Feb  8 23:37:54 localhost dhcpcd[5820]: dhcpcd not running
Feb  8 23:37:57 localhost dhcpcd[5828]: eth0: sendmsg: Cannot assign requested address
Feb  8 23:38:00 localhost dhcpcd[5856]: dhcpcd not running
Feb  8 23:39:50 localhost dhcpcd[6067]: dhcpcd not running
Feb  8 23:39:50 localhost dhcpcd[6074]: dhcpcd not running
Feb  8 23:39:51 localhost dhcpcd[6082]: dhcpcd not running
Feb  8 23:40:08 localhost dhcpcd[6216]: dhcpcd not running
Feb  8 23:40:09 localhost dhcpcd[6238]: dhcpcd not running

/var/log/wicd/wicd.log:

2012/02/08 23:26:04 :: dhcpcd[3603]: eth0: checking for 192.168.1.7
2012/02/08 23:26:04 :: 
2012/02/08 23:26:04 :: dhcpcd[3603]: eth0: Router Advertisement from fe80::222:75ff:fed5:73d4
2012/02/08 23:26:04 :: 
2012/02/08 23:26:04 :: dhcpcd[3603]: forked to background, child pid 3626
2012/02/08 23:26:04 :: 
2012/02/08 23:26:04 :: 
2012/02/08 23:26:04 :: DHCP connection successful
2012/02/08 23:26:04 :: Connecting thread exiting.
2012/02/08 23:26:05 :: Sending connection attempt result success
2012/02/08 23:27:23 :: Connecting to wireless network s_wifi
2012/02/08 23:27:24 :: Putting interface down
2012/02/08 23:27:24 :: Releasing DHCP leases...
2012/02/08 23:27:24 :: Setting false IP...
2012/02/08 23:27:24 :: Stopping wpa_supplicant
2012/02/08 23:27:24 :: Flushing the routing table...
2012/02/08 23:27:24 :: Putting interface up...
2012/02/08 23:27:26 :: Running DHCP with hostname carbon
2012/02/08 23:27:26 :: dhcpcd[3760]: version 5.5.4 starting
2012/02/08 23:27:26 :: 
2012/02/08 23:27:26 :: dhcpcd[3760]: wlan0: waiting for carrier
2012/02/08 23:27:26 :: 
2012/02/08 23:27:26 :: dhcpcd[3760]: wlan0: carrier acquired
2012/02/08 23:27:26 :: 
2012/02/08 23:27:26 :: dhcpcd[3760]: wlan0: sending IPv6 Router Solicitation
2012/02/08 23:27:26 :: 
2012/02/08 23:27:26 :: dhcpcd[3760]: wlan0: sendmsg: Cannot assign requested address
2012/02/08 23:27:26 :: 
2012/02/08 23:27:26 :: dhcpcd[3760]: wlan0: broadcasting for a lease
2012/02/08 23:27:26 :: 
2012/02/08 23:27:27 :: dhcpcd[3760]: received RA for unexpected interface from fe80::222:75ff:fed5:73d4
2012/02/08 23:27:27 :: 
2012/02/08 23:27:27 :: dhcpcd[3760]: wlan0: Router Advertisement from fe80::222:75ff:fed5:73d4
2012/02/08 23:27:27 :: 
2012/02/08 23:27:27 :: dhcpcd[3760]: forked to background, child pid 3784
2012/02/08 23:27:27 :: 
2012/02/08 23:27:27 :: 
2012/02/08 23:27:27 :: DHCP connection successful
2012/02/08 23:27:27 :: not verifying
2012/02/08 23:27:27 :: Connecting thread exiting.
2012/02/08 23:27:30 :: Sending connection attempt result success
2012/02/08 23:28:04 :: Putting interface down
2012/02/08 23:28:04 :: Error checking link using /sys/class/net/eth0/carrier
2012/02/08 23:28:04 :: Releasing DHCP leases...
2012/02/08 23:28:04 :: Setting false IP...
2012/02/08 23:28:04 :: Stopping wpa_supplicant
2012/02/08 23:28:04 :: Flushing the routing table...
2012/02/08 23:28:04 :: Putting interface up...
2012/02/08 23:28:06 :: Running DHCP with hostname carbon
2012/02/08 23:28:06 :: dhcpcd[3899]: version 5.5.4 starting
2012/02/08 23:28:06 :: 
2012/02/08 23:28:06 :: dhcpcd[3899]: eth0: waiting for carrier
2012/02/08 23:28:06 :: 
2012/02/08 23:28:07 :: dhcpcd[3899]: eth0: carrier acquired
2012/02/08 23:28:07 :: 
2012/02/08 23:28:07 :: dhcpcd[3899]: eth0: sending IPv6 Router Solicitation
2012/02/08 23:28:07 :: 
2012/02/08 23:28:07 :: dhcpcd[3899]: eth0: sendmsg: Cannot assign requested address
2012/02/08 23:28:07 :: 
2012/02/08 23:28:07 :: dhcpcd[3899]: eth0: broadcasting for a lease
2012/02/08 23:28:07 :: 
2012/02/08 23:28:08 :: dhcpcd[3899]: eth0: offered 192.168.1.7 from 192.168.1.1
2012/02/08 23:28:08 :: 
2012/02/08 23:28:08 :: dhcpcd[3899]: eth0: acknowledged 192.168.1.7 from 192.168.1.1
2012/02/08 23:28:08 :: 
2012/02/08 23:28:08 :: dhcpcd[3899]: eth0: checking for 192.168.1.7
2012/02/08 23:28:08 :: 
2012/02/08 23:28:08 :: dhcpcd[3899]: eth0: Router Advertisement from fe80::222:75ff:fed5:73d4
2012/02/08 23:28:08 :: 
2012/02/08 23:28:08 :: dhcpcd[3899]: forked to background, child pid 3922
2012/02/08 23:28:08 :: 
2012/02/08 23:28:08 :: 
2012/02/08 23:28:08 :: DHCP connection successful
2012/02/08 23:28:08 :: Connecting thread exiting.
2012/02/08 23:28:09 :: Sending connection attempt result success
2012/02/08 23:35:31 :: Daemon going down, killing wicd-monitor...
2012/02/08 23:35:31 :: Removing PID file...
2012/02/08 23:35:31 :: Shutting down...
2012/02/08 23:35:31 :: Exception KeyError: KeyError(139867792365312,) in <module 'threading' from '/usr/lib/python2.7/threading.pyo'> ignored
2012/02/08 23:35:33 :: ---------------------------
2012/02/08 23:35:33 :: wicd initializing...
2012/02/08 23:35:33 :: ---------------------------
2012/02/08 23:35:33 :: wicd is version 1.7.1 717
2012/02/08 23:35:33 :: setting backend to external
2012/02/08 23:35:33 :: trying to load backend external
2012/02/08 23:35:33 :: successfully loaded backend external
2012/02/08 23:35:33 :: trying to load backend external
2012/02/08 23:35:33 :: successfully loaded backend external
2012/02/08 23:35:33 :: Automatically detected wireless interface wlan0
2012/02/08 23:35:33 :: setting wireless interface wlan0
2012/02/08 23:35:33 :: automatically detected wired interface eth0
2012/02/08 23:35:33 :: setting wired interface eth0
2012/02/08 23:35:33 :: setting wpa driver wext
2012/02/08 23:35:33 :: setting use global dns to False
2012/02/08 23:35:33 :: setting global dns
2012/02/08 23:35:33 :: global dns servers are None None None
2012/02/08 23:35:33 :: domain is None
2012/02/08 23:35:33 :: search domain is None
2012/02/08 23:35:33 :: setting automatically reconnect when connection drops True
2012/02/08 23:35:33 :: Setting dhcp client to 0
2012/02/08 23:35:33 :: Wireless configuration file found...
2012/02/08 23:35:33 :: Wired configuration file found...
2012/02/08 23:35:33 :: chmoding configuration files 0600...
2012/02/08 23:35:33 :: chowning configuration files root:root...
2012/02/08 23:35:33 :: Using wireless interface...wlan0
2012/02/08 23:35:33 :: Using wired interface...eth0
2012/02/08 23:35:47 :: Connecting to wireless network s_wifi
2012/02/08 23:35:47 :: Putting interface down
2012/02/08 23:35:48 :: Releasing DHCP leases...
2012/02/08 23:35:48 :: Setting false IP...
2012/02/08 23:35:48 :: Stopping wpa_supplicant
2012/02/08 23:35:48 :: Flushing the routing table...
2012/02/08 23:35:48 :: Putting interface up...
2012/02/08 23:35:50 :: Running DHCP with hostname carbon
2012/02/08 23:35:50 :: dhcpcd[5483]: version 5.2.12 starting
2012/02/08 23:35:50 :: 
2012/02/08 23:35:50 :: dhcpcd[5483]: wlan0: waiting for carrier
2012/02/08 23:35:50 :: 
2012/02/08 23:35:50 :: dhcpcd[5483]: wlan0: carrier acquired
2012/02/08 23:35:50 :: 
2012/02/08 23:35:50 :: dhcpcd[5483]: wlan0: broadcasting for a lease
2012/02/08 23:35:50 :: 
2012/02/08 23:35:51 :: dhcpcd[5483]: wlan0: offered 192.168.1.3 from 192.168.1.1
2012/02/08 23:35:51 :: 
2012/02/08 23:35:51 :: dhcpcd[5483]: wlan0: acknowledged 192.168.1.3 from 192.168.1.1
2012/02/08 23:35:51 :: 
2012/02/08 23:35:51 :: dhcpcd[5483]: wlan0: checking for 192.168.1.3
2012/02/08 23:35:51 :: 
2012/02/08 23:35:55 :: dhcpcd[5483]: wlan0: leased 192.168.1.3 for 283824000 seconds
2012/02/08 23:35:55 :: 
2012/02/08 23:35:55 :: dhcpcd[5483]: forked to background, child pid 5514
2012/02/08 23:35:55 :: 
2012/02/08 23:35:55 :: 
2012/02/08 23:35:55 :: DHCP connection successful
2012/02/08 23:35:55 :: not verifying
2012/02/08 23:35:55 :: Connecting thread exiting.
2012/02/08 23:35:58 :: Sending connection attempt result success
2012/02/08 23:37:39 :: Daemon going down, killing wicd-monitor...
2012/02/08 23:37:39 :: Removing PID file...
2012/02/08 23:37:39 :: Shutting down...
2012/02/08 23:37:39 :: Exception KeyError: KeyError(139889612089088,) in <module 'threading' from '/usr/lib/python2.7/threading.pyo'> ignored
2012/02/08 23:37:40 :: ---------------------------
2012/02/08 23:37:40 :: wicd initializing...
2012/02/08 23:37:40 :: ---------------------------
2012/02/08 23:37:40 :: wicd is version 1.7.1 717
2012/02/08 23:37:40 :: setting backend to external
2012/02/08 23:37:40 :: trying to load backend external
2012/02/08 23:37:40 :: successfully loaded backend external
2012/02/08 23:37:40 :: trying to load backend external
2012/02/08 23:37:40 :: successfully loaded backend external
2012/02/08 23:37:40 :: Automatically detected wireless interface wlan0
2012/02/08 23:37:40 :: setting wireless interface wlan0
2012/02/08 23:37:40 :: automatically detected wired interface eth0
2012/02/08 23:37:40 :: setting wired interface eth0
2012/02/08 23:37:40 :: setting wpa driver wext
2012/02/08 23:37:40 :: setting use global dns to False
2012/02/08 23:37:40 :: setting global dns
2012/02/08 23:37:40 :: global dns servers are None None None
2012/02/08 23:37:40 :: domain is None
2012/02/08 23:37:40 :: search domain is None
2012/02/08 23:37:40 :: setting automatically reconnect when connection drops True
2012/02/08 23:37:40 :: Setting dhcp client to 0
2012/02/08 23:37:41 :: Wireless configuration file found...
2012/02/08 23:37:41 :: Wired configuration file found...
2012/02/08 23:37:41 :: chmoding configuration files 0600...
2012/02/08 23:37:41 :: chowning configuration files root:root...
2012/02/08 23:37:41 :: Using wireless interface...wlan0
2012/02/08 23:37:41 :: Using wired interface...eth0
2012/02/08 23:37:46 :: Connecting to wireless network s_wifi
2012/02/08 23:37:46 :: Putting interface down
2012/02/08 23:37:46 :: Releasing DHCP leases...
2012/02/08 23:37:46 :: Setting false IP...
2012/02/08 23:37:47 :: Stopping wpa_supplicant
2012/02/08 23:37:47 :: Flushing the routing table...
2012/02/08 23:37:47 :: Putting interface up...
2012/02/08 23:37:49 :: Running DHCP with hostname carbon
2012/02/08 23:37:49 :: dhcpcd[5759]: version 5.5.4 starting
2012/02/08 23:37:49 :: 
2012/02/08 23:37:49 :: dhcpcd[5759]: wlan0: sending IPv6 Router Solicitation
2012/02/08 23:37:49 :: 
2012/02/08 23:37:49 :: dhcpcd[5759]: wlan0: sendmsg: Cannot assign requested address
2012/02/08 23:37:49 :: 
2012/02/08 23:37:49 :: dhcpcd[5759]: wlan0: broadcasting for a lease
2012/02/08 23:37:49 :: 
2012/02/08 23:37:49 :: dhcpcd[5759]: wlan0: Router Advertisement from fe80::222:75ff:fed5:73d4
2012/02/08 23:37:49 :: 
2012/02/08 23:37:49 :: dhcpcd[5759]: forked to background, child pid 5777
2012/02/08 23:37:49 :: 
2012/02/08 23:37:49 :: 
2012/02/08 23:37:49 :: DHCP connection successful
2012/02/08 23:37:49 :: not verifying
2012/02/08 23:37:49 :: Connecting thread exiting.
2012/02/08 23:37:52 :: Sending connection attempt result success
2012/02/08 23:37:52 :: Autoconnecting...
2012/02/08 23:37:53 :: Putting interface downAttempting to autoconnect with wired interface...
2012/02/08 23:37:53 :: 
2012/02/08 23:37:53 :: Releasing DHCP leases...
2012/02/08 23:37:53 :: Setting false IP...
2012/02/08 23:37:53 :: Stopping wpa_supplicant
2012/02/08 23:37:53 :: Flushing the routing table...
2012/02/08 23:37:53 :: Putting interface up...
2012/02/08 23:37:55 :: Running DHCP with hostname carbon
2012/02/08 23:37:55 :: dhcpcd[5828]: version 5.5.4 starting
2012/02/08 23:37:55 :: 
2012/02/08 23:37:55 :: dhcpcd[5828]: eth0: waiting for carrier
2012/02/08 23:37:55 :: 
2012/02/08 23:37:57 :: dhcpcd[5828]: eth0: carrier acquired
2012/02/08 23:37:57 :: 
2012/02/08 23:37:57 :: dhcpcd[5828]: eth0: sending IPv6 Router Solicitation
2012/02/08 23:37:57 :: 
2012/02/08 23:37:57 :: dhcpcd[5828]: eth0: sendmsg: Cannot assign requested address
2012/02/08 23:37:57 :: 
2012/02/08 23:37:57 :: dhcpcd[5828]: eth0: broadcasting for a lease
2012/02/08 23:37:57 :: 
2012/02/08 23:37:58 :: dhcpcd[5828]: eth0: offered 192.168.1.7 from 192.168.1.1
2012/02/08 23:37:58 :: 
2012/02/08 23:37:58 :: dhcpcd[5828]: eth0: acknowledged 192.168.1.7 from 192.168.1.1
2012/02/08 23:37:58 :: 
2012/02/08 23:37:58 :: dhcpcd[5828]: eth0: checking for 192.168.1.7
2012/02/08 23:37:58 :: 
2012/02/08 23:37:58 :: dhcpcd[5828]: eth0: Router Advertisement from fe80::222:75ff:fed5:73d4
2012/02/08 23:37:58 :: 
2012/02/08 23:37:58 :: dhcpcd[5828]: forked to background, child pid 5851
2012/02/08 23:37:58 :: 
2012/02/08 23:37:58 :: 
2012/02/08 23:37:58 :: DHCP connection successful
2012/02/08 23:37:58 :: Connecting thread exiting.
2012/02/08 23:38:00 :: Sending connection attempt result success
2012/02/08 23:38:01 :: No wired connection present, attempting to autoconnect to wireless network
2012/02/08 23:38:04 :: Unable to autoconnect, you'll have to manually connect
2012/02/08 23:39:43 :: Daemon going down, killing wicd-monitor...
2012/02/08 23:39:43 :: Removing PID file...
2012/02/08 23:39:43 :: Shutting down...
2012/02/08 23:39:43 :: Exception KeyError: KeyError(140388630619904,) in <module 'threading' from '/usr/lib/python2.7/threading.pyo'> ignored
2012/02/08 23:39:45 :: ---------------------------
2012/02/08 23:39:45 :: wicd initializing...
2012/02/08 23:39:45 :: ---------------------------
2012/02/08 23:39:45 :: wicd is version 1.7.1 717
2012/02/08 23:39:45 :: setting backend to external
2012/02/08 23:39:45 :: trying to load backend external
2012/02/08 23:39:45 :: successfully loaded backend external
2012/02/08 23:39:45 :: trying to load backend external
2012/02/08 23:39:45 :: successfully loaded backend external
2012/02/08 23:39:45 :: Automatically detected wireless interface wlan0
2012/02/08 23:39:45 :: setting wireless interface wlan0
2012/02/08 23:39:45 :: automatically detected wired interface eth0
2012/02/08 23:39:45 :: setting wired interface eth0
2012/02/08 23:39:45 :: setting wpa driver wext
2012/02/08 23:39:45 :: setting use global dns to False
2012/02/08 23:39:45 :: setting global dns
2012/02/08 23:39:45 :: global dns servers are None None None
2012/02/08 23:39:45 :: domain is None
2012/02/08 23:39:45 :: search domain is None
2012/02/08 23:39:45 :: setting automatically reconnect when connection drops True
2012/02/08 23:39:45 :: Setting dhcp client to 0
2012/02/08 23:39:45 :: Wireless configuration file found...
2012/02/08 23:39:45 :: Wired configuration file found...
2012/02/08 23:39:45 :: chmoding configuration files 0600...
2012/02/08 23:39:45 :: chowning configuration files root:root...
2012/02/08 23:39:45 :: Using wireless interface...wlan0
2012/02/08 23:39:45 :: Using wired interface...eth0
2012/02/08 23:39:50 :: Autoconnecting...
2012/02/08 23:39:50 :: Attempting to autoconnect with wired interface...
2012/02/08 23:39:50 :: Putting interface down
2012/02/08 23:39:51 :: Releasing DHCP leases...
2012/02/08 23:39:51 :: Setting false IP...
2012/02/08 23:39:51 :: Stopping wpa_supplicant
2012/02/08 23:39:51 :: Flushing the routing table...
2012/02/08 23:39:51 :: Putting interface up...
2012/02/08 23:39:53 :: Running DHCP with hostname carbon
2012/02/08 23:39:53 :: dhcpcd[6087]: version 5.2.12 starting
2012/02/08 23:39:53 :: 
2012/02/08 23:39:53 :: dhcpcd[6087]: eth0: waiting for carrier
2012/02/08 23:39:53 :: 
2012/02/08 23:39:53 :: dhcpcd[6087]: eth0: carrier acquired
2012/02/08 23:39:53 :: 
2012/02/08 23:39:53 :: dhcpcd[6087]: eth0: broadcasting for a lease
2012/02/08 23:39:53 :: 
2012/02/08 23:39:54 :: dhcpcd[6087]: eth0: offered 192.168.1.7 from 192.168.1.1
2012/02/08 23:39:54 :: 
2012/02/08 23:39:54 :: dhcpcd[6087]: eth0: acknowledged 192.168.1.7 from 192.168.1.1
2012/02/08 23:39:54 :: 
2012/02/08 23:39:54 :: dhcpcd[6087]: eth0: checking for 192.168.1.7
2012/02/08 23:39:54 :: 
2012/02/08 23:39:58 :: Daemon going down, killing wicd-monitor...
2012/02/08 23:39:58 :: Removing PID file...
2012/02/08 23:39:58 :: Shutting down...
2012/02/08 23:39:58 :: Exception KeyError: KeyError(140583090784000,) in <module 'threading' from '/usr/lib/python2.7/threading.pyo'> ignored
2012/02/08 23:40:00 :: ---------------------------
2012/02/08 23:40:00 :: wicd initializing...
2012/02/08 23:40:00 :: ---------------------------
2012/02/08 23:40:00 :: wicd is version 1.7.1 717
2012/02/08 23:40:00 :: setting backend to external
2012/02/08 23:40:00 :: trying to load backend external
2012/02/08 23:40:00 :: successfully loaded backend external
2012/02/08 23:40:00 :: trying to load backend external
2012/02/08 23:40:00 :: successfully loaded backend external
2012/02/08 23:40:00 :: Automatically detected wireless interface wlan0
2012/02/08 23:40:00 :: setting wireless interface wlan0
2012/02/08 23:40:00 :: automatically detected wired interface eth0
2012/02/08 23:40:00 :: setting wired interface eth0
2012/02/08 23:40:00 :: setting wpa driver wext
2012/02/08 23:40:00 :: setting use global dns to False
2012/02/08 23:40:00 :: setting global dns
2012/02/08 23:40:00 :: global dns servers are None None None
2012/02/08 23:40:00 :: domain is None
2012/02/08 23:40:00 :: search domain is None
2012/02/08 23:40:00 :: setting automatically reconnect when connection drops True
2012/02/08 23:40:00 :: Setting dhcp client to 0
2012/02/08 23:40:00 :: Wireless configuration file found...
2012/02/08 23:40:00 :: Wired configuration file found...
2012/02/08 23:40:00 :: chmoding configuration files 0600...
2012/02/08 23:40:00 :: chowning configuration files root:root...
2012/02/08 23:40:00 :: Using wireless interface...wlan0
2012/02/08 23:40:00 :: Using wired interface...eth0
2012/02/08 23:40:09 :: Putting interface down
2012/02/08 23:40:09 :: Releasing DHCP leases...
2012/02/08 23:40:09 :: Setting false IP...
2012/02/08 23:40:09 :: Stopping wpa_supplicant
2012/02/08 23:40:09 :: Flushing the routing table...
2012/02/08 23:40:09 :: Putting interface up...
2012/02/08 23:40:11 :: Running DHCP with hostname carbon
2012/02/08 23:40:11 :: dhcpcd[6245]: version 5.2.12 starting
2012/02/08 23:40:11 :: 
2012/02/08 23:40:11 :: dhcpcd[6245]: eth0: waiting for carrier
2012/02/08 23:40:11 :: 
2012/02/08 23:40:12 :: dhcpcd[6245]: eth0: carrier acquired
2012/02/08 23:40:12 :: 
2012/02/08 23:40:12 :: dhcpcd[6245]: eth0: broadcasting for a lease
2012/02/08 23:40:12 :: 
2012/02/08 23:40:13 :: dhcpcd[6245]: eth0: offered 192.168.1.7 from 192.168.1.1
2012/02/08 23:40:13 :: 
2012/02/08 23:40:13 :: dhcpcd[6245]: eth0: acknowledged 192.168.1.7 from 192.168.1.1
2012/02/08 23:40:13 :: 
2012/02/08 23:40:13 :: dhcpcd[6245]: eth0: checking for 192.168.1.7
2012/02/08 23:40:13 :: 
2012/02/08 23:40:18 :: dhcpcd[6245]: eth0: leased 192.168.1.7 for 283824000 seconds
2012/02/08 23:40:18 :: 
2012/02/08 23:40:18 :: dhcpcd[6245]: forked to background, child pid 6272
2012/02/08 23:40:18 :: 
2012/02/08 23:40:18 :: 
2012/02/08 23:40:18 :: DHCP connection successful
2012/02/08 23:40:18 :: Connecting thread exiting.
2012/02/08 23:40:19 :: Sending connection attempt result success

excerpt from dmesg:

[  220.232167] iwlwifi 0000:03:00.0: PCI INT A disabled
[  235.617077] Intel(R) Wireless WiFi Link AGN driver for Linux, in-tree:
[  235.617084] Copyright(c) 2003-2011 Intel Corporation
[  235.617227] iwlwifi 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[  235.617297] iwlwifi 0000:03:00.0: setting latency timer to 64
[  235.617467] iwlwifi 0000:03:00.0: pci_resource_len = 0x00002000
[  235.617472] iwlwifi 0000:03:00.0: pci_resource_base = ffffc900117e4000
[  235.617477] iwlwifi 0000:03:00.0: HW Revision ID = 0x35
[  235.618087] iwlwifi 0000:03:00.0: irq 56 for MSI/MSI-X
[  235.618299] iwlwifi 0000:03:00.0: Detected Intel(R) Centrino(R) Ultimate-N 6300 AGN, REV=0x74
[  235.618699] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[  235.647477] iwlwifi 0000:03:00.0: device EEPROM VER=0x436, CALIB=0x6
[  235.647483] iwlwifi 0000:03:00.0: Device SKU: 0X1f0
[  235.647488] iwlwifi 0000:03:00.0: Valid Tx ant: 0X7, Valid Rx ant: 0X7
[  235.647519] iwlwifi 0000:03:00.0: Tunable channels: 13 802.11bg, 24 802.11a channels
[  235.650620] iwlwifi 0000:03:00.0: loaded firmware version 9.221.4.1 build 25532
[  235.650965] Registered led device: phy1-led
[  235.651159] ieee80211 phy1: Selected rate control algorithm 'iwl-agn-rs'
[  246.254967] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[  246.261863] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[  246.530405] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[  246.537210] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[  246.685081] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  251.545715] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[  251.552573] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[  251.752912] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  252.006076] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[  252.058081] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[  252.060295] ADDRCONF(NETDEV_UP): eth0: link is not ready
[  252.305685] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[  252.357970] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[  252.359622] ADDRCONF(NETDEV_UP): eth0: link is not ready
[  253.667466] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[  253.674333] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[  253.880956] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  254.137065] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[  254.189437] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[  254.191042] ADDRCONF(NETDEV_UP): eth0: link is not ready
[  254.282074] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[  254.288879] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[  254.493939] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  256.572737] wlan0: authenticate with 00:22:75:d5:73:d4 (try 1)
[  256.627057] wlan0: deauthenticating from 00:22:75:d5:73:d4 by local choice (reason=3)
[  256.634142] wlan0: authenticate with 00:22:75:d5:73:d4 (try 1)
[  256.636012] wlan0: authenticated
[  256.737360] wlan0: associate with 00:22:75:d5:73:d4 (try 1)
[  256.786082] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx
[  256.826726] wlan0: deauthenticating from 00:22:75:d5:73:d4 by local choice (reason=3)
[  256.828337] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[  256.881172] wlan0: authenticate with 00:22:75:d5:73:d4 (try 1)
[  256.884801] wlan0: authenticated
[  256.986051] wlan0: associate with 00:22:75:d5:73:d4 (try 1)
[  256.991611] wlan0: RX AssocResp from 00:22:75:d5:73:d4 (capab=0x401 status=0 aid=1)
[  256.991618] wlan0: associated
[  257.006311] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[  541.311145] wlan0: deauthenticating from 00:22:75:d5:73:d4 by local choice (reason=3)
[  541.368832] cfg80211: Calling CRDA to update world regulatory domain
[  541.453885] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[  541.460755] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[  541.683356] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  542.134773] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[  542.187993] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[  542.189715] ADDRCONF(NETDEV_UP): eth0: link is not ready
[  545.110702] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx
[  545.111269] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[  546.693999] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[  546.700730] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[  546.936168] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  547.190401] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[  547.243068] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[  547.244623] ADDRCONF(NETDEV_UP): eth0: link is not ready
[  547.340217] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[  547.347099] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[  547.560981] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  549.644554] wlan0: authenticate with 00:22:75:d5:73:d4 (try 1)
[  549.647565] wlan0: authenticated
[  549.647945] wlan0: associate with 00:22:75:d5:73:d4 (try 1)
[  549.651558] wlan0: RX AssocResp from 00:22:75:d5:73:d4 (capab=0x401 status=0 aid=1)
[  549.651564] wlan0: associated
[  549.664372] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[  551.461505] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx
[  551.463148] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[  552.308069] wlan0: deauthenticating from 00:22:75:d5:73:d4 by local choice (reason=3)
[  552.361536] cfg80211: Calling CRDA to update world regulatory domain
[  552.462798] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[  552.469740] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[  552.690035] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  552.942343] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[  552.994174] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[  552.995790] ADDRCONF(NETDEV_UP): eth0: link is not ready
[  555.897119] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx
[  555.898730] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[  579.349813] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[  579.356589] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[  579.591802] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  579.846307] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[  579.898914] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[  579.900576] ADDRCONF(NETDEV_UP): eth0: link is not ready
[  580.152275] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[  580.205302] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[  580.206916] ADDRCONF(NETDEV_UP): eth0: link is not ready
[  582.895184] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx
[  582.896930] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[  585.270436] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[  585.277198] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[  585.499201] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  585.854505] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[  585.906564] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[  585.908183] ADDRCONF(NETDEV_UP): eth0: link is not ready
[  588.995907] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx
[  588.997528] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[  663.872912] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[  663.879693] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[  664.081192] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  664.334184] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[  664.385981] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[  664.387425] ADDRCONF(NETDEV_UP): eth0: link is not ready
[  664.487889] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[  664.494654] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[  664.717618] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  666.791284] wlan0: authenticate with 00:22:75:d5:73:d4 (try 1)
[  666.793798] wlan0: authenticated
[  666.794109] wlan0: associate with 00:22:75:d5:73:d4 (try 1)
[  666.797735] wlan0: RX AssocResp from 00:22:75:d5:73:d4 (capab=0x401 status=0 aid=1)
[  666.797743] wlan0: associated
[  666.813158] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[  667.322243] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx
[  667.323899] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[  670.192203] wlan0: deauthenticating from 00:22:75:d5:73:d4 by local choice (reason=3)
[  670.263747] cfg80211: Calling CRDA to update world regulatory domain
[  670.358193] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[  670.365031] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[  670.589231] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  670.840405] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[  670.893001] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[  670.894626] ADDRCONF(NETDEV_UP): eth0: link is not ready
[  675.344581] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx
[  675.346128] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[  703.509218] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[  703.515992] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[  703.736371] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  703.985977] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[  704.038426] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[  704.040078] ADDRCONF(NETDEV_UP): eth0: link is not ready
[  704.292262] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[  704.344831] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[  704.346446] ADDRCONF(NETDEV_UP): eth0: link is not ready
[  706.924844] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx
[  706.926454] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[  709.146741] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[  709.153635] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[  709.380526] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  709.727666] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[  709.779778] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[  709.781421] ADDRCONF(NETDEV_UP): eth0: link is not ready
[  712.682663] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx
[  712.683237] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 1163.099577] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[ 1163.106361] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[ 1163.334124] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 1163.785622] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[ 1163.838170] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[ 1163.839786] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 1164.088913] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[ 1164.141284] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[ 1164.142888] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 1166.755012] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[ 1166.761833] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[ 1166.791221] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx
[ 1167.001157] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 1167.002730] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 1167.256207] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[ 1167.308293] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[ 1167.309927] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 1167.433323] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[ 1167.440189] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[ 1167.683916] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 1169.766437] wlan0: authenticate with 00:22:75:d5:73:d4 (try 1)
[ 1169.769518] wlan0: authenticated
[ 1169.769895] wlan0: associate with 00:22:75:d5:73:d4 (try 1)
[ 1169.773508] wlan0: RX AssocResp from 00:22:75:d5:73:d4 (capab=0x401 status=0 aid=1)
[ 1169.773514] wlan0: associated
[ 1169.788727] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 1170.264529] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx
[ 1170.266191] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 1250.157515] wlan0: deauthenticating from 00:22:75:d5:73:d4 by local choice (reason=3)
[ 1250.213474] cfg80211: Calling CRDA to update world regulatory domain
[ 1250.304748] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[ 1250.311548] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[ 1250.531278] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 1250.786838] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[ 1250.839522] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[ 1250.841153] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 1253.742306] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx
[ 1253.743948] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 1285.564500] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[ 1285.571291] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[ 1285.799384] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 1286.050860] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[ 1286.102984] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[ 1286.104632] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 1286.225143] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[ 1286.231901] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[ 1286.434212] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 1288.467235] wlan0: authenticate with 00:22:75:d5:73:d4 (try 1)
[ 1288.469740] wlan0: authenticated
[ 1288.470052] wlan0: associate with 00:22:75:d5:73:d4 (try 1)
[ 1288.473730] wlan0: RX AssocResp from 00:22:75:d5:73:d4 (capab=0x401 status=0 aid=1)
[ 1288.473738] wlan0: associated
[ 1288.485867] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 1289.075695] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx
[ 1289.077339] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 1291.610215] wlan0: deauthenticating from 00:22:75:d5:73:d4 by local choice (reason=3)
[ 1291.654374] cfg80211: Calling CRDA to update world regulatory domain
[ 1291.749248] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[ 1291.755994] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[ 1291.979161] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 1292.230432] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[ 1292.283644] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[ 1292.285268] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 1292.534611] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[ 1292.586642] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[ 1292.588281] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 1293.916374] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[ 1293.923205] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[ 1294.158126] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 1294.410095] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[ 1294.461555] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[ 1294.463149] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 1296.861675] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx
[ 1296.863283] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 1299.572965] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[ 1299.579879] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[ 1299.802442] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 1300.160999] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[ 1300.212812] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[ 1300.214548] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 1303.095815] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx
[ 1303.097470] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 1409.502302] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[ 1409.509094] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[ 1409.732008] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 1409.987074] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[ 1410.039305] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[ 1410.040915] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 1410.289187] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[ 1410.342358] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[ 1410.344038] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 1413.025445] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx
[ 1413.027081] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 1427.879453] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[ 1427.886240] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[ 1428.101077] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 1428.452191] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[ 1428.505126] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[ 1428.506718] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 1428.756124] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[ 1428.808184] e1000e 0000:00:19.0: irq 55 for MSI/MSI-X
[ 1428.809809] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 1431.511433] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx
[ 1431.513072] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready

Arch64/XFCE

Offline

#2 2012-02-09 14:37:49

roobie
Member
Registered: 2011-07-19
Posts: 10

Re: wicd fails to connect/inconsistently connects, manual connect works.

I had a similar problem yesterday (especially reffering to the error "Exception KeyError: KeyError(-1219500352,) in <module 'threading' from '/usr/lib/python2.7/threading.pyo'> ignored"

And after reading https://bbs.archlinux.org/viewtopic.php?id=121589 i synced my system time with my hwclock and it worked after that. The command I used:

hwclock -u -systohc

It may be the cause of your problem as well...


"Experience is something you don't get until just after you need it." -- Olivier

Offline

#3 2012-02-09 15:27:20

soupcan
Member
From: ?
Registered: 2008-10-25
Posts: 264

Re: wicd fails to connect/inconsistently connects, manual connect works.

roobie wrote:

I had a similar problem yesterday (especially reffering to the error "Exception KeyError: KeyError(-1219500352,) in <module 'threading' from '/usr/lib/python2.7/threading.pyo'> ignored"

And after reading https://bbs.archlinux.org/viewtopic.php?id=121589 i synced my system time with my hwclock and it worked after that. The command I used:

hwclock -u -systohc

It may be the cause of your problem as well...

My hardware clock and system time are in sync and there's no change of time in my logs like is mentioned in the thread. I don't think this is the issue.
EDIT: This seems to be limited to my home network, possibly an IPv6 problem. Maybe the IPv6 address is not being assigned properly somewhere?

Last edited by soupcan (2012-02-10 00:23:03)


Arch64/XFCE

Offline

#4 2012-02-15 23:25:50

morecowbell
Member
From: USA
Registered: 2009-09-10
Posts: 9

Re: wicd fails to connect/inconsistently connects, manual connect works.

I seem to be having the same problem as well. My log files appear to be the same. Also I'm not using [testing].

Offline

#5 2012-02-19 17:03:19

Marin M.
Banned
Registered: 2011-11-12
Posts: 12

Re: wicd fails to connect/inconsistently connects, manual connect works.

Offline

#6 2012-03-06 23:45:21

soupcan
Member
From: ?
Registered: 2008-10-25
Posts: 264

Re: wicd fails to connect/inconsistently connects, manual connect works.

Just updating this as this is still an issue. I held off updating dhcpcd until today, and found that wicd still would not connect. Disabling IPv6 did not help as I had hoped. I've installed dhclient and set wicd to use that instead, which has (somewhat) resolved the issue for now. Still waiting on a fix for this.


Arch64/XFCE

Offline

#7 2012-03-11 17:18:14

kazimir
Member
Registered: 2012-01-20
Posts: 55

Re: wicd fails to connect/inconsistently connects, manual connect works.

Same problem here with the particularity that it only occurs on my home wifi network, wicd still work with the few other wifi network I tried.

Offline

#8 2012-03-11 22:51:08

xouillet
Member
Registered: 2012-03-11
Posts: 1

Re: wicd fails to connect/inconsistently connects, manual connect works.

Same problem here…

Looks like it's a wicd bug, it has been reported here : https://bugs.launchpad.net/wicd/+bug/933378

Offline

Board footer

Powered by FluxBB