You are not logged in.

#1 2012-02-16 22:34:53

rggjan
Member
Registered: 2007-01-06
Posts: 69

Chrome Fonts: fine, Firefox Fonts: ugly [solved]

Does anyone know why the fonts look suddenly so terrible on some webpages in Firefox? Both with default settings:

Firefox:
http://i.imgur.com/SMVdi.png

Chrome:
http://i.imgur.com/jNmxU.png

I mean, both have the same system fonts available. And I'm sure that Firefox looked nice, too, some updates ago.

Last edited by rggjan (2012-02-18 09:16:05)

Offline

#2 2012-02-16 23:00:32

grimi
Member
Registered: 2009-12-27
Posts: 26

Re: Chrome Fonts: fine, Firefox Fonts: ugly [solved]

Hi, it seems that firefox uses bitmap fonts.
Just disable them for X (link /etc/fonts/conf.avail/70-no-bitmaps.conf to /etc/fonts/conf.d/).
Regards.

Offline

#3 2012-02-16 23:10:25

litemotiv
Forum Fellow
Registered: 2008-08-01
Posts: 5,026

Re: Chrome Fonts: fine, Firefox Fonts: ugly [solved]

grimi wrote:

Hi, it seems that firefox uses bitmap fonts.
Just disable them for X (link /etc/fonts/conf.avail/70-no-bitmaps.conf to /etc/fonts/conf.d/).
Regards.

Maybe because github lists helvetica as the first font to use, which is symlinked to a bitmap font provided by xorg-fonts-100dpi / xorg-fonts-75dpi (i never understood why).

Last edited by litemotiv (2012-02-16 23:21:31)


ᶘ ᵒᴥᵒᶅ

Offline

#4 2012-02-18 09:15:50

rggjan
Member
Registered: 2007-01-06
Posts: 69

Re: Chrome Fonts: fine, Firefox Fonts: ugly [solved]

Great, disabling bitmap fonts did it, thanks a lot!

I added this fix to the archwiki Firefox page, right away:
https://wiki.archlinux.org/index.php/Fi … n_webpages

big_smile

Offline

#5 2012-02-18 11:00:44

berbae
Member
From: France
Registered: 2007-02-12
Posts: 1,172

Re: Chrome Fonts: fine, Firefox Fonts: ugly [solved]

@rggjan :
You forgot the -s (--symbolic) option of ln:
ln -s TARGET directory
It doesn't need to be a hard link, which is the default if not using the -s option.

Offline

#6 2012-02-18 11:08:20

rggjan
Member
Registered: 2007-01-06
Posts: 69

Re: Chrome Fonts: fine, Firefox Fonts: ugly [solved]

berbae wrote:

@rggjan :
You forgot the -s (--symbolic) option of ln:
ln -s TARGET directory
It doesn't need to be a hard link, which is the default if not using the -s option.

Fixed! big_smile

Offline

#7 2012-05-13 23:13:26

Marvell
Member
From: Poland
Registered: 2009-07-12
Posts: 28

Re: Chrome Fonts: fine, Firefox Fonts: ugly [solved]

Is it possible to disable bitmap fonts ONLY in firefox?
I use terminus font in urxvt, but after 

ln -s /etc/fonts/conf.avail/70-no-bitmaps.conf /etc/fonts/conf.d/ 

i can't ;(

Offline

#8 2012-05-14 02:40:45

Ranmaru
Member
From: Japan
Registered: 2011-11-20
Posts: 60

Re: Chrome Fonts: fine, Firefox Fonts: ugly [solved]

Try to leave bitmap fonts enabled and do

ln -s /etc/fonts/conf.avail/10-autohint.conf /etc/fonts/conf.d/

instead.

Last edited by Ranmaru (2012-05-14 02:43:07)

Offline

#9 2012-05-14 03:08:50

anonymous_user
Member
Registered: 2009-08-28
Posts: 3,058

Re: Chrome Fonts: fine, Firefox Fonts: ugly [solved]

This is my ~/.fonts.conf. It disables all bitmaps fonts EXCEPT for terminus:

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
    <!-- reject all bitmap fonts, with the exception of 'terminus' -->
    <selectfont>
        <acceptfont>
            <pattern>
                <patelt name="family"> <string>Terminus</string> </patelt>
            </pattern>
        </acceptfont>
        <rejectfont>
            <pattern>
                <patelt name="scalable"> <bool>false</bool> </patelt>
            </pattern>
        </rejectfont>
    </selectfont>
</fontconfig>

Remember to enable /etc/fonts/conf.avail/50-user.conf though.

Last edited by anonymous_user (2012-05-14 03:11:27)

Offline

#10 2012-05-14 10:28:15

Marvell
Member
From: Poland
Registered: 2009-07-12
Posts: 28

Re: Chrome Fonts: fine, Firefox Fonts: ugly [solved]

anonymous_user, thanks a lot, it works wink

Offline

Board footer

Powered by FluxBB