You are not logged in.

#26 2005-08-05 17:57:59

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: rxvt-unicode

Cerebral wrote:

$TERM=rxvt works fine for me, and is probably more accurate than xterm-color for rxvt-based terminals, I suppose.  tongue

Yeah, I think my xterm-color setting was simply a copy/paste from my aterm days.

rxvt-unicode should be there - I'll look at the package tonight

Offline

#27 2005-08-05 18:37:29

citral
Member
Registered: 2005-05-07
Posts: 87

Re: rxvt-unicode

jackmetal wrote:
citral wrote:

I'm being a nitpick here, but xterm-color is officially a bad habit.

I don't mind nitpicking!  If it helps me get a better config. :-)

I set mine all to rxvt and color still seems to work fine.  What is the 'recommended' term to use if xterm-color isn't good to use?

You probably won't ever notice a difference, but the xterm faq link I posted above dictates that 'xterm-xfree86' is the correct $TERM to use, so I've been using it ever since.  tongue


One of the main causes of the fall of the Roman Empire was that, lacking zero,
they had no way to indicate successful termination of their C programs.

Offline

#28 2005-08-05 19:55:36

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: rxvt-unicode

Yep, changing termname to "rxvt" works. Thanks. 8)

Offline

#29 2005-08-05 21:29:47

elasticdog
Member
From: Washington, USA
Registered: 2005-05-02
Posts: 995
Website

Re: rxvt-unicode

citral wrote:

You probably won't ever notice a difference, but the xterm faq link I posted above dictates that 'xterm-xfree86' is the correct $TERM to use, so I've been using it ever since.  tongue

Is this true even though we're running Xorg?

Offline

#30 2005-08-05 22:51:50

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: rxvt-unicode

Well, I find rxvt-unicode quite satisfactory now... There's only one problem with it I can find, other than the lack of a terminfo file:

IT NEEDS A DESKTOP FILE!

Uhh... sorry, couldn't help it. What can I say, I'm a sucker for standards compliance... I'll have to make a desktop file for it and post it in the comments for rxvt-unicode in the AUR.

Offline

#31 2005-08-05 23:06:52

citral
Member
Registered: 2005-05-07
Posts: 87

Re: rxvt-unicode

elasticdog wrote:
citral wrote:

You probably won't ever notice a difference, but the xterm faq link I posted above dictates that 'xterm-xfree86' is the correct $TERM to use, so I've been using it ever since.  tongue

Is this true even though we're running Xorg?

It seems that a transition might be made in the distant future, but for now it is definitely best to use xterm-xfree86. xterm-xorg doesn't even work yet, as 'xterm -tn xterm-xorg' shows. And considering that Xorg is just a fork of xfree86, it all makes sense.


One of the main causes of the fall of the Roman Empire was that, lacking zero,
they had no way to indicate successful termination of their C programs.

Offline

#32 2005-08-06 01:42:31

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: rxvt-unicode

cd /usr/share/terminfo/x
ln -s xterm-xfree86 xterm-xorg

tongue

edit: rxvt-unicode terminfo entry is now in the community package

Offline

#33 2005-08-06 03:41:49

ozar
Member
From: USA
Registered: 2005-02-18
Posts: 1,681

Re: rxvt-unicode

phrakture wrote:

edit: rxvt-unicode terminfo entry is now in the community package

Hmm... just downloaded the new package.  I can use any one of these and keep color:

urxvt*termName: xterm-color
urxvt*termName: xterm-xfree86
urxvt*termName: rxvt

...but I lose all color if I use:

urxvt*termName: rxvt-unicode

Is the "rxvt-unicode" file in /usr/share/terminfo/r supposed to be empy?  Mine is just an empy file.


oz

Offline

#34 2005-08-06 05:23:39

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: rxvt-unicode

Nope, it ain't, and the empty file is not working. roll In fact, urxvt gives me errors when I use nano ("error opening terminal: rxvt-unicode") with this new terminfo file.

Offline

#35 2005-08-06 05:49:37

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: rxvt-unicode

ditto, package upgrade is still broken.

iphitus

Offline

#36 2005-08-06 06:49:50

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: rxvt-unicode

BTW... Here's a desktopy entry for rxvt-unicode (based roughly on the one for gnome-terminal):

[Desktop Entry]
Encoding=UTF-8
Name=Urxvt
Comment=An rxvt clone with added features
Exec=urxvt
Categories=Application;System;Utility;TerminalEmulator;
StartupNotify=true

Offline

#37 2005-08-06 21:02:31

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: rxvt-unicode

Hmm, that's funny... The desktop entry doesn't work. :?

Offline

#38 2005-08-06 22:28:12

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: rxvt-unicode

Turn off startup notify.

phrakture: the rxvt-unicode entry you include is broken. I did a ./configure make make install and compile it myself, and it installed an entry fine.

iphitus

Offline

#39 2005-08-07 03:28:22

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: rxvt-unicode

Oh... Thanks, Iphitus. :oops:

Edit: nope... desktop entry still doesn't register with menumaker-devel.

Offline

#40 2005-08-07 03:47:50

ozar
Member
From: USA
Registered: 2005-02-18
Posts: 1,681

Re: rxvt-unicode

Gullible, here are a couple entries I found on another site.  You can try them if you wish:

[Desktop Entry]
Name=urxvt
Comment=a VT102 emulator for the X window system
Exec=urxvt
Terminal=false
Type=Application
Encoding=UTF-8
Categories=Application;System;
[Desktop Entry]
Encoding=UTF-8
Name=urxvt-single
Exec=urxvt
Icon=xterm.png
Terminal=false
Type=Application
Categories=Application;XTerminals;

oz

Offline

#41 2005-08-07 06:07:09

Gullible Jones
Member
Registered: 2004-12-29
Posts: 4,863

Re: rxvt-unicode

Thanks... Now I have one that works!

[Desktop Entry]
Encoding=UTF-8
Name=Urxvt
Comment=An rxvt clone with added features
Exec=urxvt
Terminal=false
Type=Application
Categories=Application;System;TerminalEmulator;

Offline

#42 2005-08-08 00:39:44

kristian
Member
From: Norway
Registered: 2005-06-03
Posts: 24

Re: rxvt-unicode

Sorry I didn't see this thread. I started another thread about the same thing (I belive)  here: LINK

I won't repeat myself. I'll just keep on in this thread.

I removed the cvs-version from aur. (Witch works for me). To test the comunity-package again:
- When running "pacman -R rxvt-unicode-cvs", the terminfo-file was not removed.
- "pacman -S rxvt-unicode" resulted in:

checking for file conflicts... 
error: the following file conflicts were found:
  rxvt-unicode: /usr/share/terminfo/r/rxvt-unicode: exists in filesystem

-I moved the file to another location manually. Installing worked fine now. The terminfofile is present, and does not look blank (it's a binary file). But It still wont work. (same errors that I described in the thread I'm linking to.)
-Overwriting the terminfo-file from the comunity-package, with the one from the cvs-package makes it all work smile

I think I'm going back to CVS, don't like to have files from to diferent packages. Or?
Funny, just as I was about to post this message I tried:
"pacman -Qo /usr/share/terminfo/r/rxvt-unicode"
and it gave me:

/usr/share/terminfo/r/rxvt-unicode is owned by rxvt-unicode 5.7-2

What!? Shouldn't it say: rxvt-unicode-cvs "something"?
EDIT: Probably not. Ownership it's like it's expected to be. Allthough the file was originally installed by the cvs-package.

Those of you that cant get rxvt-unicode form the comunity to work. Try the PKGBUILD for cvs-version of rxvt-unicode in the aur (clickable link), while you wait for this problem to be taken care of.

Offline

#43 2005-08-08 01:05:45

ozar
Member
From: USA
Registered: 2005-02-18
Posts: 1,681

Re: rxvt-unicode

Maybe an admin or mod can split off the rxvt-unicode parts of this thread into a new thread.  The original thread was about aterm problems and we are now off of that, and onto rxvt-unicode problems.


oz

Offline

#44 2005-08-08 01:22:23

kristian
Member
From: Norway
Registered: 2005-06-03
Posts: 24

Re: rxvt-unicode

This thing is haunted!

I decided to remove it and install it again, but now I don't have any terminfofile anymore. It was not  install with the "rxvt-unicode"-package nor was it installed with the "rxvt-unicode-cvs"-package.

"/var/cache/pacman/pkg/rxvt-unicode-5.7-2.pkg.tar.gz" actually has a terminfo-file that doesn't work, or doesn't install at all.

I recompiled "rxvt-unicode-cvs" with the PKGBUILD from the aur, and installed. It works, and the terminfo-file is present. But this package doesn't contain any terminfo-file. Witch probably means that it was installed to my system in the makepkg-process. Witch is weird, or?

I have fakeroot istalled, and I thought it would prevent files from being installed on the system during the makepkg-process. But I didn't take my time to read anythig about how fakeroot works. Thus i haven't done anything with it, and I run makepkg as root... Am I stupid?

Offline

#45 2005-08-08 01:37:11

Cerebral
Forum Fellow
From: Waterloo, ON, CA
Registered: 2005-04-08
Posts: 3,108
Website

Re: rxvt-unicode

Suggestion: you don't need the terminfo file if you add the following to your .bashrc or equivalent shell startup file:

export TERM=xterm-xfree86

Or, you can insert the following

urxvt*termName: xterm-xfree86

into your .Xdefaults and .Xresources files (I have the two symlinked).

Alternatively, you can use xterm-color, xterm, or rxvt in place of xterm-xfree86 - each one is a slightly different terminal, but it was recommended earlier in this thread (I think) to use xterm-xfree86.

Offline

#46 2005-08-08 15:18:41

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: rxvt-unicode

Ack - ok, I'll have to fix it when I get home - no idea why it was empty... but the PKGBUILD does not install the correct terminfo file, so I had to manually do it.  Not sure why it's empty though...

Splitting rxvt-unicode stuff in a sec

Offline

#47 2005-08-10 14:58:08

neri
Forum Fellow
From: Victoria, Canada
Registered: 2003-05-04
Posts: 552

Re: rxvt-unicode

edited: fixed the .install file to get rid of the trouble described
further down the tread.

phrakture wrote:

Ack - ok, I'll have to fix it when I get home - no idea why it was empty... but the PKGBUILD does not install the correct terminfo file, so I had to manually do it.  Not sure why it's empty though...

Splitting rxvt-unicode stuff in a sec

Finally I fugured the issue and it takes a couple of manpages an error
messages reading to find the problem.

Firstly and foremost, don't mess with $TERM just do what you've been told
by the rxvt-manpages ->

export TERM=rxvt-unicode 

is the way to go.
Then the terminfo file needs to be installed, the trick instead is, it has to be
compiled. Ncurses brings in an terminfo compiler "tic", call it post_install. I
will post in time a way to make your vim aware of these colors.

Anybody else has some more issues? If not I'll put this to extra next week.
It has so many votes.

Sample files:
NOTE:
1. you need the the rxvt-unicode.png which I extracted from the *.ico file you can get from dibbles rxvt-unicode-cvs checkout
2. the rxvt-tabbed script kills all the resource you save in rxvt by pulling in perl and GTK2 - so be warned

# Contributor: dibblethewrecker dibblethewrecker.at.jiwe.dot.org
pkgname=rxvt-unicode
pkgver=5.7
pkgrel=3
pkgdesc="a clone of rxvt terminal emulator, modified to deal with Unicode (UCS-2 or UCS-4) i/o"
depends=('x-server' 'ncurses')
makedepends=('cvs' 'imagemagick')
url="http://software.schmorp.de/#rxvt-unicode"
license=""
install=$pkgname.install
source=(http://dist.schmorp.de/rxvt-unicode/$pkgname-$pkgver.tar.bz2 
        $pkgname.desktop $pkgname.png)

build() {
  cd $startdir/src/$pkgname-$pkgver
  ./configure --prefix=/usr --enable-everything
#    --enable-xft 
#    --enable-rxvt-scroll --enable-next-scroll 
#    --enable-xterm-scroll --enable-plain-scroll 
#    --enable-fontstyles --enable-codesets=all 
#    --enable-unicode3 --enable--combining 
#    --enable-utmp --enable-wtmp --enable-lastlog 
#    --enable-xmp-background --enable-transparency 
#    --enable-fading --enable-tinting --enable-menubar 
#    --enable-ttygid --enable-half-shadow 
#    --enable-xgetdefault --enable-strings --enable-frills 
#    --enable-iso14755 --enable-keepscrolling --enable-mousewheel 
#    --enable-slipwheeling --disable-new-selection --enable-dlmalloc 
#    --enable-smart-resize --enable-pointer-blank --with-name=urxvt 
#    --with-term=rxvt-unicode --with-terminfo=/usr/share/terminfo
  make || return 1
  make DESTDIR=$startdir/pkg install
 # install the tabbing wrapper ( requires gtk2-perl! )
  sed -i 's/"rxvt"/"urxvt"/' doc/rxvt-tabbed
  install -Dm 755 doc/rxvt-tabbed $startdir/pkg/usr/bin/rxvt-tabbed
 # install freedesktop menu and icon ( icon from cvs checkout )
  install -Dm644 ../${pkgname}.desktop 
    $startdir/pkg/usr/share/applications/${pkgname}.desktop
  install -Dm644 ../${pkgname}.png 
    $startdir/pkg/usr/share/pixmaps/${pkgname}.png
 # some people might have that as a blueprint for ther menues
  for file in doc/menu/*.menu; do
    install -Dm755 $file $startdir/pkg/usr/share/rxvt/`basename $file`
  done
 # terminfo file (we install it, ncurses' tic will compile it on post_install )
  install -Dm 644 doc/etc/$pkgname.terminfo
     $startdir/pkg/usr/share/terminfo/r/$pkgname
}
# vim: ft=sh

rxvt.install

# arg 1:  the new package version
post_install() {
  echo -n "compiling terminfo file... "
  /usr/bin/tic /usr/share/terminfo/r/rxvt-unicode
  echo "done."
  cat << 'EOM'
  --> urxvt is a 88 color terminal, to achieve that you have to set your $TERM
  -->          export TERM=rxvt-unicode
  --> Some ncurses application and editors like are capable of diplaying more
  --> than 8 dark + 8 light(bolded) colors. To honour rxvt's capabilities you
  --> have to mess with the respective applications' configuration then.
EOM
}

post_upgrade() {
  post_install $1
}

op=$1
shift

$op $*
# vim: ft=sh

rxvt-unicode.desktop

[Desktop Entry]
Version=1.0
Encoding=UTF-8
Name=rxvt-unicode
Comment=An Unicode capable rxvt clone
Exec=urxvt
Icon=rxvt-unicode
Terminal=false
Type=Application
Categories=Application;System;TerminalEmulator;

Offline

#48 2005-08-10 15:15:02

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: rxvt-unicode

wow - neri's on the ball today!

I haven't had my internet connection working at home... I was doing some furniture moving and hadn't hooked it back up - it's back and I'll make sure to update neotuli's package in [community] today with this stuff - thanks alot neri!

edit whoops missed the "I'll put this into extra" part

Offline

#49 2005-08-10 15:44:03

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,431
Website

Re: rxvt-unicode

I have updated my cvs version in similar fashion - good job this thread got split out!

Offline

#50 2005-08-10 15:54:29

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,431
Website

Re: rxvt-unicode

GREAT!  I built it, installed it, tried to run irssi in it and got:

setupterm() failed for TERM=rxvt-unicode: 0
Can't initialize screen handling, quitting.
You can still use the dummy mode with -d parameter

Offline

Board footer

Powered by FluxBB