You are not logged in.

#1 2012-02-19 16:19:45

Pyruzan
Member
Registered: 2010-10-19
Posts: 34

KNemo Problem with new libnl (3.2.7-1)

Since libnl being upgraded to version 3.2.7-1, KNemo works (the installed version is 0.7.3-2 from community-testing repo) and/or gets compiled no more.

~  ᐅ knemo
knemo: error while loading shared libraries: libnl.so.1: cannot open shared object file: No such file or directory

Trying to compile knemo-svn:

-- Found KDE 4.7 include dir: /usr/include
-- Found KDE 4.7 library dir: /usr/lib
-- Found the KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
CMake Error at /usr/share/apps/cmake/modules/FindPackageHandleStandardArgs.cmake:198 (MESSAGE):
  Could NOT find Libnl (missing: LIBNL_LIBRARY LIBNL_INCLUDE_DIR)
Call Stack (most recent call first):
  cmake/modules/FindLibnl.cmake:20 (find_package_handle_standard_args)
  CMakeLists.txt:19 (find_package)


-- Configuring incomplete, errors occurred!

Last edited by Pyruzan (2012-02-19 17:15:22)

Offline

#2 2012-02-19 16:26:28

Pyruzan
Member
Registered: 2010-10-19
Posts: 34

Re: KNemo Problem with new libnl (3.2.7-1)

By the way, downgrading libnl isn't an option since networkmanager depends on the new libnl to work.

Offline

#3 2012-02-19 16:36:40

Gusar
Member
Registered: 2009-08-25
Posts: 3,472

Re: KNemo Problem with new libnl (3.2.7-1)

Why downgrade libnl? Just install libnl1

Offline

#4 2012-02-19 17:09:08

Pyruzan
Member
Registered: 2010-10-19
Posts: 34

Re: KNemo Problem with new libnl (3.2.7-1)

@Gusar
libnl1 (legacy) was already installed.

Last edited by Pyruzan (2012-02-19 17:15:04)

Offline

#5 2012-02-19 17:20:02

Pyruzan
Member
Registered: 2010-10-19
Posts: 34

Re: KNemo Problem with new libnl (3.2.7-1)

Well, I simply made a visual mistake and saw the core repo's libnl 1.1-3 as libnl1 1.1-3, libnl1 1.1-1 and libnl 3.2.7-1 are both installed from testing and the problem still stands.

Offline

#6 2012-02-22 01:25:12

Pyruzan
Member
Registered: 2010-10-19
Posts: 34

Re: KNemo Problem with new libnl (3.2.7-1)

For those experiencing the same problem; I'm currently using 'netspeed plasmoid' instead of knemo and I'm completely satisfied smile

Offline

Board footer

Powered by FluxBB