You are not logged in.

#1 2012-02-09 15:56:12

litemotiv
Forum Fellow
Registered: 2008-08-01
Posts: 5,026

syslinux 4.05-1 + linux 3.2.5-1 = no boot

Just  as a warning to others: i just had a non-booting system with syslinux 4.05-1 and linux 3.2.5-1, hanging on the syslinux line right after it tries to load the initramfs. I had to chroot in to fix. I'm in a bit of a hurry today so i didn't check out which one is at fault, but downgrading both fixed things.


ᶘ ᵒᴥᵒᶅ

Offline

#2 2012-02-09 16:18:23

cybertorture
Member
Registered: 2010-05-05
Posts: 338

Re: syslinux 4.05-1 + linux 3.2.5-1 = no boot

core/linux 3.2.5-1 (base) [installed]
core/syslinux 4.05-1 [installed]

Everythig works booth on i686 and x64
funny thing is that i can not find any changelog for 4.05 but still problem may lay in type of boot partition maybe?
btw syslinux do not update boot image file "ldlinux.sys" so ehn you update you still use old one.

edit: i found out that updating that file make it appear in /boot rather than old place /boot/syslinux so a little edit on path will be required.

Last edited by cybertorture (2012-02-09 16:20:26)


O' rly ? Ya rly Oo

Offline

#3 2012-02-11 03:18:03

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,931

Re: syslinux 4.05-1 + linux 3.2.5-1 = no boot

I hadn't gotten around to checking the syslinux.cfg.pacnew file, so I've been using the old one. One of the interesting differences between them is in the INITRD line:

Old:

INITRD /initramfs-linux.img

New:

INITRD ../initramfs-linux.img

So it appears to me that cybertorture's observations could be related.

Last edited by skottish (2012-02-11 03:22:03)

Offline

#4 2012-03-01 22:33:38

litemotiv
Forum Fellow
Registered: 2008-08-01
Posts: 5,026

Re: syslinux 4.05-1 + linux 3.2.5-1 = no boot

Still having this issue, but i found out it's only on cold boot. Not that much of a problem since i usually suspend anyway...


ᶘ ᵒᴥᵒᶅ

Offline

#5 2012-03-01 22:54:58

Gusar
Member
Registered: 2009-08-25
Posts: 3,409

Re: syslinux 4.05-1 + linux 3.2.5-1 = no boot

I have this on my netbook with pretty much every syslinux and/or kernel version. I chalked it up to being another of the many, many quirks of this crazy machine and switched to grub because of it. Boot hangs, I turn off the machine and immediately turn it back on, boot works. Initramfs or no initramfs (using a custom kernel that doesn't require it), doesn't make a difference. Interesting to know I'm not the only one being hit by this.

Offline

Board footer

Powered by FluxBB