You are not logged in.

#1 2012-03-02 06:13:21

orbat
Member
Registered: 2012-03-02
Posts: 2

"eclipse and xulrunner are in conflict"?

I was trying to install Eclipse from extra, but I ran into the following problem:

➜  ~  sudo pacman -S eclipse
resolving dependencies...
looking for inter-conflicts...
:: eclipse and xulrunner are in conflict. Remove xulrunner? [y/N] n
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: eclipse and xulrunner are in conflict

I have a few programs installed that depend on xulrunner, so removing it doesn't work.

Is pacman's local database corrupted or is there really a conflict here? I can't figure out how to get pacman to tell me why xulrunner and Eclipse are in conflict.

Offline

#2 2012-03-02 06:39:07

skunktrader
Member
From: Brisbane, Australia
Registered: 2010-02-14
Posts: 1,321

Re: "eclipse and xulrunner are in conflict"?

Online

#3 2012-03-02 07:03:36

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: "eclipse and xulrunner are in conflict"?

skunktrader wrote:

that's the most stupidest solution ever smile. the best solution is to report on the tracker and drop xulrunner from monodevelop dependency chain

Last edited by wonder (2012-03-02 07:05:59)


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#4 2012-03-02 07:20:07

orbat
Member
Registered: 2012-03-02
Posts: 2

Re: "eclipse and xulrunner are in conflict"?

skunktrader wrote:

Christ, this is typical. I swear I didn't see that in either Google's or the forum search's results. Oh well.

Still, that doesn't really solve my problem since I'd like to have both Eclipse and XULRunner installed using pacman instead of just having to manually (gasp) download Eclipse.

Last edited by orbat (2012-03-02 07:22:48)

Offline

#5 2012-03-02 07:55:54

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: "eclipse and xulrunner are in conflict"?

you can ignore the update until monodevelop and his dependecies are fixed


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#6 2012-03-02 10:56:04

jaco
Member
From: Toulouse, France
Registered: 2011-03-17
Posts: 149

Re: "eclipse and xulrunner are in conflict"?

wonder wrote:
skunktrader wrote:

that's the most stupidest solution ever smile. the best solution is to report on the tracker and drop xulrunner from monodevelop dependency chain

The best solution, imho, would be to wait for the fix in "testing"... I've not reported in the tracker because someone else had already done and warned about the removal of xulrunner... without effect.
And, sorry, i'm not qualified to drop xulrunner from Monodevelop dependancy chain.

Anyway, i prefer using a old version of Eclipse AND Monodevelop than the brand new shiny version of Eclipse without Monodevelop.

Last edited by jaco (2012-03-02 10:58:12)

Offline

#7 2012-03-02 12:24:23

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: "eclipse and xulrunner are in conflict"?

@jaco i'm not sure i get you. old version of eclipse has the same issues with newer xul. It will just crash when showing tooltips


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#8 2012-03-02 13:59:37

jaco
Member
From: Toulouse, France
Registered: 2011-03-17
Posts: 149

Re: "eclipse and xulrunner are in conflict"?

wonder wrote:

@jaco i'm not sure i get you. old version of eclipse has the same issues with newer xul. It will just crash when showing tooltips

By 'old', i wanted to mean 'old upstream' (3.6.2 Helios, for instance -- just a matter of download the tar.gz and untar it somewhere...). Until now, i have no issue with it (but... crossing fingers)

Last edited by jaco (2012-03-02 14:01:02)

Offline

#9 2012-03-03 07:04:45

CheesyBeef
Member
Registered: 2008-06-04
Posts: 190

Re: "eclipse and xulrunner are in conflict"?

I also have this conflict neutral

Offline

#10 2012-03-03 09:42:58

giowck
Member
Registered: 2011-07-13
Posts: 77

Re: "eclipse and xulrunner are in conflict"?

no solution yet?

Offline

#11 2012-03-03 10:28:08

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: "eclipse and xulrunner are in conflict"?

giowck wrote:

no solution yet?

monodevelop dropped gecko-sharp-2.0 dependency and you can remove xulrunner all together


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#12 2012-03-03 10:35:08

giowck
Member
Registered: 2011-07-13
Posts: 77

Re: "eclipse and xulrunner are in conflict"?

wonder wrote:
giowck wrote:

no solution yet?

monodevelop dropped gecko-sharp-2.0 dependency and you can remove xulrunner all together

yes but i'm not using monodevelop. xulrunner is needed by the tor browser bundle from aur.

Offline

#13 2012-03-03 10:53:28

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: "eclipse and xulrunner are in conflict"?

giowck wrote:

yes but i'm not using monodevelop. xulrunner is needed by the tor browser bundle from aur.

pretty sure that's a makedepends than depends.


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#14 2012-03-03 11:14:02

ethail
Member
From: Spain
Registered: 2011-02-10
Posts: 225

Re: "eclipse and xulrunner are in conflict"?

giowck wrote:

yes but i'm not using monodevelop. xulrunner is needed by the tor browser bundle from aur.


If you need xulrunner for building something ( a makedepend and not a run-time dep) try to use a chroot for building:

https://wiki.archlinux.org/index.php/De … ean_Chroot

All of this, obviously only applies if you have something that conflicts with xulrunner (I use eclipse, so anything that uses xulrunner to build has to be built in a chroot)


My GitHub Page

Best Testing Repo Warning: [testing] means it can eat you hamster, catch fire and you should keep it away from children. And I'm serious here, it's not an April 1st joke.

Offline

#15 2012-03-03 11:29:31

giowck
Member
Registered: 2011-07-13
Posts: 77

Re: "eclipse and xulrunner are in conflict"?

ethail wrote:
giowck wrote:

yes but i'm not using monodevelop. xulrunner is needed by the tor browser bundle from aur.


If you need xulrunner for building something ( a makedepend and not a run-time dep) try to use a chroot for building:

https://wiki.archlinux.org/index.php/De … ean_Chroot

All of this, obviously only applies if you have something that conflicts with xulrunner (I use eclipse, so anything that uses xulrunner to build has to be built in a chroot)

on my system, xulrunner is not only a makedep but actually a runtime dep, because the tor browser package requires it.Maybe it is a bug by the aur packager?

Last edited by giowck (2012-03-03 11:29:48)

Offline

#16 2012-03-03 11:42:44

ethail
Member
From: Spain
Registered: 2011-02-10
Posts: 225

Re: "eclipse and xulrunner are in conflict"?

No, it's not a bug on the AUR helper you've used but what the PKGBUILD actually says, maybe the packager should question whether or not it is actually a run-time dep and not a makedep


My GitHub Page

Best Testing Repo Warning: [testing] means it can eat you hamster, catch fire and you should keep it away from children. And I'm serious here, it's not an April 1st joke.

Offline

#17 2012-03-03 11:45:21

giowck
Member
Registered: 2011-07-13
Posts: 77

Re: "eclipse and xulrunner are in conflict"?

hmm.. that kinda sucks. What do you suggest?

remove xulrunner and upgrade eclipse, modifiy the PKGBUILD of tor browser??

Offline

#18 2012-03-03 11:59:21

ethail
Member
From: Spain
Registered: 2011-02-10
Posts: 225

Re: "eclipse and xulrunner are in conflict"?

I just did. I did upgrade eclipse yesterday, removing xulrunner from my system (not used aside from building). I've tried to build tor-browser-en from the AUR, modifying the PKGBUILd to use xulrunner as makedepend, built it in a chroot and intalled in my system without xulrunner, it works.

Just change xulrunner from depends to makedepends and build in a chroot if you've upgraded  or build and then upgrade if you didn't


My GitHub Page

Best Testing Repo Warning: [testing] means it can eat you hamster, catch fire and you should keep it away from children. And I'm serious here, it's not an April 1st joke.

Offline

#19 2012-03-03 12:00:39

giowck
Member
Registered: 2011-07-13
Posts: 77

Re: "eclipse and xulrunner are in conflict"?

ok thanks

Offline

#20 2012-03-03 13:57:30

Micah89
Member
Registered: 2011-05-01
Posts: 29

Re: "eclipse and xulrunner are in conflict"?

Didnt quite get it how to solve this... is this going to be fixed soon? I basically can't upgrade the system because of this conflict.

Offline

#21 2012-03-03 14:23:47

giowck
Member
Registered: 2011-07-13
Posts: 77

Re: "eclipse and xulrunner are in conflict"?

@Micah89 just remove tor-browser and xulrunner, then upgrade your system and reinstall tor-browser by editing the PKGBUILD and removing xulrunner.

Offline

#22 2012-03-03 15:13:51

Micah89
Member
Registered: 2011-05-01
Posts: 29

Re: "eclipse and xulrunner are in conflict"?

I do not have tor-browser installed =X. Only xulrunner which is needed for other apps i guess.

Offline

#23 2012-03-03 16:50:10

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: "eclipse and xulrunner are in conflict"?

Micah89 wrote:

I do not have tor-browser installed =X. Only xulrunner which is needed for other apps i guess.

pacman -Qi xulrunner  | grep Required


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#24 2012-03-03 17:41:20

Micah89
Member
Registered: 2011-05-01
Posts: 29

Re: "eclipse and xulrunner are in conflict"?

[micah@myhost ~]$ pacman -Qi xulrunner  | grep Required
Required By    : gecko-sharp-2.0  gluezilla
[micah@myhost ~]$ pacman -Qi gecko-sharp-2.0  | grep Required
Required By    : None

So i guess its safe to remove xulrunner? From what i remember i thought ive seen xulrunner being installed
when i installed firefox... but i may be wrong =P

Offline

#25 2012-03-03 18:28:44

skython
Member
Registered: 2012-03-03
Posts: 5

Re: "eclipse and xulrunner are in conflict"?

I just had to update monodevelop first, then the dependency to gecko-sharp-2.0 disappeared and i could remove it.

So if you have the same Problem:

pacman -S monodevelop
pacman -R gecko-sharp-2.0 xulrunner
pacman -Syu

Last edited by skython (2012-03-03 18:29:02)

Offline

Board footer

Powered by FluxBB