You are not logged in.

#1 2012-03-04 04:54:57

Llama
Member
From: St.-Petersburg, Russia
Registered: 2008-03-03
Posts: 1,291

[SOLVED] ghc: could not satisfy dependencies

Hi,

After moving to the new haskell repo (http://xsounds.org/~haskell/$arch) I'm having this:

$ yaourt -Ss ghc
extra/ghc 7.4.1-2 (haskell) [installed: 7.0.3-2]
    The Glasgow Haskell Compiler

On the other hand (after -Syy):

$ yaourt -Syua --noconfirm
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
haskell is up to date
archlinuxfr is up to date
error: failed to prepare transaction (could not satisfy dependencies)
:: Starting full system upgrade...
:: haskell-base64-bytestring: requires ghc=7.0.3-2
:: haskell-base64-bytestring: requires haskell-bytestring=0.9.1.10
:: haskell-citeproc-hs: requires ghc=7.0.3-2
...

Somehow, I can't see where the dissatisfaction comes from.

Last edited by Llama (2012-03-09 16:42:20)

Offline

#2 2012-03-04 06:53:39

securitybreach
Member
From: In front of my computers
Registered: 2007-11-18
Posts: 409
Website

Re: [SOLVED] ghc: could not satisfy dependencies

Same issue here on x86_64:

missing dependency for haskell-hscolour : ghc=7.0.3-2
missing dependency for haskell-hscolour : haskell-containers=0.4.0.0

╔═ comhack@Cerberus 12:55 AM 
╚═══ ~-> pacman -Qi ghc | grep Version
Version        : 7.4.1-2

Last edited by securitybreach (2012-03-04 06:55:26)


"Every normal man must be tempted at times to spit upon his hands, hoist the black flag, and begin slitting throats." -- H.L. Mencken
Website      Configs
Forum Admin: Bruno's All Things Linux   
securitybreach<a>archlinux.us

Offline

#3 2012-03-04 06:55:06

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,396
Website

Re: [SOLVED] ghc: could not satisfy dependencies

Report it to the people running that repo.

Offline

#4 2012-03-04 06:57:07

securitybreach
Member
From: In front of my computers
Registered: 2007-11-18
Posts: 409
Website

Re: [SOLVED] ghc: could not satisfy dependencies

Allan wrote:

Report it to the people running that repo.

Good point but who should this be reported to as this is affecting multiple haskell packages?


"Every normal man must be tempted at times to spit upon his hands, hoist the black flag, and begin slitting throats." -- H.L. Mencken
Website      Configs
Forum Admin: Bruno's All Things Linux   
securitybreach<a>archlinux.us

Offline

#5 2012-03-04 06:58:44

securitybreach
Member
From: In front of my computers
Registered: 2007-11-18
Posts: 409
Website

Re: [SOLVED] ghc: could not satisfy dependencies

Ah it looks like the maintainer is Sergej Pupykin for a bunch of the haskell packages:
http://www.archlinux.org/packages/commu … -hslogger/

BTW I am not running the Haskell repo as the OP is

╔═ comhack@Cerberus 01:06 AM 
╚═══ ~-> yaourt -Syua
Password: 
:: Synchronizing package databases...
 xorg110 is up to date
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 Foreign packages: / 141 / 141
missing dependency for haskell-hscolour : ghc=7.0.3-2
missing dependency for haskell-hscolour : haskell-containers=0.4.0.0

Last edited by securitybreach (2012-03-04 07:08:01)


"Every normal man must be tempted at times to spit upon his hands, hoist the black flag, and begin slitting throats." -- H.L. Mencken
Website      Configs
Forum Admin: Bruno's All Things Linux   
securitybreach<a>archlinux.us

Offline

#6 2012-03-04 07:17:06

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,396
Website

Re: [SOLVED] ghc: could not satisfy dependencies

haskell-hslogger is updated in the repos for the haskell update.   Wait for your mirror to sync.

Offline

#7 2012-03-04 07:17:47

securitybreach
Member
From: In front of my computers
Registered: 2007-11-18
Posts: 409
Website

Re: [SOLVED] ghc: could not satisfy dependencies

Thanks a lot Allan!!!


"Every normal man must be tempted at times to spit upon his hands, hoist the black flag, and begin slitting throats." -- H.L. Mencken
Website      Configs
Forum Admin: Bruno's All Things Linux   
securitybreach<a>archlinux.us

Offline

#8 2012-03-05 04:05:21

dubtheat
Member
Registered: 2012-03-05
Posts: 9

Re: [SOLVED] ghc: could not satisfy dependencies

Any update on whether this was resolved in the end?

I've been having this identical problem for the past 24 hours when trying to pacman -Syu, and I don't use any custom mirrors.

:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: haskell-hscolour: requires ghc=7.0.3-2
:: haskell-hscolour: requires haskell-containers=0.4.0.0

I have ghc 7.0.3-2, haskell-hscolour 1.19-1, and am using xmonad, which I presume is why I have haskell-hscolour installed, otherwise I can't remember installing or needing it (perhaps when trying out custom configs).

I'm seeing haskell-containers listed as a dependency on the haskell-hscolour AUR page, but can't see that package anywhere in the official repos or the AUR.
It seems to have either appeared or disappeared overnight.

Offline

#9 2012-03-05 04:10:14

dubtheat
Member
Registered: 2012-03-05
Posts: 9

Re: [SOLVED] ghc: could not satisfy dependencies

I removed the package in question, as I was unable to find a need for it. Now there's apparently a bunch of haskell updates that've been added to the repos over the last few days, which are probably related to why it broke in the first place.

So to anybody else who has this problem, investigate whether you actually need the package in question (haskell-hscolours), and if so, contact the package maintainer asking why a non-existent package is listed as a dependency.

Last edited by dubtheat (2012-03-05 04:10:40)

Offline

#10 2012-03-05 08:20:23

mdev
Member
Registered: 2010-01-29
Posts: 15

Re: [SOLVED] ghc: could not satisfy dependencies

I think there is a deeper problem.

I only have haskell-platform and xmonad installed and pacman refuses to upgrade since two days (log below).

Was haskell-platform removed from the official repositories? Was that announced somewhere?

Just for my own reference, two related bug reports:
https://bugs.archlinux.org/task/28758
https://bugs.archlinux.org/task/16816

Starting full system upgrade...
:: Replace haskell-deepseq with extra/ghc? [Y/n] 
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: haskell-cgi: requires ghc=7.0.3-2
:: haskell-cgi: requires haskell-mtl=2.0.1.0-3.1
:: haskell-cgi: requires haskell-network=2.3.0.2-2.1
:: haskell-cgi: requires haskell-parsec=3.1.1-2.1
:: haskell-cgi: requires haskell-xhtml=3000.2.0.1-7.1
:: haskell-fgl: requires ghc=7.0.3-2
:: haskell-fgl: requires haskell-mtl=2.0.1.0-3.1
:: haskell-glut: requires ghc=7.0.3-2
:: haskell-haskell-src: requires ghc=7.0.3-2
:: haskell-haskell-src: requires haskell-syb=0.3-2.1
:: haskell-hunit: requires ghc=7.0.3-2
:: haskell-opengl: requires ghc=7.0.3-2
:: haskell-parallel: requires ghc=7.0.3-2
:: haskell-parallel: requires haskell-deepseq=1.1.0.2-2.1
:: haskell-platform: requires ghc=7.0.3-2
:: haskell-platform: requires haskell-http=4000.1.1-3.1
:: haskell-platform: requires haskell-quickcheck=2.4.0.1-3.1
:: haskell-platform: requires haskell-deepseq=1.1.0.2-2.1
:: haskell-platform: requires haskell-html=1.0.1.2-9.1
:: haskell-platform: requires haskell-mtl=2.0.1.0-3.1
:: haskell-platform: requires haskell-network=2.3.0.2-2.1
:: haskell-platform: requires haskell-parsec=3.1.1-2.1
:: haskell-platform: requires haskell-regex-base=0.93.2-4.1
:: haskell-platform: requires haskell-regex-posix=0.94.4-2.1
:: haskell-platform: requires haskell-regex-compat=0.93.1-4.1
:: haskell-platform: requires haskell-stm=2.2.0.1-2.1
:: haskell-platform: requires haskell-syb=0.3-2.1
:: haskell-platform: requires haskell-text=0.11.0.5-2.1
:: haskell-platform: requires haskell-transformers=0.2.2.0-3.1
:: haskell-platform: requires haskell-xhtml=3000.2.0.1-7.1
:: haskell-platform: requires haskell-zlib=0.5.3.1-2.1
:: haskell-platform: requires alex=2.3.5
:: haskell-platform: requires happy=1.18.6

Offline

#11 2012-03-05 09:09:24

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,396
Website

Re: [SOLVED] ghc: could not satisfy dependencies

None of those packages are in the repos so you are required to deal with them yourself.  Remove them, update, then reinstall the ones you need.

Offline

#12 2012-03-05 10:02:05

mdev
Member
Registered: 2010-01-29
Posts: 15

Re: [SOLVED] ghc: could not satisfy dependencies

OK, thanks. This basically means that haskell-platform was removed from the official repositories a few days ago
(one year after it was introduced: https://bugs.archlinux.org/task/16816 ).

I see that it now lives on the AUR: http://aur.archlinux.org/packages.php?ID=56992

Offline

#13 2012-03-05 10:40:12

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,396
Website

Re: [SOLVED] ghc: could not satisfy dependencies

Yes - haskell-package is a very un-Arch-like idea.  We package latest upstream releases.

Offline

#14 2012-03-05 14:23:36

Llama
Member
From: St.-Petersburg, Russia
Registered: 2008-03-03
Posts: 1,291

Re: [SOLVED] ghc: could not satisfy dependencies

Allan wrote:

None of those packages are in the repos so you are required to deal with them yourself.  Remove them, update, then reinstall the ones you need.

Eh? My whole haskell shebang exists for one reason:

$ yaourt -Ss haskell-pandoc
haskell/haskell-pandoc 1.8.2.1-10 [installed]

The relevant error messages:

:: haskell-pandoc: requires ghc=7.0.3-2
:: haskell-pandoc: requires haskell-http=4000.1.1-3.1
:: haskell-pandoc: requires haskell-mtl=2.0.1.0-3.1
:: haskell-pandoc: requires haskell-network=2.3.0.2-2.1
:: haskell-pandoc: requires haskell-parsec=3.1.1-2.1
:: haskell-pandoc: requires haskell-syb=0.3-2.1
:: haskell-pandoc: requires haskell-utf8-string=0.3.6-7.2
:: haskell-pandoc: requires haskell-xhtml=3000.2.0.1-7.1

Besides, ghc is present in extra, and of the right version, too. I still can't get it.

UPD:

Sorry, extra/ghc is 7.4.1-2. Still -- what am I to do?

Last edited by Llama (2012-03-05 14:58:13)

Offline

#15 2012-03-05 16:34:37

akuschki
Member
Registered: 2009-10-17
Posts: 40

Re: [SOLVED] ghc: could not satisfy dependencies

Eh? My whole haskell shebang exists for one reason:

$ yaourt -Ss haskell-pandoc
haskell/haskell-pandoc 1.8.2.1-10 [installed]

In Arch, installing pandoc via cabal (http://www.archlinux.org/packages/extra … l-install/) seems to be the least painful way in my experience. YMMV.

Offline

#16 2012-03-05 21:24:02

Stefan Husmann
Member
From: Germany
Registered: 2007-08-07
Posts: 998

Re: [SOLVED] ghc: could not satisfy dependencies

Remove all the version restrictions from the PKGBUILDS and try again. I never understood why they are there.

Offline

#17 2012-03-06 03:56:27

katelman
Member
Registered: 2011-05-16
Posts: 6

Re: [SOLVED] ghc: could not satisfy dependencies

I just want to register my interest in seeing this fixed in some sensible way as soon as possible.

Offline

#18 2012-03-06 04:20:59

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,396
Website

Re: [SOLVED] ghc: could not satisfy dependencies

katelman wrote:

I just want to register my interest in seeing this fixed in some sensible way as soon as possible.

Unsupported packages (i.e. anything not in the repos) are up to you to fix/update

Offline

#19 2012-03-06 09:28:29

dubtheat
Member
Registered: 2012-03-05
Posts: 9

Re: [SOLVED] ghc: could not satisfy dependencies

I don't recall ever installing any haskell packages that weren't directly from the repo's (or even from the AUR), so I think the problem everybody is having, is that they installed these from the repos, and all of a sudden some package dependencies have vanished from the repos, causing pacman to choke.

Forgive me if I'm wrong, but what else would cause everyone on haskell/xmonad to suddenly start having the same identical problem, and why did pacman start choking when it has been fine for over a year?

Offline

#20 2012-03-06 09:35:00

4on6
Member
Registered: 2011-10-05
Posts: 166

Re: [SOLVED] ghc: could not satisfy dependencies

Same problem here, can't update with pacman. My only use of Haskell (I'm aware of) is installing pandoc via cabal.

Someone must have broken something, since it worked all the time before. Any solutions for this?

Cheers

:: Replace haskell-deepseq with extra/ghc? [Y/n] y

[tj@arch ~]$ LC_ALL=C sudo pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
:: Starting full system upgrade...
:: Replace haskell-deepseq with extra/ghc? [Y/n] y
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: haskell-cgi: requires ghc=7.0.3-2
:: haskell-cgi: requires haskell-mtl=2.0.1.0-3.1
:: haskell-cgi: requires haskell-network=2.3.0.2-2.1
:: haskell-cgi: requires haskell-parsec=3.1.1-2.1
:: haskell-cgi: requires haskell-xhtml=3000.2.0.1-7.1
:: haskell-fgl: requires ghc=7.0.3-2
:: haskell-fgl: requires haskell-mtl=2.0.1.0-3.1
:: haskell-glut: requires ghc=7.0.3-2
:: haskell-haskell-src: requires ghc=7.0.3-2
:: haskell-haskell-src: requires haskell-syb=0.3-2.1
:: haskell-hunit: requires ghc=7.0.3-2
:: haskell-opengl: requires ghc=7.0.3-2
:: haskell-parallel: requires ghc=7.0.3-2
:: haskell-parallel: requires haskell-deepseq=1.1.0.2-2.1
:: haskell-platform: requires ghc=7.0.3-2
:: haskell-platform: requires haskell-http=4000.1.1-3.1
:: haskell-platform: requires haskell-quickcheck=2.4.0.1-3.1
:: haskell-platform: requires haskell-deepseq=1.1.0.2-2.1
:: haskell-platform: requires haskell-html=1.0.1.2-9.1
:: haskell-platform: requires haskell-mtl=2.0.1.0-3.1
:: haskell-platform: requires haskell-network=2.3.0.2-2.1
:: haskell-platform: requires haskell-parsec=3.1.1-2.1
:: haskell-platform: requires haskell-regex-base=0.93.2-4.1
:: haskell-platform: requires haskell-regex-posix=0.94.4-2.1
:: haskell-platform: requires haskell-regex-compat=0.93.1-4.1
:: haskell-platform: requires haskell-stm=2.2.0.1-2.1
:: haskell-platform: requires haskell-syb=0.3-2.1
:: haskell-platform: requires haskell-text=0.11.0.5-2.1
:: haskell-platform: requires haskell-transformers=0.2.2.0-3.1
:: haskell-platform: requires haskell-xhtml=3000.2.0.1-7.1
:: haskell-platform: requires haskell-zlib=0.5.3.1-2.1
:: haskell-platform: requires alex=2.3.5
:: haskell-platform: requires happy=1.18.6

:: Replace haskell-deepseq with extra/ghc? [Y/n] n

[tj@arch ~]$ LC_ALL=C sudo pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
:: Starting full system upgrade...
:: Replace haskell-deepseq with extra/ghc? [Y/n] n
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: haskell-cgi: requires ghc=7.0.3-2
:: haskell-cgi: requires haskell-mtl=2.0.1.0-3.1
:: haskell-cgi: requires haskell-network=2.3.0.2-2.1
:: haskell-cgi: requires haskell-parsec=3.1.1-2.1
:: haskell-cgi: requires haskell-xhtml=3000.2.0.1-7.1
:: haskell-deepseq: requires ghc=7.0.3-2
:: haskell-fgl: requires ghc=7.0.3-2
:: haskell-fgl: requires haskell-mtl=2.0.1.0-3.1
:: haskell-glut: requires ghc=7.0.3-2
:: haskell-haskell-src: requires ghc=7.0.3-2
:: haskell-haskell-src: requires haskell-syb=0.3-2.1
:: haskell-hunit: requires ghc=7.0.3-2
:: haskell-opengl: requires ghc=7.0.3-2
:: haskell-parallel: requires ghc=7.0.3-2
:: haskell-platform: requires ghc=7.0.3-2
:: haskell-platform: requires haskell-http=4000.1.1-3.1
:: haskell-platform: requires haskell-quickcheck=2.4.0.1-3.1
:: haskell-platform: requires haskell-html=1.0.1.2-9.1
:: haskell-platform: requires haskell-mtl=2.0.1.0-3.1
:: haskell-platform: requires haskell-network=2.3.0.2-2.1
:: haskell-platform: requires haskell-parsec=3.1.1-2.1
:: haskell-platform: requires haskell-regex-base=0.93.2-4.1
:: haskell-platform: requires haskell-regex-posix=0.94.4-2.1
:: haskell-platform: requires haskell-regex-compat=0.93.1-4.1
:: haskell-platform: requires haskell-stm=2.2.0.1-2.1
:: haskell-platform: requires haskell-syb=0.3-2.1
:: haskell-platform: requires haskell-text=0.11.0.5-2.1
:: haskell-platform: requires haskell-transformers=0.2.2.0-3.1
:: haskell-platform: requires haskell-xhtml=3000.2.0.1-7.1
:: haskell-platform: requires haskell-zlib=0.5.3.1-2.1
:: haskell-platform: requires alex=2.3.5
:: haskell-platform: requires happy=1.18.6

Last edited by 4on6 (2012-03-06 09:40:27)

Offline

#21 2012-03-06 09:37:27

dubtheat
Member
Registered: 2012-03-05
Posts: 9

Re: [SOLVED] ghc: could not satisfy dependencies

And since when does pacman update packages from the AUR?

Offline

#22 2012-03-06 09:44:38

4on6
Member
Registered: 2011-10-05
Posts: 166

Re: [SOLVED] ghc: could not satisfy dependencies

dubtheat wrote:

And since when does pacman update packages from the AUR?

I did not update my AUR packages for a while, therefore it seems something must have happened in the 'pacman universe' that broke things?

Offline

#23 2012-03-06 09:46:31

4on6
Member
Registered: 2011-10-05
Posts: 166

Re: [SOLVED] ghc: could not satisfy dependencies

akuschki wrote:

Eh? My whole haskell shebang exists for one reason:

$ yaourt -Ss haskell-pandoc
haskell/haskell-pandoc 1.8.2.1-10 [installed]

In Arch, installing pandoc via cabal (http://www.archlinux.org/packages/extra … l-install/) seems to be the least painful way in my experience. YMMV.

Exactly! I tried it without cabal and quickly learned what the term "dependency hell" really means ...

Offline

#24 2012-03-06 16:16:21

simeon
Member
Registered: 2012-03-06
Posts: 1

Re: [SOLVED] ghc: could not satisfy dependencies

I removed pandoc and all the self-made dependencies:

pacman -R haskell-pandoc haskell-pandoc-types haskell-citeproc-hs haskell-base64-bytestring haskell-digest haskell-dlist haskell-hs-bibutils haskell-json haskell-tagsoup haskell-xml haskell-zip-archive

and then I still could not upgrade the system because of:

root@pandora:/home/simeon# pacman -Su

...
Error: ...
ghc: /usr/share/doc/ghc/html/libraries/doc-index-126.html exists on filesystem

So I did

rm /usr/share/doc/ghc/html/libraries/doc-index-126.html

Now I could upgrade my System.

@4on6: Well, on debian I ran in many more depency hells, especially when an unrelated package required an older version of a library I wanted to install. That's hell...

Offline

#25 2012-03-06 16:49:22

Xyne
Moderator/TU
Registered: 2008-08-03
Posts: 5,644
Website

Re: [SOLVED] ghc: could not satisfy dependencies

For those of you not following the arch-haskell mailing list, [ghc74] will be updated tonight at which point I think it will contain all of the Haskell packages from [extra] and [community], minus the broken dependency chains. The repo will be rebuilt topologically with each update so this kind of breakage should be avoided in the future with that repo.

Rejoice, my Haskell brethren, and heap praise upon brother Magnus, for he shall lead us out of dependency hell and into the light!

Offline

Board footer

Powered by FluxBB