You are not logged in.

#1 2005-08-09 04:47:57

omniwolf
Member
From: mechanical Engineering student
Registered: 2004-12-11
Posts: 17

voice chat in ut2k4 won't work [not solved yet]

I have already tried the following resources:

http://www.linux-gamers.net/modules/wfs … ticleid=34

http://www.thehaus.net/Tips/UT/ut2004icculusfaq.shtml

my ~/.openalrc:

 Contains user settings for OpenAL
; Which backend?  Tried in order of appearance.
;(define devices '(native alsa sdl esd arts null))
(define devices '(alsa sdl esd))

; Four speaker surround with ALSA.
(define speaker-num 2)
;(define alsa-out-device "surround40:0,0")
(define alsa-out-device "hw:0,0")

; For alsa-in support. Mainly for using voice chat.
(define alsa-in-device "hw:1,0")
;hw:1,0 because i use my second sound card to record on many programs (ie audacity) bc emu10k1 only records the sound out not mic.

; Some drivers do not support select.
;(define native-use-select ;t)

symptoms:

sound works great, clear and not laggy at all. i have all the voice chat keys  mapped and all the good voice chat options enabled. everytime i press a key that chats, either teamchat or public-chat the sound gets sort quiet (like it's supposed to, to avoid feedback). the problem is nobody hears me at all, not even a "turn up you volume dude!" or "what was that?!"

hardware wink

amd 3200 64-bit winchester
nvidia 6800 256
2gb ocz 2-3-2-5
250 gb sata hd linux drive
160 gb windows drive
water cooling #complete unecessary i know : )
audigy gamer # works with emu10k1 fine no recording though
chaintech zenith VE nforce 4 with 7 channel audio using  snd_intel8x0 module since nvsound only does oss

Offline

#2 2005-08-09 17:23:32

aCoder
Member
From: Medina, OH
Registered: 2004-03-07
Posts: 359
Website

Re: voice chat in ut2k4 won't work [not solved yet]

; For alsa-in support. Mainly for using voice chat.
(define alsa-in-device "hw:1,0")
;hw:1,0 because i use my second sound card to record on many programs (ie audacity) bc emu10k1 only records the sound out not mic.

Maybe it would help to troubleshoot emu10k1, and use the Audigy instead.

What works for me:

alsamixer -V all[quote]

That should show a bunch of recording-related-ish stuff as well as the usual, try turning them up.[/quote]

If you develop an ear for sounds that are musical it is like developing an ego. You begin to refuse sounds that are not musical and that way cut yourself off from a good deal of experience.
  - John Cage

Offline

#3 2005-08-09 22:33:09

shadowhand
Member
From: MN, USA
Registered: 2004-02-19
Posts: 1,142
Website

Re: voice chat in ut2k4 won't work [not solved yet]

Did you turn on your mic? (No, I'm not kidding, I've had that issue before. 8) )

Try using alsamixer and turning up the mic volume and turn on mic boost (+25 dbi). Also, you have to modprobe snd-pcm-oss and symlink /dev/sound/dsp to /dev/dsp (this is done automagically with udev when you modprove snd-pcm-oss in the proper order, as follows).

MODULES line in rc.conf (non-sound stuff taken out):

MODULES=( snd-pcm-oss soundcore snd-seq snd-emu10k1)

My .openalrc:

(define devices '(alsa))

(define alsa-in-device "hw:0,0")
(define alsa-out-device "hw:0,0")

·¬»· i am shadowhand, powered by webfaction

Offline

#4 2005-08-10 03:20:20

omniwolf
Member
From: mechanical Engineering student
Registered: 2004-12-11
Posts: 17

Re: voice chat in ut2k4 won't work [not solved yet]

didn't know about the -v option for alsamixer, i had always used aumix turned up the mic but with the -v option i see that mic was up like i had set it but mic-capture was off. i can't believe i missed that! i'm trying it now....

Offline

#5 2005-08-11 03:58:13

omniwolf
Member
From: mechanical Engineering student
Registered: 2004-12-11
Posts: 17

Re: voice chat in ut2k4 won't work [not solved yet]

thanks for the previous replies!

┌──────────────────[AlsaMixer v1.0.9a (Press Escape to quit)]──────────────────┐
│ Card: Audigy 1 or 2 [Unknown]                                                │
│ Chip: SB Audigy                                                              │
│ View:  Playback [Capture] All                                                │
│ Item: PCM                                                                    │
│                                                                              │
│                                                                              │
│                                                                              │
│                                                                              │
│                                                                              │
│    ┌──┐     ┌──┐      ┌──┐     ┌──┐     ┌──┐      ┌──┐     ┌──┐     ┌──┐     │
│    │  │     │  │      │  │     │  │     │  │      │  │     │▒▒│     │▒▒│     │
│    │  │     │  │      │▒▒│     │  │     │▒▒│      │  │     │▒▒│     │▒▒│     │
│    │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│     │
│    │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│     │
│    │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│     │
│    │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│     │
│    │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│     │
│    │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│     │
│    │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│     │
│    │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│     │
│    │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│     │
│    │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│     │
│    │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│     │
│    │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│     │
│    │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│     │
│    │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│     │
│    │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│     │
│    │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│     │
│    │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│     │
│    │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│     │
│    └──┘     └──┘      └──┘     └──┘     └──┘      └──┘     └──┘     └──┘     │
│                                                                              │
│   86<>86   90<>90    91<>91   88<>88   94<>94    88<>88   96<>96   96<>96    │
│ <  PCM   > Synth      Line      CD      Mic     IEC958 O   Aux    Analog M   │
│                                                                              │
│                                                                              │
│                                                                              │
│                                                                              │
└──────────────────────────────────────────────────────────────────────────────┘

this is what i see on "alsamixer -V capture" i turned on the mic capture and encreased it's volume. still the same syptoms persist in any recording app set to use the audigy gamer. no matter where i plug in the mic the app only records the outgoing sounds from the sound servers and apps but never the mic.


btw: on all distros my kmix has never had anything in the input tab, (no record sources) when you click mixer in the tray of kde.

Offline

#6 2005-08-11 07:20:49

Moo-Crumpus
Member
From: Hessen / Germany
Registered: 2003-12-01
Posts: 1,441

Re: voice chat in ut2k4 won't work [not solved yet]

aCoder wrote:

Maybe it would help to troubleshoot emu10k1, and use the Audigy instead.

There is an audigy module, is there?


Frumpus addict
[mu'.krum.pus], [frum.pus]

Offline

#7 2005-08-11 23:02:03

omniwolf
Member
From: mechanical Engineering student
Registered: 2004-12-11
Posts: 17

Re: voice chat in ut2k4 won't work [not solved yet]

yeah the emu10k1 module

Offline

Board footer

Powered by FluxBB