You are not logged in.

#26 2012-03-09 14:51:15

L0cutus
Member
Registered: 2005-11-17
Posts: 24

Re: "eclipse and xulrunner are in conflict"?

:-/

Required By   : aptana-studio  firefox-aurora-bin-it

Offline

#27 2012-03-10 17:45:27

cro
Member
From: Germany
Registered: 2006-01-02
Posts: 101

Re: "eclipse and xulrunner are in conflict"?

I've the same problem.
Although I currently have no packages requiring xulrunner, I find it odd, to be forced to remove such a basic package (it is a runtime environment for everything based on XUL, isn't it?). What if I want to write software using XUL?
Is this just a workround because of a bug from upstream (in eclipse)? Will this conflict disappear once the bug is fixed?

Offline

#28 2012-03-16 04:53:25

wucan
Member
From: China
Registered: 2011-12-09
Posts: 6

Re: "eclipse and xulrunner are in conflict"?

see the conflict when I install npapi-vlc-git.

Offline

#29 2012-03-16 07:46:39

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: "eclipse and xulrunner are in conflict"?

wucan wrote:

see the conflict when I install npapi-vlc-git.

makedepends is wrong. xulrunner can be replaced with npapi-sdk and nothing will conflict. Please report this in comments on that specific build


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#30 2012-04-07 16:14:58

JohnnyAce
Member
Registered: 2009-08-09
Posts: 22

Re: "eclipse and xulrunner are in conflict"?

I'm also having this problem while trying to install evolus pencil from AUR. http://aur.archlinux.org/packages.php?ID=32614

Offline

#31 2012-04-27 01:48:45

timseal
Member
Registered: 2010-03-30
Posts: 6

Re: "eclipse and xulrunner are in conflict"?

wonder wrote:
wucan wrote:

see the conflict when I install npapi-vlc-git.

makedepends is wrong. xulrunner can be replaced with npapi-sdk and nothing will conflict. Please report this in comments on that specific build

I had the same problem with the vlc plugin, tried your fix and it works nicely. I reported it in the comments.
Thanks.

Offline

#32 2012-05-09 20:31:39

Kastrovolus
Member
From: Schleswig-Holstein, Germany
Registered: 2011-05-13
Posts: 2

Re: "eclipse and xulrunner are in conflict"?

I needed xulrunner and Eclipse to run Eclipse-PDT and its tooltips. So, for all those with the same problem:

I removed the xulrunner-Package and installed this package from AUR: https://aur.archlinux.org/packages.php?ID=53282
This perfectly worked.

Offline

#33 2012-06-04 21:31:18

BluntObjectNo4
Member
Registered: 2012-01-23
Posts: 8

Re: "eclipse and xulrunner are in conflict"?

I also have the conflict, but for me modelio-open from AUR (http://aur.archlinux.org/packages.php?ID=58681) requires xulrunner which conflicts with eclipse...

Offline

#34 2012-09-24 20:27:17

pirj
Member
From: Phuket, Thailand
Registered: 2011-11-24
Posts: 19

Re: "eclipse and xulrunner are in conflict"?

My success story:

I had eclipse, and i need it.
I needed evolus-pencil, which requires xulrunner.

I downloaded http://ftp.mozilla.org/pub/mozilla.org/ … 86.tar.bz2
unzipped it to ~/.xulrunner

Added to .bashrc:
PATH=$PATH:$HOME/.xulrunner

UPD:
aurget -S evolus-pencil-svn

Edit PKGBUILD and comment out depends=(xulrunner)
END UPD

I've edited /usr/lib/evolus-pencil-svn/app/application.ini to have MaxVersion=15.*

and everything works fine, including these popup hints in eclipse.

Last edited by pirj (2012-09-27 09:08:06)

Offline

#35 2012-09-28 10:41:50

ckpinguin
Member
Registered: 2012-09-08
Posts: 4

Re: "eclipse and xulrunner are in conflict"?

The problem is not restricted to mono, also for example evolus-pencil-svn needs xulrunner. The mentioned post ist not a solution, it's not even a workaround. But I don't have a better one yet ;-) so it looks like we gonna have to install Eclipse manually *sigh*...

Offline

#36 2012-09-28 22:35:28

mrunion
Member
From: Jonesborough, TN
Registered: 2007-01-26
Posts: 1,571
Website

Re: "eclipse and xulrunner are in conflict"?

FYI, you can download the evolus pencil xpi from their website, install it in firefox and run it with out xulrunner installed at all.


Matt

"It is very difficult to educate the educated."

Offline

#37 2012-11-28 13:00:27

flying sheep
Member
Registered: 2012-02-29
Posts: 79

Re: "eclipse and xulrunner are in conflict"?

the bug here is that tehre is no way to tell pacman that it can safely install a makedepend temporarily, since the conflict is only about the presence of the package, not actually files present in multiple packages.

so what we need is a way to say “those packages are conflicting, but the conflict can be ignored for short periods of time (e.g. makedepends)”

what i will do now:

1. download the xulrunner package
2. give it another packagename (e.g. xulrunner-fuckyou)
3. change the makedependency of globalmenu-extension to xulrunner-fuckyou
4. uninstall xulrunner-fuckyou

Last edited by flying sheep (2012-11-28 13:16:51)

Offline

#38 2013-03-01 20:22:59

teekay
Member
Registered: 2011-10-26
Posts: 270

Re: "eclipse and xulrunner are in conflict"?

I guess the solution is to provide a xulrunner 1.9.2 package (there is one in AUR) and set the MOZILLA_FIVE_HOME variable correctly in eclipse startup script. Might require a wrapper.

I didn't care enough to find out - but stumbled over the same issue trying to run a 3rd party vendor's eclipse-based client app on my Arch workstation which had xulrunner installed (without having it installed it complained about MOZILLA_FIVE_HOME being unset)

Offline

Board footer

Powered by FluxBB